summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-08-24 23:44:08 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-08-27 10:16:52 +0800
commite2705425ba27840af7dc40c16ad4f4f4dd972fbc (patch)
tree2c738f817deb6c3edb546ef2ced16dab4d45b244
parentfae3212a314636f51278dfb29e6e5f827abba1c8 (diff)
downloadmeta-intel-e2705425ba27840af7dc40c16ad4f4f4dd972fbc.tar.gz
cryptodev: remove patch for 4.13+ kernels
This fix is in OE-core rocko now and isn't needed here anymore. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--common/recipes-kernel/cryptodev/cryptodev-module/0001-ioctl.c-Fix-build-with-linux-4.13.patch51
-rw-r--r--common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend2
2 files changed, 0 insertions, 53 deletions
diff --git a/common/recipes-kernel/cryptodev/cryptodev-module/0001-ioctl.c-Fix-build-with-linux-4.13.patch b/common/recipes-kernel/cryptodev/cryptodev-module/0001-ioctl.c-Fix-build-with-linux-4.13.patch
deleted file mode 100644
index a013d8d7..00000000
--- a/common/recipes-kernel/cryptodev/cryptodev-module/0001-ioctl.c-Fix-build-with-linux-4.13.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From f0d69774afb27ffc62bf353465fba145e70cb85a Mon Sep 17 00:00:00 2001
2From: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
3Date: Mon, 4 Sep 2017 11:05:08 +0200
4Subject: [PATCH] ioctl.c: Fix build with linux 4.13
5
6git/ioctl.c:1127:3: error: positional initialization of field in 'struct' declared with 'designated_init' attribute [-Werror=designated-init]
7 {0, },
8 ^
9note: (near initialization for 'verbosity_ctl_dir[1]')
10git/ioctl.c:1136:3: error: positional initialization of field in 'struct' declared with 'designated_init' attribute [-Werror=designated-init]
11 {0, },
12 ^
13
14Linux kernel has added -Werror=designated-init around 4.11 (c834f0e8a8b)
15triggering build errors with gcc 5 and 6 (but not with gcc 4)
16
17Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
18Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
19
20Upstream-Status: Backport [https://github.com/cryptodev-linux/cryptodev-linux/commit/f0d69774afb27ffc62bf353465fba145e70cb85a]
21
22Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
23---
24 ioctl.c | 4 ++--
25 1 file changed, 2 insertions(+), 2 deletions(-)
26
27diff --git a/ioctl.c b/ioctl.c
28index 0385203..8d4a162 100644
29--- a/ioctl.c
30+++ b/ioctl.c
31@@ -1124,7 +1124,7 @@ static struct ctl_table verbosity_ctl_dir[] = {
32 .mode = 0644,
33 .proc_handler = proc_dointvec,
34 },
35- {0, },
36+ {},
37 };
38
39 static struct ctl_table verbosity_ctl_root[] = {
40@@ -1133,7 +1133,7 @@ static struct ctl_table verbosity_ctl_root[] = {
41 .mode = 0555,
42 .child = verbosity_ctl_dir,
43 },
44- {0, },
45+ {},
46 };
47 static struct ctl_table_header *verbosity_sysctl_header;
48 static int __init init_cryptodev(void)
49--
502.17.1
51
diff --git a/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend b/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
index b5b56f01..c59ddb2f 100644
--- a/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
+++ b/common/recipes-kernel/cryptodev/cryptodev-module_%.bbappend
@@ -1,7 +1,5 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_intel-x86-common = " file://0001-ioctl.c-Fix-build-with-linux-4.13.patch"
4
5python() { 3python() {
6 # When we add more kernels for linux-intel, we may have to add a Version check 4 # When we add more kernels for linux-intel, we may have to add a Version check
7 if (d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel"): 5 if (d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel"):