summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-10-07 15:16:36 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-10-07 16:07:27 +0800
commitdbae24f5bb5c133958439b9943f59f77a4c368f1 (patch)
treeceee03593b798c469e3cccd7ad396e4bde3a2877
parent68a4077bdd98cbb4d6e3dd3fd6b30f2bb69366a0 (diff)
downloadmeta-intel-dbae24f5bb5c133958439b9943f59f77a4c368f1.tar.gz
libva-intel: add recipe
We need a later version of libva than what is available in oe-core for the media components. Create our own copy of the recipe and include it only when someone has included one of meta-intel MACHINEs. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--conf/layer.conf6
-rw-r--r--conf/machine/include/meta-intel.inc5
-rw-r--r--recipes-graphics/libva/libva-intel_2.9.0.bb54
3 files changed, 65 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index fcfdf2a7..6e9d86e8 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -34,3 +34,9 @@ require ${LAYERDIR}/conf/include/maintainers.inc
34PREFERRED_PROVIDER_zlib ?= "zlib" 34PREFERRED_PROVIDER_zlib ?= "zlib"
35PREFERRED_PROVIDER_zlib-native ?= "zlib-native" 35PREFERRED_PROVIDER_zlib-native ?= "zlib-native"
36PREFERRED_PROVIDER_nativesdk-zlib ?= "nativesdk-zlib" 36PREFERRED_PROVIDER_nativesdk-zlib ?= "nativesdk-zlib"
37
38# Use the libva from OE-Core when layer is included but no MACHINE
39# from meta-intel is being used.
40PREFERRED_PROVIDER_libva ?= "libva"
41PREFERRED_PROVIDER_libva-native ?= "libva-native"
42PREFERRED_PROVIDER_nativesdk-libva ?= "nativesdk-libva"
diff --git a/conf/machine/include/meta-intel.inc b/conf/machine/include/meta-intel.inc
index 932c0cc1..86c94878 100644
--- a/conf/machine/include/meta-intel.inc
+++ b/conf/machine/include/meta-intel.inc
@@ -17,6 +17,11 @@ PREFERRED_VERSION_linux-intel-rt ?= "5.4%"
17PREFERRED_VERSION_linux-intel_poky-altcfg ?= "5.4%" 17PREFERRED_VERSION_linux-intel_poky-altcfg ?= "5.4%"
18PREFERRED_VERSION_linux-intel-rt_poky-altcfg ?= "5.4%" 18PREFERRED_VERSION_linux-intel-rt_poky-altcfg ?= "5.4%"
19 19
20# Need to point to latest version of libva needed for media components
21PREFERRED_PROVIDER_libva = "libva-intel"
22PREFERRED_PROVIDER_libva-native = "libva-intel-native"
23PREFERRED_PROVIDER_nativesdk-libva = "nativesdk-libva-intel"
24
20XSERVER_X86_ASPEED_AST = "xf86-video-ast \ 25XSERVER_X86_ASPEED_AST = "xf86-video-ast \
21 " 26 "
22 27
diff --git a/recipes-graphics/libva/libva-intel_2.9.0.bb b/recipes-graphics/libva/libva-intel_2.9.0.bb
new file mode 100644
index 00000000..620a1f01
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel_2.9.0.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2"
21SRC_URI[sha256sum] = "e344c1392dde92696c9ffd9cb3c7277d0a3b912236eb4e0fdedf7f375434584b"
22
23S = "${WORKDIR}/libva-${PV}"
24
25UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
26
27DEPENDS = "libdrm"
28
29inherit meson pkgconfig
30
31PACKAGECONFIG ??= " \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
34"
35
36PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
37PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
38
39PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
40
41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
42
43RDEPENDS_${PN}-x11 =+ "${PN}"
44RDEPENDS_${PN}-glx =+ "${PN}-x11"
45
46FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
49
50PROVIDES += "libva"
51RPROVIDES_${PN} += "libva"
52RPROVIDES_${PN}-x11 += "libva-x11"
53RPROVIDES_${PN}-glx += "libva-glx"
54RPROVIDES_${PN}-wayland += "libva-wayland"