summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-08-23 08:51:26 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-08-24 12:48:08 +0800
commitd731daf575036e4b09b6bf6fa22443c438e3975e (patch)
tree0cc7431fab165f24b649ceb45a37de6492e18453
parent87d4088ecff5c07ddb0b2764bd4c2cee8803685a (diff)
downloadmeta-intel-d731daf575036e4b09b6bf6fa22443c438e3975e.tar.gz
openvino-inference-engine: upgrade 2022.1 -> 2022.1.1
Enable an option that's is available now to use TBB from system and refresh patches accordingly. This version also switches to using system installed OpenCV and Intel version is not included. Release notes: https://github.com/openvinotoolkit/openvino/releases/tag/2022.1.1 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch132
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch54
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.1.1.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.1.bb)7
3 files changed, 48 insertions, 145 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
index 315385d8..60285eec 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
@@ -1,30 +1,27 @@
1From b0f30ab7ecdac98afa72a31371a393a73f855b3c Mon Sep 17 00:00:00 2001 1From d997ee70a49cee8a577a81968c1d603a97bc614f Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 7 Apr 2022 21:39:26 +0800 3Date: Thu, 7 Apr 2022 21:39:26 +0800
4Subject: [PATCH] Use system installed dependencies 4Subject: [PATCH] Use system installed dependencies
5 5
6Use the system versions of libva, tbb, OpenCV, ade and zlib. 6Use the system versions of libva, ade and zlib.
7 7
8Upstream-Status: Inappropriate 8Upstream-Status: Inappropriate
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10
11--- 10---
12 cmake/dependencies.cmake | 75 ------------------------- 11 cmake/dependencies.cmake | 20 --------------------
13 cmake/extra_modules.cmake | 4 +- 12 cmake/extra_modules.cmake | 4 ++--
14 cmake/templates/OpenVINOConfig.cmake.in | 9 --- 13 src/plugins/intel_gpu/include/va/va.h | 6 ------
15 src/cmake/ie_parallel.cmake | 2 +- 14 tests/fuzz/src/CMakeLists.txt | 3 +--
16 src/plugins/intel_gpu/include/va/va.h | 6 -- 15 thirdparty/CMakeLists.txt | 26 ++++++++++----------------
17 tests/fuzz/src/CMakeLists.txt | 3 +- 16 thirdparty/cnpy/CMakeLists.txt | 2 +-
18 thirdparty/CMakeLists.txt | 26 ++++----- 17 6 files changed, 14 insertions(+), 47 deletions(-)
19 thirdparty/cnpy/CMakeLists.txt | 2 +-
20 8 files changed, 15 insertions(+), 112 deletions(-)
21 delete mode 100644 src/plugins/intel_gpu/include/va/va.h 18 delete mode 100644 src/plugins/intel_gpu/include/va/va.h
22 19
23diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake 20diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
24index e2f941fcd..1fcc358ef 100644 21index 106af36c7d..45a3214100 100644
25--- a/cmake/dependencies.cmake 22--- a/cmake/dependencies.cmake
26+++ b/cmake/dependencies.cmake 23+++ b/cmake/dependencies.cmake
27@@ -29,26 +29,6 @@ endif() 24@@ -27,26 +27,6 @@ get_linux_name(LINUX_OS_NAME)
28 25
29 if(CMAKE_CROSSCOMPILING AND CMAKE_HOST_SYSTEM_NAME MATCHES Linux AND CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*") 26 if(CMAKE_CROSSCOMPILING AND CMAKE_HOST_SYSTEM_NAME MATCHES Linux AND CMAKE_HOST_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
30 set(protoc_version "3.18.2") 27 set(protoc_version "3.18.2")
@@ -51,70 +48,8 @@ index e2f941fcd..1fcc358ef 100644
51 endif() 48 endif()
52 49
53 if(ENABLE_INTEL_MYRIAD) 50 if(ENABLE_INTEL_MYRIAD)
54@@ -102,61 +82,6 @@ if(THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
55 set(IE_PATH_TO_DEPS "${THIRDPARTY_SERVER_PATH}")
56 endif()
57
58- if(WIN32 AND X86_64)
59- # TODO: add target_path to be platform specific as well, to avoid following if
60- RESOLVE_DEPENDENCY(TBB
61- ARCHIVE_WIN "tbb2020_20200415_win.zip"
62- TARGET_PATH "${TEMP}/tbb"
63- ENVIRONMENT "TBBROOT"
64- SHA256 "f1c9b9e2861efdaa01552bd25312ccbc5feeb45551e5f91ae61e29221c5c1479")
65- if(ENABLE_TBBBIND_2_5)
66- RESOLVE_DEPENDENCY(TBBBIND_2_5
67- ARCHIVE_WIN "tbbbind_2_5_static_win_v1.zip"
68- TARGET_PATH "${TEMP}/tbbbind_2_5"
69- ENVIRONMENT "TBBBIND_2_5_ROOT"
70- SHA256 "a67afeea8cf194f97968c800dab5b5459972908295242e282045d6b8953573c1")
71- else()
72- message(WARNING "prebuilt TBBBIND_2_5 is not available.
73- Build oneTBB from sources and set TBBROOT environment var before OpenVINO cmake configure")
74- endif()
75- elseif(ANDROID) # Should be before LINUX due LINUX is detected as well
76- RESOLVE_DEPENDENCY(TBB
77- ARCHIVE_ANDROID "tbb2020_20200404_android.tgz"
78- TARGET_PATH "${TEMP}/tbb"
79- ENVIRONMENT "TBBROOT"
80- SHA256 "f42d084224cc2d643314bd483ad180b081774608844000f132859fca3e9bf0ce")
81- elseif(LINUX AND X86_64)
82- RESOLVE_DEPENDENCY(TBB
83- ARCHIVE_LIN "tbb2020_20200415_lin_strip.tgz"
84- TARGET_PATH "${TEMP}/tbb"
85- ENVIRONMENT "TBBROOT"
86- SHA256 "95b2f3b0b70c7376a0c7de351a355c2c514b42c4966e77e3e34271a599501008")
87- if(ENABLE_TBBBIND_2_5)
88- RESOLVE_DEPENDENCY(TBBBIND_2_5
89- ARCHIVE_LIN "tbbbind_2_5_static_lin_v2.tgz"
90- TARGET_PATH "${TEMP}/tbbbind_2_5"
91- ENVIRONMENT "TBBBIND_2_5_ROOT"
92- SHA256 "865e7894c58402233caf0d1b288056e0e6ab2bf7c9d00c9dc60561c484bc90f4")
93- else()
94- message(WARNING "prebuilt TBBBIND_2_5 is not available.
95- Build oneTBB from sources and set TBBROOT environment var before OpenVINO cmake configure")
96- endif()
97- elseif(LINUX AND AARCH64)
98- RESOLVE_DEPENDENCY(TBB
99- ARCHIVE_LIN "keembay/tbb2020_38404_kmb_lic.tgz"
100- TARGET_PATH "${TEMP}/tbb_yocto"
101- ENVIRONMENT "TBBROOT"
102- SHA256 "321261ff2eda6d4568a473cb883262bce77a93dac599f7bd65d2918bdee4d75b")
103- elseif(APPLE AND X86_64)
104- RESOLVE_DEPENDENCY(TBB
105- ARCHIVE_MAC "tbb2020_20200404_mac.tgz"
106- TARGET_PATH "${TEMP}/tbb"
107- ENVIRONMENT "TBBROOT"
108- SHA256 "ad9cf52e657660058aa6c6844914bc0fc66241fec89a392d8b79a7ff69c3c7f6")
109- else()
110- message(FATAL_ERROR "TBB is not available on current platform")
111- endif()
112-
113 update_deps_cache(TBBROOT "${TBB}" "Path to TBB root folder")
114 if(EXISTS "${TBBROOT}/lib/cmake/TBB/TBBConfig.cmake")
115 # oneTBB case
116diff --git a/cmake/extra_modules.cmake b/cmake/extra_modules.cmake 51diff --git a/cmake/extra_modules.cmake b/cmake/extra_modules.cmake
117index e33e4378f..f0cacdf6f 100644 52index e33e4378f1..f0cacdf6ff 100644
118--- a/cmake/extra_modules.cmake 53--- a/cmake/extra_modules.cmake
119+++ b/cmake/extra_modules.cmake 54+++ b/cmake/extra_modules.cmake
120@@ -18,7 +18,7 @@ function(ie_generate_dev_package_config) 55@@ -18,7 +18,7 @@ function(ie_generate_dev_package_config)
@@ -135,42 +70,9 @@ index e33e4378f..f0cacdf6f 100644
135 NO_CHECK_REQUIRED_COMPONENTS_MACRO) 70 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
136 71
137 configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cmake.in" 72 configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cmake.in"
138diff --git a/cmake/templates/OpenVINOConfig.cmake.in b/cmake/templates/OpenVINOConfig.cmake.in
139index 00e892f2b..7c686fa07 100644
140--- a/cmake/templates/OpenVINOConfig.cmake.in
141+++ b/cmake/templates/OpenVINOConfig.cmake.in
142@@ -146,15 +146,6 @@ set(_ov_package_prefix_dir "${PACKAGE_PREFIX_DIR}")
143
144 set(THREADING "@THREADING@")
145 if((THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO") AND NOT TBB_FOUND)
146- set_and_check(_tbb_dir "@PACKAGE_IE_TBB_DIR@")
147- _ov_find_dependency(TBB
148- COMPONENTS tbb tbbmalloc
149- CONFIG
150- PATHS ${TBBROOT}/cmake
151- ${_tbb_dir}
152- NO_CMAKE_FIND_ROOT_PATH
153- NO_DEFAULT_PATH)
154-
155 set(install_tbbbind "@install_tbbbind@")
156 if(install_tbbbind)
157 set_and_check(_tbb_bind_dir "@PACKAGE_IE_TBBBIND_DIR@")
158diff --git a/src/cmake/ie_parallel.cmake b/src/cmake/ie_parallel.cmake
159index a036b019c..031f1ea48 100644
160--- a/src/cmake/ie_parallel.cmake
161+++ b/src/cmake/ie_parallel.cmake
162@@ -34,7 +34,7 @@ function(set_ie_threading_interface_for TARGET_NAME)
163 endforeach()
164 endif()
165 set(TBB_FOUND ${TBB_FOUND} PARENT_SCOPE)
166- set(TBB_IMPORTED_TARGETS ${TBB_IMPORTED_TARGETS} PARENT_SCOPE)
167+ set(TBB_IMPORTED_TARGETS "tbb;tbbmalloc" PARENT_SCOPE)
168 set(TBB_VERSION ${TBB_VERSION} PARENT_SCOPE)
169 if (NOT TBB_FOUND)
170 set(THREADING "SEQ" PARENT_SCOPE)
171diff --git a/src/plugins/intel_gpu/include/va/va.h b/src/plugins/intel_gpu/include/va/va.h 73diff --git a/src/plugins/intel_gpu/include/va/va.h b/src/plugins/intel_gpu/include/va/va.h
172deleted file mode 100644 74deleted file mode 100644
173index 5c8a5c6f6..000000000 75index 5c8a5c6f6e..0000000000
174--- a/src/plugins/intel_gpu/include/va/va.h 76--- a/src/plugins/intel_gpu/include/va/va.h
175+++ /dev/null 77+++ /dev/null
176@@ -1,6 +0,0 @@ 78@@ -1,6 +0,0 @@
@@ -181,7 +83,7 @@ index 5c8a5c6f6..000000000
181-typedef cl_uint VASurfaceID; 83-typedef cl_uint VASurfaceID;
182-typedef void* VADisplay; 84-typedef void* VADisplay;
183diff --git a/tests/fuzz/src/CMakeLists.txt b/tests/fuzz/src/CMakeLists.txt 85diff --git a/tests/fuzz/src/CMakeLists.txt b/tests/fuzz/src/CMakeLists.txt
184index 5e6b7b168..a81c51bb7 100644 86index 5e6b7b168e..a81c51bb77 100644
185--- a/tests/fuzz/src/CMakeLists.txt 87--- a/tests/fuzz/src/CMakeLists.txt
186+++ b/tests/fuzz/src/CMakeLists.txt 88+++ b/tests/fuzz/src/CMakeLists.txt
187@@ -10,14 +10,13 @@ add_custom_target(fuzz) 89@@ -10,14 +10,13 @@ add_custom_target(fuzz)
@@ -201,7 +103,7 @@ index 5e6b7b168..a81c51bb7 100644
201 add_dependencies(fuzz ${test_name}) 103 add_dependencies(fuzz ${test_name})
202 104
203diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 105diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
204index 2d61c5fd7..97b372998 100644 106index 2d61c5fd7a..97b372998a 100644
205--- a/thirdparty/CMakeLists.txt 107--- a/thirdparty/CMakeLists.txt
206+++ b/thirdparty/CMakeLists.txt 108+++ b/thirdparty/CMakeLists.txt
207@@ -12,10 +12,9 @@ endif() 109@@ -12,10 +12,9 @@ endif()
@@ -279,7 +181,7 @@ index 2d61c5fd7..97b372998 100644
279 endforeach() 181 endforeach()
280 endif() 182 endif()
281diff --git a/thirdparty/cnpy/CMakeLists.txt b/thirdparty/cnpy/CMakeLists.txt 183diff --git a/thirdparty/cnpy/CMakeLists.txt b/thirdparty/cnpy/CMakeLists.txt
282index 041031e92..793de9845 100644 184index 041031e923..793de9845c 100644
283--- a/thirdparty/cnpy/CMakeLists.txt 185--- a/thirdparty/cnpy/CMakeLists.txt
284+++ b/thirdparty/cnpy/CMakeLists.txt 186+++ b/thirdparty/cnpy/CMakeLists.txt
285@@ -13,7 +13,7 @@ if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang$") 187@@ -13,7 +13,7 @@ if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang$")
@@ -292,5 +194,5 @@ index 041031e92..793de9845 100644
292 194
293 set_target_properties(${TARGET_NAME} PROPERTIES FOLDER thirdparty) 195 set_target_properties(${TARGET_NAME} PROPERTIES FOLDER thirdparty)
294-- 196--
2952.35.1 1972.36.1
296 198
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
index 9e2b46fd..f80e45f8 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
@@ -1,4 +1,4 @@
1From 07772636ef9b7207967395d22a869e204e8f485b Mon Sep 17 00:00:00 2001 1From 5b6c285b5398fd29cc541ccf92e13440537bb5e8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 11 Apr 2022 11:11:23 +0800 3Date: Mon, 11 Apr 2022 11:11:23 +0800
4Subject: [PATCH] Fix installation of binaries and libraries 4Subject: [PATCH] Fix installation of binaries and libraries
@@ -31,10 +31,10 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31 19 files changed, 37 insertions(+), 32 deletions(-) 31 19 files changed, 37 insertions(+), 32 deletions(-)
32 32
33diff --git a/CMakeLists.txt b/CMakeLists.txt 33diff --git a/CMakeLists.txt b/CMakeLists.txt
34index fe62c6318..344d9398f 100644 34index beb0214284..c9ffa7fcae 100644
35--- a/CMakeLists.txt 35--- a/CMakeLists.txt
36+++ b/CMakeLists.txt 36+++ b/CMakeLists.txt
37@@ -104,7 +104,7 @@ include(cmake/extra_modules.cmake) 37@@ -106,7 +106,7 @@ include(cmake/extra_modules.cmake)
38 add_subdirectory(docs) 38 add_subdirectory(docs)
39 add_subdirectory(tools) 39 add_subdirectory(tools)
40 add_subdirectory(scripts) 40 add_subdirectory(scripts)
@@ -44,7 +44,7 @@ index fe62c6318..344d9398f 100644
44 # 44 #
45 # CPack 45 # CPack
46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake 46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
47index 39b23fe65..aa638c077 100644 47index 39b23fe655..aa638c0778 100644
48--- a/cmake/developer_package/frontends/frontends.cmake 48--- a/cmake/developer_package/frontends/frontends.cmake
49+++ b/cmake/developer_package/frontends/frontends.cmake 49+++ b/cmake/developer_package/frontends/frontends.cmake
50@@ -2,7 +2,7 @@ 50@@ -2,7 +2,7 @@
@@ -57,7 +57,7 @@ index 39b23fe65..aa638c077 100644
57 set(FRONTEND_NAME_SUFFIX "_frontend") 57 set(FRONTEND_NAME_SUFFIX "_frontend")
58 58
59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake 59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake
60index cc287ff1f..2daee6611 100644 60index cc287ff1f3..2daee6611e 100644
61--- a/cmake/developer_package/packaging.cmake 61--- a/cmake/developer_package/packaging.cmake
62+++ b/cmake/developer_package/packaging.cmake 62+++ b/cmake/developer_package/packaging.cmake
63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir) 63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir)
@@ -72,7 +72,7 @@ index cc287ff1f..2daee6611 100644
72 endif() 72 endif()
73 endfunction() 73 endfunction()
74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake 74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake
75index a630d6c35..779c43631 100644 75index a630d6c354..779c43631a 100644
76--- a/cmake/developer_package/plugins/plugins.cmake 76--- a/cmake/developer_package/plugins/plugins.cmake
77+++ b/cmake/developer_package/plugins/plugins.cmake 77+++ b/cmake/developer_package/plugins/plugins.cmake
78@@ -138,7 +138,7 @@ function(ie_add_plugin) 78@@ -138,7 +138,7 @@ function(ie_add_plugin)
@@ -85,7 +85,7 @@ index a630d6c35..779c43631 100644
85 else() 85 else()
86 ov_install_static_lib(${IE_PLUGIN_NAME} ${install_component}) 86 ov_install_static_lib(${IE_PLUGIN_NAME} ${install_component})
87diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt 87diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
88index 86b0e8652..4f31d3cc4 100644 88index 86b0e8652b..4f31d3cc4b 100644
89--- a/docs/CMakeLists.txt 89--- a/docs/CMakeLists.txt
90+++ b/docs/CMakeLists.txt 90+++ b/docs/CMakeLists.txt
91@@ -36,9 +36,10 @@ if(NOT ENABLE_DOCKER) 91@@ -36,9 +36,10 @@ if(NOT ENABLE_DOCKER)
@@ -101,7 +101,7 @@ index 86b0e8652..4f31d3cc4 100644
101 endforeach() 101 endforeach()
102 endif() 102 endif()
103diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt 103diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
104index 8101b5e32..6abe8c20c 100644 104index 8101b5e328..6abe8c20ce 100644
105--- a/samples/CMakeLists.txt 105--- a/samples/CMakeLists.txt
106+++ b/samples/CMakeLists.txt 106+++ b/samples/CMakeLists.txt
107@@ -9,7 +9,7 @@ add_subdirectory(c) 107@@ -9,7 +9,7 @@ add_subdirectory(c)
@@ -114,7 +114,7 @@ index 8101b5e32..6abe8c20c 100644
114 114
115 openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils) 115 openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils)
116diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt 116diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
117index a8e6e5172..aa3d2fe0e 100644 117index 2755579a0f..4a5f5b424f 100644
118--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt 118--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
119+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt 119+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
120@@ -34,3 +34,5 @@ install( 120@@ -34,3 +34,5 @@ install(
@@ -124,7 +124,7 @@ index a8e6e5172..aa3d2fe0e 100644
124+ 124+
125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}) 125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
127index 3433dee0e..0c0fa0723 100644 127index 9a73582a73..70c4147f3f 100644
128--- a/samples/cpp/CMakeLists.txt 128--- a/samples/cpp/CMakeLists.txt
129+++ b/samples/cpp/CMakeLists.txt 129+++ b/samples/cpp/CMakeLists.txt
130@@ -222,6 +222,8 @@ macro(ie_add_sample) 130@@ -222,6 +222,8 @@ macro(ie_add_sample)
@@ -137,7 +137,7 @@ index 3433dee0e..0c0fa0723 100644
137 if(NOT TARGET ie_samples) 137 if(NOT TARGET ie_samples)
138 add_custom_target(ie_samples ALL) 138 add_custom_target(ie_samples ALL)
139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt 139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
140index 9ad26ba95..0853e2370 100644 140index 9ad26ba952..0853e23706 100644
141--- a/scripts/CMakeLists.txt 141--- a/scripts/CMakeLists.txt
142+++ b/scripts/CMakeLists.txt 142+++ b/scripts/CMakeLists.txt
143@@ -28,7 +28,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}" 143@@ -28,7 +28,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}"
@@ -168,7 +168,7 @@ index 9ad26ba95..0853e2370 100644
168 install(DIRECTORY install_dependencies/ 168 install(DIRECTORY install_dependencies/
169 DESTINATION install_dependencies 169 DESTINATION install_dependencies
170diff --git a/src/bindings/c/src/CMakeLists.txt b/src/bindings/c/src/CMakeLists.txt 170diff --git a/src/bindings/c/src/CMakeLists.txt b/src/bindings/c/src/CMakeLists.txt
171index 9200d0bda..b3636e071 100644 171index 9200d0bda1..b3636e0716 100644
172--- a/src/bindings/c/src/CMakeLists.txt 172--- a/src/bindings/c/src/CMakeLists.txt
173+++ b/src/bindings/c/src/CMakeLists.txt 173+++ b/src/bindings/c/src/CMakeLists.txt
174@@ -43,8 +43,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets 174@@ -43,8 +43,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
@@ -183,7 +183,7 @@ index 9200d0bda..b3636e071 100644
183+ DESTINATION include/ie 183+ DESTINATION include/ie
184 COMPONENT core_c_dev) 184 COMPONENT core_c_dev)
185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake 185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake
186index c46548468..3d65a20a5 100644 186index ddd016d14e..76db0f9927 100644
187--- a/src/cmake/openvino.cmake 187--- a/src/cmake/openvino.cmake
188+++ b/src/cmake/openvino.cmake 188+++ b/src/cmake/openvino.cmake
189@@ -59,8 +59,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets 189@@ -59,8 +59,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
@@ -197,7 +197,7 @@ index c46548468..3d65a20a5 100644
197 197
198 # --------------- OpenVINO runtime library dev ------------------------------ 198 # --------------- OpenVINO runtime library dev ------------------------------
199 add_library(${TARGET_NAME}_dev INTERFACE) 199 add_library(${TARGET_NAME}_dev INTERFACE)
200@@ -96,7 +96,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components}) 200@@ -95,7 +95,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components})
201 201
202 if(BUILD_SHARED_LIBS) 202 if(BUILD_SHARED_LIBS)
203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml 203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
@@ -206,7 +206,7 @@ index c46548468..3d65a20a5 100644
206 COMPONENT core) 206 COMPONENT core)
207 207
208 # for InferenceEngineUnitTest 208 # for InferenceEngineUnitTest
209@@ -115,7 +115,7 @@ endif() 209@@ -114,7 +114,7 @@ endif()
210 install(EXPORT OpenVINOTargets 210 install(EXPORT OpenVINOTargets
211 FILE OpenVINOTargets.cmake 211 FILE OpenVINOTargets.cmake
212 NAMESPACE openvino:: 212 NAMESPACE openvino::
@@ -214,8 +214,8 @@ index c46548468..3d65a20a5 100644
214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO 214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
215 COMPONENT core_dev) 215 COMPONENT core_dev)
216 216
217 set(OV_CORE_DIR "${CMAKE_BINARY_DIR}/src/core") 217 # Build tree
218@@ -161,10 +161,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm 218@@ -160,10 +160,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm
219 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake" 219 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake"
220 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake" 220 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake"
221 "${OpenVINO_SOURCE_DIR}/src/cmake/ie_parallel.cmake" 221 "${OpenVINO_SOURCE_DIR}/src/cmake/ie_parallel.cmake"
@@ -229,7 +229,7 @@ index c46548468..3d65a20a5 100644
229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO 229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
230 COMPONENT core_dev) 230 COMPONENT core_dev)
231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt 231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt
232index e41e286c9..11aaffca6 100644 232index e41e286c95..11aaffca6a 100644
233--- a/src/common/preprocessing/CMakeLists.txt 233--- a/src/common/preprocessing/CMakeLists.txt
234+++ b/src/common/preprocessing/CMakeLists.txt 234+++ b/src/common/preprocessing/CMakeLists.txt
235@@ -202,7 +202,7 @@ openvino_developer_export_targets(COMPONENT core TARGETS ${TARGET_NAME}) 235@@ -202,7 +202,7 @@ openvino_developer_export_targets(COMPONENT core TARGETS ${TARGET_NAME})
@@ -242,7 +242,7 @@ index e41e286c9..11aaffca6 100644
242 ov_install_static_lib(${TARGET_NAME} core) 242 ov_install_static_lib(${TARGET_NAME} core)
243 endif() 243 endif()
244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt 244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
245index cc64b94ca..5f0dcf20c 100644 245index cc64b94ca3..5f0dcf20cf 100644
246--- a/src/core/CMakeLists.txt 246--- a/src/core/CMakeLists.txt
247+++ b/src/core/CMakeLists.txt 247+++ b/src/core/CMakeLists.txt
248@@ -114,7 +114,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_ 248@@ -114,7 +114,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_
@@ -262,10 +262,10 @@ index cc64b94ca..5f0dcf20c 100644
262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph 262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
263 COMPONENT core_dev) 263 COMPONENT core_dev)
264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt 264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt
265index ddd2fdcbc..f4ad1e623 100644 265index 767fbc1b81..f279a2ef7d 100644
266--- a/src/inference/CMakeLists.txt 266--- a/src/inference/CMakeLists.txt
267+++ b/src/inference/CMakeLists.txt 267+++ b/src/inference/CMakeLists.txt
268@@ -204,7 +204,7 @@ set_target_properties(${TARGET_NAME}_obj 268@@ -209,7 +209,7 @@ set_target_properties(${TARGET_NAME}_obj
269 269
270 openvino_developer_export_targets(COMPONENT core_legacy TARGETS ${TARGET_NAME}_plugin_api) 270 openvino_developer_export_targets(COMPONENT core_legacy TARGETS ${TARGET_NAME}_plugin_api)
271 271
@@ -275,7 +275,7 @@ index ddd2fdcbc..f4ad1e623 100644
275 275
276 # Install static libraries for case BUILD_SHARED_LIBS=OFF 276 # Install static libraries for case BUILD_SHARED_LIBS=OFF
277diff --git a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt 277diff --git a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
278index 3993bd973..99287bad5 100644 278index 3993bd9731..99287bad51 100644
279--- a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt 279--- a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
280+++ b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt 280+++ b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
281@@ -94,7 +94,7 @@ add_custom_command( 281@@ -94,7 +94,7 @@ add_custom_command(
@@ -288,7 +288,7 @@ index 3993bd973..99287bad5 100644
288 288
289 ov_install_static_lib(${TARGET_NAME} gpu) 289 ov_install_static_lib(${TARGET_NAME} gpu)
290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake 290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake
291index 5bba4235f..69c1470a7 100644 291index 5bba4235ff..69c1470a71 100644
292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake 292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake
293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake 293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake
294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES) 294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES)
@@ -301,7 +301,7 @@ index 5bba4235f..69c1470a7 100644
301 301
302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS) 302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS)
303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
304index 12a2f15e4..893146294 100644 304index 12a2f15e4a..893146294c 100644
305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL 307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL
@@ -313,7 +313,7 @@ index 12a2f15e4..893146294 100644
313 COMPONENT myriad) 313 COMPONENT myriad)
314 endif() 314 endif()
315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt 315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
316index c8638f7fd..ba30641c5 100644 316index c8638f7fd3..ba30641c5a 100644
317--- a/tools/CMakeLists.txt 317--- a/tools/CMakeLists.txt
318+++ b/tools/CMakeLists.txt 318+++ b/tools/CMakeLists.txt
319@@ -20,7 +20,7 @@ endif() 319@@ -20,7 +20,7 @@ endif()
@@ -326,7 +326,7 @@ index c8638f7fd..ba30641c5 100644
326 USE_SOURCE_PERMISSIONS) 326 USE_SOURCE_PERMISSIONS)
327 327
328diff --git a/tools/compile_tool/CMakeLists.txt b/tools/compile_tool/CMakeLists.txt 328diff --git a/tools/compile_tool/CMakeLists.txt b/tools/compile_tool/CMakeLists.txt
329index d19eb5cc1..9fc929cbb 100644 329index d19eb5cc14..9fc929cbb0 100644
330--- a/tools/compile_tool/CMakeLists.txt 330--- a/tools/compile_tool/CMakeLists.txt
331+++ b/tools/compile_tool/CMakeLists.txt 331+++ b/tools/compile_tool/CMakeLists.txt
332@@ -38,9 +38,9 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME}) 332@@ -38,9 +38,9 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
@@ -344,5 +344,5 @@ index d19eb5cc1..9fc929cbb 100644
344+# DESTINATION tools/compile_tool 344+# DESTINATION tools/compile_tool
345+# COMPONENT core_tools) 345+# COMPONENT core_tools)
346-- 346--
3472.35.1 3472.36.1
348 348
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.1.1.bb
index 4595835f..8acd72f7 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.1.1.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \ 4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic." 5integrated with application logic."
6 6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/1;lfs=0 \ 7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/1.1;lfs=0 \
8 https://download.01.org/opencv/master/openvinotoolkit/thirdparty/unified/VPU/usb-ma2x8x/firmware_usb-ma2x8x_1875.zip;name=usb_ma2x8x \ 8 https://download.01.org/opencv/master/openvinotoolkit/thirdparty/unified/VPU/usb-ma2x8x/firmware_usb-ma2x8x_1875.zip;name=usb_ma2x8x \
9 https://download.01.org/opencv/master/openvinotoolkit/thirdparty/unified/VPU/pcie-ma2x8x/firmware_pcie-ma2x8x_1875.zip;name=pcie_ma2x8x \ 9 https://download.01.org/opencv/master/openvinotoolkit/thirdparty/unified/VPU/pcie-ma2x8x/firmware_pcie-ma2x8x_1875.zip;name=pcie_ma2x8x \
10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/mkl-dnn;name=mkl;nobranch=1 \ 10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/mkl-dnn;name=mkl;nobranch=1 \
@@ -20,7 +20,7 @@ SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=r
20 file://cython-cmake.patch \ 20 file://cython-cmake.patch \
21 " 21 "
22 22
23SRCREV = "cdb9bec7210f8c24fde3e416c7ada820faaaa23e" 23SRCREV = "39aba80957e10b66a6c8f3f590c2d90e8238ca75"
24SRCREV_mkl = "82ca2f931c1d588b67d154d873136d4af1ffb3a8" 24SRCREV_mkl = "82ca2f931c1d588b67d154d873136d4af1ffb3a8"
25SRCREV_onednn = "9e2bf22e51726ad36ddae90c7caf2898d124baa6" 25SRCREV_onednn = "9e2bf22e51726ad36ddae90c7caf2898d124baa6"
26SRCREV_xbyak = "8d1e41b650890080fb77548372b6236bbd4079f9" 26SRCREV_xbyak = "8d1e41b650890080fb77548372b6236bbd4079f9"
@@ -28,7 +28,7 @@ SRCREV_pybind11 = "d71ba0cb73616c493d35699a8a9283aa64ef0f6b"
28SRCREV_protobuf = "6c6b0778b70f35f93c2f0dee30e5d12ad2a83eea" 28SRCREV_protobuf = "6c6b0778b70f35f93c2f0dee30e5d12ad2a83eea"
29SRCREV_json = "fec56a1a16c6e1c1b1f4e116a20e79398282626c" 29SRCREV_json = "fec56a1a16c6e1c1b1f4e116a20e79398282626c"
30SRCREV_jsonschema = "b1ef8628326cf0b53612f12784fd245e5e4382f1" 30SRCREV_jsonschema = "b1ef8628326cf0b53612f12784fd245e5e4382f1"
31SRCREV_omz = "cf9003a95ddb742aabea341aa1573c3fa25ebbe1" 31SRCREV_omz = "0c94071faef095f544a228f8455718fbd653950e"
32 32
33SRC_URI[usb_ma2x8x.sha256sum] = "e65fcc1c6b0f3e9d814e53022c212ec0a2b83197a9df38badb298fb85ccf3acf" 33SRC_URI[usb_ma2x8x.sha256sum] = "e65fcc1c6b0f3e9d814e53022c212ec0a2b83197a9df38badb298fb85ccf3acf"
34SRC_URI[pcie_ma2x8x.sha256sum] = "b11368fec2036d96fb703d2a40b171184fefe89f27e74a988ef1ca34260a2bc5" 34SRC_URI[pcie_ma2x8x.sha256sum] = "b11368fec2036d96fb703d2a40b171184fefe89f27e74a988ef1ca34260a2bc5"
@@ -54,6 +54,7 @@ EXTRA_OECMAKE += " \
54 -DOpenCV_DIR=${STAGING_LIBDIR}/cmake \ 54 -DOpenCV_DIR=${STAGING_LIBDIR}/cmake \
55 -DENABLE_PLUGIN_RPATH=0 \ 55 -DENABLE_PLUGIN_RPATH=0 \
56 -DENABLE_INTEL_GNA=OFF \ 56 -DENABLE_INTEL_GNA=OFF \
57 -DENABLE_SYSTEM_TBB=ON \
57 -DPYTHON_EXECUTABLE=${PYTHON} \ 58 -DPYTHON_EXECUTABLE=${PYTHON} \
58 -DCMAKE_BUILD_TYPE=RelWithDebInfo \ 59 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
59 -DTHREADING=TBB -DTBB_DIR="${STAGING_LIBDIR}/cmake/TBB" \ 60 -DTHREADING=TBB -DTBB_DIR="${STAGING_LIBDIR}/cmake/TBB" \