summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-06-26 10:24:05 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-06-26 11:54:15 +0800
commitc4e2039ca6b0e9506db55b91797bfdceb1c64853 (patch)
tree936f3dac6d9d317a91dc0229c742726e1c4b2def
parentb69d444dc9b9df3608918a1130fd60a7a42c6633 (diff)
downloadmeta-intel-c4e2039ca6b0e9506db55b91797bfdceb1c64853.tar.gz
libxcam: upgrade 1.3.0 -> 1.4.0
Created and submitted a patch to fix header path. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch37
-rw-r--r--recipes-core/libxcam/libxcam_1.4.0.bb (renamed from recipes-core/libxcam/libxcam_1.3.0.bb)6
2 files changed, 40 insertions, 3 deletions
diff --git a/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch b/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch
new file mode 100644
index 00000000..67db3e4c
--- /dev/null
+++ b/recipes-core/libxcam/libxcam/0001-test-soft-image.cpp-fix-header-path.patch
@@ -0,0 +1,37 @@
1From 8f8a1d131a05aa1494825f0fae32580cbed680e5 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 25 Jun 2020 14:22:59 +0800
4Subject: [PATCH] test-soft-image.cpp: fix header path
5
6throw compilation error:
7 | ../../git/tests/test-soft-image.cpp:31:10: fatal error: xcore/fisheye_dewarp.h: No such file or directory
8| 31 | #include <xcore/fisheye_dewarp.h>
9| | ^~~~~~~~~~~~~~~~~~~~~~~~
10| compilation terminated.
11
12TEST_BASE_CXXFLAGS already includes -I$(top_srcdir)/xcore
13
14Ref: https://github.com/intel/libxcam/blob/1.4.0/tests/Makefile.am#L48
15
16Upstream-Status: Submitted [https://github.com/intel/libxcam/pull/734]
17Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
18---
19 tests/test-soft-image.cpp | 2 +-
20 1 file changed, 1 insertion(+), 1 deletion(-)
21
22diff --git a/tests/test-soft-image.cpp b/tests/test-soft-image.cpp
23index a9e02d8..1c687e5 100644
24--- a/tests/test-soft-image.cpp
25+++ b/tests/test-soft-image.cpp
26@@ -28,7 +28,7 @@
27 #include <interface/blender.h>
28 #include <interface/geo_mapper.h>
29 #include <interface/stitcher.h>
30-#include <xcore/fisheye_dewarp.h>
31+#include <fisheye_dewarp.h>
32
33 #define MAP_WIDTH 3
34 #define MAP_HEIGHT 4
35--
362.17.1
37
diff --git a/recipes-core/libxcam/libxcam_1.3.0.bb b/recipes-core/libxcam/libxcam_1.4.0.bb
index 7bfcacde..987f94ee 100644
--- a/recipes-core/libxcam/libxcam_1.3.0.bb
+++ b/recipes-core/libxcam/libxcam_1.4.0.bb
@@ -7,9 +7,9 @@ SECTION = "lib"
7inherit autotools pkgconfig 7inherit autotools pkgconfig
8 8
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10SRCREV = "90f386c44fdfc550d0c81697cf070b3249bef4dd" 10SRCREV = "e0d740f0706f7902d4f262b649d42b1b48c5e4e3"
11SRC_URI = "git://github.com/intel/libxcam.git;branch=1.3.0 \ 11SRC_URI = "git://github.com/intel/libxcam.git;branch=1.4.0; \
12 " 12 file://0001-test-soft-image.cpp-fix-header-path.patch"
13 13
14COMPATIBLE_HOST_libc-musl = "null" 14COMPATIBLE_HOST_libc-musl = "null"
15 15