summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2022-09-01 11:43:30 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-09-05 17:05:57 +0800
commitc12abbd33fd00f219fdc4d6f253be2a6c3b6b7c6 (patch)
treed84b6697800db181738abf62c751c523714e2cdd
parent0337f4a8fc8156db6b8f84b814a3d00cb4f3c5d3 (diff)
downloadmeta-intel-c12abbd33fd00f219fdc4d6f253be2a6c3b6b7c6.tar.gz
ipmctl : upgrade 03.00.00.0439 -> 03.00.00.0462
Release notes: https://github.com/intel/ipmctl/releases/tag/v03.00.00.0462 Drops upstreamed patch: * 227d9cb35658fe104ff6fde62e4a00e6d595df0d.patch Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/227d9cb35658fe104ff6fde62e4a00e6d595df0d.patch128
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0462.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0439.bb)5
2 files changed, 2 insertions, 131 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/227d9cb35658fe104ff6fde62e4a00e6d595df0d.patch b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/227d9cb35658fe104ff6fde62e4a00e6d595df0d.patch
deleted file mode 100644
index a6e83617..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/227d9cb35658fe104ff6fde62e4a00e6d595df0d.patch
+++ /dev/null
@@ -1,128 +0,0 @@
1From 227d9cb35658fe104ff6fde62e4a00e6d595df0d Mon Sep 17 00:00:00 2001
2From: Adam Borowski <kilobyte@angband.pl>
3Date: Sat, 25 Jun 2022 20:35:35 +0200
4Subject: [PATCH] Drop unused queries for block size, fixing build with new
5 kernels
6
7Quoting Linux commit f8669f1d6a86a6b17104ceca9340ded280307ac1:
8
9> Block Aperture Window support was an attempt to layer an error model
10> over PMEM for platforms that did not support machine-check-recovery.
11> However, it was abandoned before it ever shipped, and only ever existed
12> in the ACPI specification. Meanwhile Linux has carried a large pile of
13> dead code for non-shipping infrastructure. [...]
14
15We fetched block sizes but never used that info for anything. Now that
16the required defines have been dropped in kernel 5.18, let's purge that
17code.
18
19Signed-off-by: Adam Borowski <adam.borowski@intel.com>
20
21Upstream-Status: Submitted
22Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
23---
24 src/os/linux/lnx_system.c | 56 ---------------------------------------
25 src/os/os.h | 2 --
26 src/os/win/win_system.c | 2 --
27 3 files changed, 60 deletions(-)
28
29diff --git a/src/os/linux/lnx_system.c b/src/os/linux/lnx_system.c
30index a2903d8b..d2ad3c1f 100644
31--- a/src/os/linux/lnx_system.c
32+++ b/src/os/linux/lnx_system.c
33@@ -315,61 +315,6 @@ int os_get_os_type()
34 return OS_TYPE_LINUX;
35 }
36
37-int get_supported_block_sizes(struct nvm_driver_capabilities *p_capabilities)
38-{
39- int rc = NVM_SUCCESS;
40- int found = 0;
41- struct ndctl_ctx *ctx;
42-
43- p_capabilities->num_block_sizes = 0;
44-
45- if ((rc = ndctl_new(&ctx)) >= 0)
46- {
47- struct ndctl_bus *bus;
48- ndctl_bus_foreach(ctx, bus)
49- {
50- struct ndctl_region *region;
51- ndctl_region_foreach(bus, region)
52- {
53- int nstype = ndctl_region_get_nstype(region);
54- if (ndctl_region_is_enabled(region) &&
55- (nstype == ND_DEVICE_NAMESPACE_BLK))
56- {
57- struct ndctl_namespace *namespace;
58- ndctl_namespace_foreach(region, namespace)
59- {
60- p_capabilities->num_block_sizes =
61- ndctl_namespace_get_num_sector_sizes(namespace);
62-
63- for (int i = 0; i < p_capabilities->num_block_sizes; i++)
64- {
65- p_capabilities->block_sizes[i] =
66- ndctl_namespace_get_supported_sector_size(namespace, i);
67- }
68- found = 1;
69- break;
70- }
71- }
72- if (found)
73- {
74- break;
75- }
76- }
77- if (found)
78- {
79- break;
80- }
81- }
82- ndctl_unref(ctx);
83- }
84- else
85- {
86- rc = linux_err_to_nvm_lib_err(rc);
87- }
88-
89- return rc;
90-}
91-
92 int os_get_driver_capabilities(struct nvm_driver_capabilities *p_capabilities)
93 {
94 p_capabilities->features.get_platform_capabilities = 1;
95@@ -399,7 +344,6 @@ int os_get_driver_capabilities(struct nvm_driver_capabilities *p_capabilities)
96 p_capabilities->features.app_direct_mode = 1;
97
98 p_capabilities->min_namespace_size = ndctl_min_namespace_size();
99- get_supported_block_sizes(p_capabilities);
100 p_capabilities->namespace_memory_page_allocation_capable = 1;
101 return 0;
102 }
103diff --git a/src/os/os.h b/src/os/os.h
104index 736904de..e5a08bcd 100644
105--- a/src/os/os.h
106+++ b/src/os/os.h
107@@ -66,8 +66,6 @@ struct driver_feature_flags
108
109 struct nvm_driver_capabilities
110 {
111- unsigned int block_sizes[MAX_NUMBER_OF_BLOCK_SIZES]; // in bytes
112- unsigned int num_block_sizes;
113 unsigned long long min_namespace_size; // in bytes
114 unsigned int namespace_memory_page_allocation_capable;
115 struct driver_feature_flags features;
116diff --git a/src/os/win/win_system.c b/src/os/win/win_system.c
117index 0c18cf0e..4d840333 100644
118--- a/src/os/win/win_system.c
119+++ b/src/os/win/win_system.c
120@@ -830,8 +830,6 @@ int os_get_driver_capabilities(struct nvm_driver_capabilities *p_capabilities)
121 memset(p_capabilities, 0, sizeof(struct nvm_driver_capabilities));
122
123 p_capabilities->min_namespace_size = BYTES_PER_GIB;
124- p_capabilities->num_block_sizes = 1;
125- p_capabilities->block_sizes[0] = 1;
126
127 p_capabilities->namespace_memory_page_allocation_capable = 0;
128 p_capabilities->features.get_platform_capabilities = 1;
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0439.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0462.bb
index 7bf0cb70..11e4f285 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0439.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0462.bb
@@ -19,12 +19,11 @@ SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=development;n
19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2;branch=master \ 19 git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2;branch=master \
20 file://0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch;patchdir=edk2 \ 20 file://0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch;patchdir=edk2 \
21 file://0001-CMakeLists-disable-Werror.patch \ 21 file://0001-CMakeLists-disable-Werror.patch \
22 file://227d9cb35658fe104ff6fde62e4a00e6d595df0d.patch \
23" 22"
24 23
25SRCREV_ipmctl = "8a73a975e2501c9baa6e4b1fb9101b40a227d084" 24SRCREV_ipmctl = "e332e3048f3884bb3719f61cf72aaf85f32d2090"
26#tag edk2-stable202205 25#tag edk2-stable202205
27SRCREV_edk2 = "16779ede2d366bfc6b702e817356ccf43425bcc8" 26SRCREV_edk2 = "ba0e0e4c6a174b71b18ccd6e47319cc45878893c"
28 27
29S = "${WORKDIR}/git" 28S = "${WORKDIR}/git"
30 29