summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-01-21 14:57:03 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-01-23 14:05:01 -0600
commitb966b769aa388dc3cdce4bb1f68c987647b922ca (patch)
treea1f4d3b6b45598a41c67f18ac30bc1a322831841
parent0b2a42bab3cc720d3b787b17d21d172d67b4a751 (diff)
downloadmeta-intel-b966b769aa388dc3cdce4bb1f68c987647b922ca.tar.gz
emenlow: use emgd 1.16 driver for graphics
Move from 1.14 version to 1.16 version of the emgd driver for graphics support. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-emenlow/README6
-rw-r--r--meta-emenlow/conf/machine/emenlow.conf2
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend4
3 files changed, 6 insertions, 6 deletions
diff --git a/meta-emenlow/README b/meta-emenlow/README
index b8b42107..6cc06fe6 100644
--- a/meta-emenlow/README
+++ b/meta-emenlow/README
@@ -83,7 +83,7 @@ common metadata shared between BSPs) e.g.:
83 yocto/meta-intel/meta-emenlow \ 83 yocto/meta-intel/meta-emenlow \
84 84
85The meta-emenlow layer contains support for the 'emenlow' machine 85The meta-emenlow layer contains support for the 'emenlow' machine
86configuration, which makes use of the Intel-proprietary EMGD 1.14 86configuration, which makes use of the Intel-proprietary EMGD 1.16
87graphics driver. 87graphics driver.
88 88
89To enable the emenlow layer, add the emenlow MACHINE to local.conf: 89To enable the emenlow layer, add the emenlow MACHINE to local.conf:
@@ -92,10 +92,10 @@ To enable the emenlow layer, add the emenlow MACHINE to local.conf:
92 92
93The 'emenlow' machine includes the emgd-driver-bin package, which has 93The 'emenlow' machine includes the emgd-driver-bin package, which has
94a proprietary license that must be whitelisted by adding the string 94a proprietary license that must be whitelisted by adding the string
95"license_emgd-driver-bin_1.14" to the LICENSE_FLAGS_WHITELIST variable 95"license_emgd-driver-bin_1.16" to the LICENSE_FLAGS_WHITELIST variable
96in your local.conf. For example: 96in your local.conf. For example:
97 97
98 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.14" 98 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16"
99 99
100You should then be able to build an emenlow image as such: 100You should then be able to build an emenlow image as such:
101 101
diff --git a/meta-emenlow/conf/machine/emenlow.conf b/meta-emenlow/conf/machine/emenlow.conf
index dc9fde8d..a3c40869 100644
--- a/meta-emenlow/conf/machine/emenlow.conf
+++ b/meta-emenlow/conf/machine/emenlow.conf
@@ -22,7 +22,7 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
22PREFERRED_VERSION_xserver-xorg ?= "1.9.3" 22PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
23PREFERRED_VERSION_mesa-dri ?= "7.11" 23PREFERRED_VERSION_mesa-dri ?= "7.11"
24PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0" 24PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
25PREFERRED_VERSION_emgd-driver-bin ?= "1.14" 25PREFERRED_VERSION_emgd-driver-bin ?= "1.16"
26 26
27APPEND += "video=vesafb vga=0x318 vmalloc=256MB" 27APPEND += "video=vesafb vga=0x318 vmalloc=256MB"
28 28
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
index d3700240..3eff5dd8 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_emenlow = "emenlow" 3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd cfg/vesafb" 6KERNEL_FEATURES_emenlow_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7 7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd" 8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow" 9KMACHINE_emenlow-noemgd = "emenlow"
@@ -17,4 +17,4 @@ SRCREV_emgd_pn-linux-yocto_emenlow ?= "${AUTOREV}"
17SRCREV_machine_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}" 17SRCREV_machine_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}"
18SRCREV_meta_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}" 18SRCREV_meta_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}"
19 19
20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.14;name=machine,meta,emgd" 20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"