summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-03-17 09:24:17 -0700
committerTom Zanussi <tom.zanussi@intel.com>2014-03-26 22:42:14 -0500
commitb3614d762b40930b57680bf2a81b8068f1067d50 (patch)
tree130feefb9ad856c7ecbc54a5834487e8f1c9c209
parent8d79fb4e0cec07fe05ca440578414eaa6be80a3a (diff)
downloadmeta-intel-b3614d762b40930b57680bf2a81b8068f1067d50.tar.gz
common linux-yocto-3.10: specify kernel SRCREVs
Define the kernel branch SRCREVs in meta-intel layer, so that other layers can not break the common BSP kernel unknowingly. Using the latest HEADs of the git branches for SRCREVs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Reviewed-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 01e3f77b..650919f6 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -2,18 +2,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5#LINUX_VERSION_core2-32-intel-common = "3.10" 5LINUX_VERSION_core2-32-intel-common = "3.10.33"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7#SRCREV_meta_core2-32-intel-common = "${AUTOREV}" 7SRCREV_meta_core2-32-intel-common = "99c503a92885060bebf2bba6747735e8e9346a40"
8#SRCREV_machine_core2-32-intel-common = "${AUTOREV}" 8SRCREV_machine_core2-32-intel-common = "21df0c8486e129a4087970a07b423c533ae05de7"
9KMACHINE_core2-32-intel-common = "intel-core2-32" 9KMACHINE_core2-32-intel-common = "intel-core2-32"
10KBRANCH_core2-32-intel-common = "standard/base" 10KBRANCH_core2-32-intel-common = "standard/base"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12 12
13#LINUX_VERSION_corei7-64-intel-common = "3.10" 13LINUX_VERSION_corei7-64-intel-common = "3.10.33"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15#SRCREV_meta_corei7-64-intel-common = "${AUTOREV}" 15SRCREV_meta_corei7-64-intel-common = "99c503a92885060bebf2bba6747735e8e9346a40"
16#SRCREV_machine_corei7-64-intel-common = "${AUTOREV}" 16SRCREV_machine_corei7-64-intel-common = "21df0c8486e129a4087970a07b423c533ae05de7"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_intel-corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"