summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-07-21 16:55:25 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-07-22 12:32:46 +0800
commitae7f71a65d1ca3dd9bea3384fec693fc5e70bddf (patch)
treefc229cc1a4e0fd67a81d34d9123a4b2a1807422a
parent085ba92a5930e841362b2294f7b6869e21697cd5 (diff)
downloadmeta-intel-ae7f71a65d1ca3dd9bea3384fec693fc5e70bddf.tar.gz
llvm-project-source: drop llvm9 support
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-dont-export-targets-for-binaries.patch68
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch51
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend28
3 files changed, 6 insertions, 141 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-dont-export-targets-for-binaries.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-dont-export-targets-for-binaries.patch
deleted file mode 100644
index da2475f9..00000000
--- a/dynamic-layers/clang-layer/recipes-devtools/clang/files/0001-dont-export-targets-for-binaries.patch
+++ /dev/null
@@ -1,68 +0,0 @@
1From 559fb8f82295ec4dc64a132b6566939b85c1b6fe Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 15 Aug 2019 22:34:31 +0800
4Subject: [PATCH] dont export targets for binaries
5
6The projects using LLVM cmake modules look for target binaries in
7sysroot as a result which isn't desirable in this case and isn't needed
8either.
9
10Upstream-Status: Inappropriate [cross-compile specific]
11
12Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
13Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
14---
15 llvm/cmake/modules/AddLLVM.cmake | 9 ---------
16 llvm/cmake/modules/TableGen.cmake | 6 ------
17 2 files changed, 15 deletions(-)
18
19diff --git a/llvm/cmake/modules/AddLLVM.cmake b/llvm/cmake/modules/AddLLVM.cmake
20index 619e986b8aa..d2bc1a25dd9 100644
21--- a/llvm/cmake/modules/AddLLVM.cmake
22+++ b/llvm/cmake/modules/AddLLVM.cmake
23@@ -898,12 +898,6 @@ macro(add_llvm_tool name)
24
25 if ( ${name} IN_LIST LLVM_TOOLCHAIN_TOOLS OR NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
26 if( LLVM_BUILD_TOOLS )
27- set(export_to_llvmexports)
28- if(${name} IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
29- NOT LLVM_DISTRIBUTION_COMPONENTS)
30- set(export_to_llvmexports EXPORT LLVMExports)
31- set_property(GLOBAL PROPERTY LLVM_HAS_EXPORTS True)
32- endif()
33
34 install(TARGETS ${name}
35 ${export_to_llvmexports}
36@@ -917,9 +911,6 @@ macro(add_llvm_tool name)
37 endif()
38 endif()
39 endif()
40- if( LLVM_BUILD_TOOLS )
41- set_property(GLOBAL APPEND PROPERTY LLVM_EXPORTS ${name})
42- endif()
43 set_target_properties(${name} PROPERTIES FOLDER "Tools")
44 endmacro(add_llvm_tool name)
45
46diff --git a/llvm/cmake/modules/TableGen.cmake b/llvm/cmake/modules/TableGen.cmake
47index 36c026b5c0f..537acd696d8 100644
48--- a/llvm/cmake/modules/TableGen.cmake
49+++ b/llvm/cmake/modules/TableGen.cmake
50@@ -148,15 +148,9 @@ macro(add_tablegen target project)
51 endif()
52
53 if (${project} STREQUAL LLVM AND NOT LLVM_INSTALL_TOOLCHAIN_ONLY AND LLVM_BUILD_UTILS)
54- set(export_to_llvmexports)
55- if(${target} IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
56- NOT LLVM_DISTRIBUTION_COMPONENTS)
57- set(export_to_llvmexports EXPORT LLVMExports)
58- endif()
59
60 install(TARGETS ${target}
61 ${export_to_llvmexports}
62 RUNTIME DESTINATION ${LLVM_TOOLS_INSTALL_DIR})
63 endif()
64- set_property(GLOBAL APPEND PROPERTY LLVM_EXPORTS ${target})
65 endmacro()
66--
672.17.1
68
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
deleted file mode 100644
index 9a7b8445..00000000
--- a/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm9-skip-building-tests.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 48e50f06b1bbed94cdf5207587161d4bfce7366e Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 21 Aug 2019 14:35:31 +0800
4Subject: [PATCH] llvm-spirv: skip building tests
5
6Some of these need clang to be built and since we're building this in-tree,
7that leads to problems when compiling libcxx, compiler-rt which aren't built
8in-tree.
9
10Instead of using SPIRV_SKIP_CLANG_BUILD to skip clang build and adding this to
11all components, disable the building of tests altogether.
12
13Upstream-Status: Inappropriate
14
15Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
16Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
17---
18 CMakeLists.txt | 10 ----------
19 1 file changed, 10 deletions(-)
20
21diff --git a/CMakeLists.txt b/CMakeLists.txt
22index 1208741..20ca3e6 100644
23--- a/CMakeLists.txt
24+++ b/CMakeLists.txt
25@@ -15,13 +15,6 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
26 set(CMAKE_CXX_STANDARD 11)
27 set(CMAKE_CXX_STANDARD_REQUIRED ON)
28
29- if(LLVM_INCLUDE_TESTS)
30- set(LLVM_TEST_COMPONENTS
31- llvm-as
32- llvm-dis
33- )
34- endif(LLVM_INCLUDE_TESTS)
35-
36 find_package(LLVM 9.0.0 REQUIRED
37 COMPONENTS
38 Analysis
39@@ -56,9 +49,6 @@ set(LLVM_SPIRV_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include)
40
41 add_subdirectory(lib/SPIRV)
42 add_subdirectory(tools/llvm-spirv)
43-if(LLVM_INCLUDE_TESTS)
44- add_subdirectory(test)
45-endif(LLVM_INCLUDE_TESTS)
46
47 install(
48 FILES
49--
502.17.1
51
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend b/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
index b4afb329..4c05b659 100644
--- a/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
+++ b/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
@@ -1,27 +1,11 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/files:" 1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/files:"
2 2
3SPIRV_BRANCH = "${@bb.utils.contains('LLVMVERSION', '9.0.1', 'llvm_release_90', 'llvm_release_100', d)}"
4
5SPIRV9_SRCREV = "70420631144a6a25613ae37178f2cc1d3607b65b"
6SPIRV10_SRCREV = "4d43f68a30a510b4e7607351caab3df8e7426a6b"
7SPIRV_SRCREV = "${@bb.utils.contains('LLVMVERSION', '9.0.1', '${SPIRV9_SRCREV}', '${SPIRV10_SRCREV}', d)}"
8
9LLVM_RECOMMENDED_PATCHES = " file://BasicBlockUtils-Add-metadata-fixing-in-SplitBlockPre.patch;patchdir=llvm \
10 file://IndVarSimplify-Do-not-use-SCEV-expander-for-IVCount-.patch;patchdir=llvm \
11 "
12
13LLVM9_PATCH_LIST = " file://0001-dont-export-targets-for-binaries.patch \
14 file://llvm9-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \
15 ${LLVM_RECOMMENDED_PATCHES} \
16 "
17LLVM10_PATCH_LIST = " file://llvm10-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \
18 file://fix-shared-libs.patch;patchdir=llvm/projects/llvm-spirv \
19 ${LLVM_RECOMMENDED_PATCHES} \
20 "
21
22SRC_URI_append_intel-x86-common = " \ 3SRC_URI_append_intel-x86-common = " \
23 git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=${SPIRV_BRANCH};destsuffix=git/llvm/projects/llvm-spirv;name=spirv \ 4 git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=llvm_release_100;destsuffix=git/llvm/projects/llvm-spirv;name=spirv \
5 file://llvm10-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \
6 file://fix-shared-libs.patch;patchdir=llvm/projects/llvm-spirv \
7 file://BasicBlockUtils-Add-metadata-fixing-in-SplitBlockPre.patch;patchdir=llvm \
8 file://IndVarSimplify-Do-not-use-SCEV-expander-for-IVCount-.patch;patchdir=llvm \
24 " 9 "
25SRC_URI_append_intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '9.0.1', '${LLVM9_PATCH_LIST}', '${LLVM10_PATCH_LIST}', d)}"
26 10
27SRCREV_spirv = "${SPIRV_SRCREV}" 11SRCREV_spirv = "4d43f68a30a510b4e7607351caab3df8e7426a6b"