summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-25 12:38:21 -0500
committerSaul Wold <sgw@linux.intel.com>2017-09-25 15:53:57 -0700
commita513894de8cbe7d6671f58f0c3f374e08d7af1b8 (patch)
treee106754311226a7dc80e1a5e4b8454d642e3c4ab
parenta20d06d7e4b07c8ba12364a5262eeab8455235af (diff)
downloadmeta-intel-a513894de8cbe7d6671f58f0c3f374e08d7af1b8.tar.gz
dpdk: Move BSP specific configurations from recipes to machine.conf
The COMPATIBLE_MACHINE entry for dpdk recipes is set to 'null'. This will prevent arbitrary machines from trying to use the dpdk functionality. A compatible MACHINE must define itself as such for the dpdk recipes. Also the BSP aware target machine was similarly moved to the BSP. Embedding BSP specific knowledge into the recipe will cause the recipe to slowly get out of date. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--conf/machine/intel-corei7-64.conf5
-rw-r--r--meta-dpdk/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb5
-rw-r--r--meta-dpdk/recipes-extended/dpdk/dpdk.inc18
3 files changed, 16 insertions, 12 deletions
diff --git a/conf/machine/intel-corei7-64.conf b/conf/machine/intel-corei7-64.conf
index a8097fc3..e3969827 100644
--- a/conf/machine/intel-corei7-64.conf
+++ b/conf/machine/intel-corei7-64.conf
@@ -16,6 +16,11 @@ MACHINE_HWCODECS ?= "va-intel gstreamer1.0-vaapi"
16 16
17MACHINE_EXTRA_RRECOMMENDS += "lms8" 17MACHINE_EXTRA_RRECOMMENDS += "lms8"
18 18
19# Enable optional dpdk:
20COMPATIBLE_MACHINE_pn-dpdk = "intel-corei7-64"
21COMPATIBLE_MACHINE_pn-dpdk-dev-libibverbs = "intel-corei7-64"
22DPDK_TARGET_MACHINE ?= "atm"
23
19XSERVER ?= "${XSERVER_X86_BASE} \ 24XSERVER ?= "${XSERVER_X86_BASE} \
20 ${XSERVER_X86_EXT} \ 25 ${XSERVER_X86_EXT} \
21 ${XSERVER_X86_FBDEV} \ 26 ${XSERVER_X86_FBDEV} \
diff --git a/meta-dpdk/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb b/meta-dpdk/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
index c06cceb7..e40c63b8 100644
--- a/meta-dpdk/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
+++ b/meta-dpdk/recipes-extended/dpdk-dev-libibverbs/dpdk-dev-libibverbs_1.2.1-3.4-2.0.0.0.bb
@@ -14,7 +14,10 @@ SRC_URI = "https://github.com/Mellanox/dpdk-dev-libibverbs/archive/libibverbs-${
14SRC_URI[dpdk-dev-libibverbs.md5sum] = "65234ee278eb437a7069326f37cd4d86" 14SRC_URI[dpdk-dev-libibverbs.md5sum] = "65234ee278eb437a7069326f37cd4d86"
15SRC_URI[dpdk-dev-libibverbs.sha256sum] = "a6471515556cb8d10ad471bb7efb8cf760b248a28aceb57d4534d50d572f56cd" 15SRC_URI[dpdk-dev-libibverbs.sha256sum] = "a6471515556cb8d10ad471bb7efb8cf760b248a28aceb57d4534d50d572f56cd"
16 16
17COMPATIBLE_MACHINE = "intel-corei7-64" 17# A machine needs to enable this using:
18# COMPATIBLE_MACHINE_pn-dpdk-dev-libibverbs = "<machine name>"
19
20COMPATIBLE_MACHINE = "null"
18COMPATIBLE_HOST_libc-musl_class-target = "null" 21COMPATIBLE_HOST_libc-musl_class-target = "null"
19 22
20S = "${WORKDIR}/${PN}-libibverbs-${PV}" 23S = "${WORKDIR}/${PN}-libibverbs-${PV}"
diff --git a/meta-dpdk/recipes-extended/dpdk/dpdk.inc b/meta-dpdk/recipes-extended/dpdk/dpdk.inc
index ba382675..c1d01491 100644
--- a/meta-dpdk/recipes-extended/dpdk/dpdk.inc
+++ b/meta-dpdk/recipes-extended/dpdk/dpdk.inc
@@ -12,7 +12,10 @@ SRC_URI = "http://fast.dpdk.org/rel/${BP}.tar.gz;name=dpdk \
12 file://dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch \ 12 file://dpdk-17.02-dpdk-fix-installation-warning-and-issue.patch \
13 " 13 "
14 14
15COMPATIBLE_MACHINE = "intel-corei7-64" 15# A machine needs to enable this using:
16# COMPATIBLE_MACHINE_pn-dpdk-dev-libibverbs = "<machine name>"
17
18COMPATIBLE_MACHINE = "null"
16COMPATIBLE_HOST_libc-musl_class-target = "null" 19COMPATIBLE_HOST_libc-musl_class-target = "null"
17 20
18 21
@@ -55,16 +58,9 @@ export ICP_LAC_API_DIR = "${STAGING_DIR_TARGET}${includedir}/lac"
55# process mapping. The supported target machine is listed under 58# process mapping. The supported target machine is listed under
56# dpdk/mk/machine 59# dpdk/mk/machine
57def get_dpdk_target_mach(bb, d): 60def get_dpdk_target_mach(bb, d):
58 target_arch = d.getVar('MACHINE_ARCH', True) 61 target_arch = d.getVar('DPDK_TARGET_MACHINE', True)
59 multiarch_options = { 62 if target_arch:
60 "mohonpeak64": "atm", 63 target_arch
61 "mohonpeak32": "atm",
62 "crystalforest": "ivb",
63 "intel_corei7_64": "atm",
64 }
65
66 if target_arch in multiarch_options :
67 return multiarch_options[target_arch]
68 return "default" 64 return "default"
69 65
70do_configure () { 66do_configure () {