summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-08-06 08:56:45 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-08-06 13:02:14 +0800
commit9fe382034e9f32ad753285b34d70f82e33110133 (patch)
treead9c35aefe985983d435b78c0ecd5bd60540a795
parentaa2fb07c2a4b15c171c85c8eb3d401384cc6910a (diff)
downloadmeta-intel-9fe382034e9f32ad753285b34d70f82e33110133.tar.gz
linux-intel: backport commit to fix perf builds
Fixes: | /build/build/tmp/work/intel_corei7_64-poky-linux/perf/1.0-r9/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/10.1.0/ld:/home/pokybuild/yocto-worker/meta-intel/build/build/tmp/work/intel_corei7_64-poky-linux/perf/1.0-r9/perf-1.0/plugins/libtraceevent-dynamic-list:2: ignoring invalid character `@' in script | /build/tmp/work/intel_corei7_64-poky-linux/perf/1.0-r9/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/10.1.0/ld:/home/pokybuild/yocto-worker/meta-intel/build/build/tmp/work/intel_corei7_64-poky-linux/perf/1.0-r9/perf-1.0/plugins/libtraceevent-dynamic-list:2: ignoring invalid character `@' in script | /build/tmp/work/intel_corei7_64-poky-linux/perf/1.0-r9/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/10.1.0/ld:/home/pokybuild/yocto-worker/meta-intel/build/build/tmp/work/intel_corei7_64-poky-linux/perf/1.0-r9/perf-1.0/plugins/libtraceevent-dynamic-list:2: syntax error in dynamic list Include the patch in recipe for now until it's not in Intel LTS tree. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel.inc1
-rw-r--r--recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch39
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index c6163973..a592d527 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -8,6 +8,7 @@ KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;n
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ 9 git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
10 ${KERNEL_CONFIG_URI} \ 10 ${KERNEL_CONFIG_URI} \
11 file://libtraceevent-fix-build-with-binutils-25.patch \
11 " 12 "
12 13
13SRC_URI_append = " file://enable_lynxpoint_gpio.cfg" 14SRC_URI_append = " file://enable_lynxpoint_gpio.cfg"
diff --git a/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch b/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch
new file mode 100644
index 00000000..66cb981e
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch
@@ -0,0 +1,39 @@
1From 1fe4ee7f680c3f69f620d68a5d2f7341e8db693b Mon Sep 17 00:00:00 2001
2From: Ben Hutchings <ben@decadent.org.uk>
3Date: Sat, 25 Jul 2020 02:06:23 +0100
4Subject: libtraceevent: Fix build with binutils 2.35
5
6In binutils 2.35, 'nm -D' changed to show symbol versions along with
7symbol names, with the usual @@ separator. When generating
8libtraceevent-dynamic-list we need just the names, so strip off the
9version suffix if present.
10
11Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
12Tested-by: Salvatore Bonaccorso <carnil@debian.org>
13Reviewed-by: Steven Rostedt <rostedt@goodmis.org>
14Cc: linux-trace-devel@vger.kernel.org
15Cc: stable@vger.kernel.org
16Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
17
18Upstream-Status: Backport [https://github.com/torvalds/linux/commit/39efdd94e314336f4acbac4c07e0f37bdc3bef71]
19Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
20---
21 tools/lib/traceevent/plugins/Makefile | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/tools/lib/traceevent/plugins/Makefile b/tools/lib/traceevent/plugins/Makefile
25index f440989fa55e..23c3535bcbd6 100644
26--- a/tools/lib/traceevent/plugins/Makefile
27+++ b/tools/lib/traceevent/plugins/Makefile
28@@ -196,7 +196,7 @@ define do_generate_dynamic_list_file
29 xargs echo "U w W" | tr 'w ' 'W\n' | sort -u | xargs echo`;\
30 if [ "$$symbol_type" = "U W" ];then \
31 (echo '{'; \
32- $(NM) -u -D $1 | awk 'NF>1 {print "\t"$$2";"}' | sort -u;\
33+ $(NM) -u -D $1 | awk 'NF>1 {sub("@.*", "", $$2); print "\t"$$2";"}' | sort -u;\
34 echo '};'; \
35 ) > $2; \
36 else \
37--
38cgit v1.2.2-1-g5e49
39