summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-03-26 18:39:13 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-01 13:28:51 +0800
commit9aecbb76e8a4404dc01e0d6cdf654d4998198c96 (patch)
tree12c0004602eda1f1eda2cbc17685f12cd0d940d9
parentfa5566a9fd8a282e79d8f2f59314fd8ef0bae4c1 (diff)
downloadmeta-intel-9aecbb76e8a4404dc01e0d6cdf654d4998198c96.tar.gz
llvm-project-source: exclude for llvm-12
meta-clang now builds llvm-spiv-translator as an external project for llvm12 so stop building it. It still need to be built for llvm-10 and llvm-11 though. Ref: https://github.com/kraj/meta-clang/commit/aa1ab889bcbb580f33151933d7ed44fd4a93f1bf Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend10
1 files changed, 5 insertions, 5 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend b/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
index fb87900e..17e991ab 100644
--- a/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
+++ b/dynamic-layers/clang-layer/recipes-devtools/clang/llvm-project-source.bbappend
@@ -18,10 +18,10 @@ SRC_URI_LLVM11 = " \
18 file://llvm11-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \ 18 file://llvm11-skip-building-tests.patch;patchdir=llvm/projects/llvm-spirv \
19 " 19 "
20 20
21SRC_URI_append_intel-x86-common = " \ 21SPIRV_LLVM_SRC_URI = "git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=${SPIRV_BRANCH};destsuffix=git/llvm/projects/llvm-spirv;name=spirv"
22 git://github.com/KhronosGroup/SPIRV-LLVM-Translator.git;protocol=https;branch=${SPIRV_BRANCH};destsuffix=git/llvm/projects/llvm-spirv;name=spirv \
23 "
24 22
25SRC_URI_append_intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '${SRC_URI_LLVM10}', '${SRC_URI_LLVM11}', d)}" 23SPIRV_LLVM_PATCHES = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '${SRC_URI_LLVM10}', '${SRC_URI_LLVM11}', d)}"
26 24
27SRCREV_spirv = "${SPIRV_SRCREV}" 25
26SRC_URI_append_intel-x86-common = "${@bb.utils.contains('LLVMVERSION', '12.0.0', '', ' ${SPIRV_LLVM_SRC_URI} ${SPIRV_LLVM_PATCHES} ', d)}"
27SRCREV_spirv = "${@bb.utils.contains('LLVMVERSION', '12.0.0', '', '${SPIRV_SRCREV}', d)}"