summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-02-25 13:20:20 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-02-25 15:03:03 +0800
commit9796a61261005366070d1f5119e46295c8f920e5 (patch)
treee70f438bf30adf3aab693c57ce266bd7c45007cc
parent2b0a523adeb5ab8b20135375dccb3cacce582fbe (diff)
downloadmeta-intel-9796a61261005366070d1f5119e46295c8f920e5.tar.gz
dldt-inference-engine: use libdir when installing python modules
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-R2-Install-DLDT-headers-libs-sample-Apps.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-R2-Install-DLDT-headers-libs-sample-Apps.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-R2-Install-DLDT-headers-libs-sample-Apps.patch
index 8b563b1c..b89964b1 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-R2-Install-DLDT-headers-libs-sample-Apps.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-R2-Install-DLDT-headers-libs-sample-Apps.patch
@@ -1,14 +1,14 @@
1From d73cd3c504e1409861da0b6879ea0dbd4572e706 Mon Sep 17 00:00:00 2001 1From 518cd8afb38810924371209416fd5b5d2c23a92e Mon Sep 17 00:00:00 2001
2From: Erin Park <erin.park@intel.com> 2From: Erin Park <erin.park@intel.com>
3Date: Wed, 11 Sep 2019 10:33:58 -0700 3Date: Wed, 11 Sep 2019 10:33:58 -0700
4Subject: [PATCH 2/7] R2 Install DLDT headers, libs, sample Apps 4Subject: [PATCH] R2 Install DLDT headers, libs, sample Apps
5 5
6-Update to R3 6-Update to R3
7-Libraries to /usr/lib64 7-Libraries to /usr/lib64
8-Headers to /usr/include 8-Headers to /usr/include
9-Sample Apps executable to /usr/bin 9-Sample Apps executable to /usr/bin
10-Sample Apps source code to /usr/share/doc/inference_engine 10-Sample Apps source code to /usr/share/doc/inference_engine
11-Python library to /usr/lib/python3.7/site-packages 11-Python library to ${libdir}/python<version>/site-packages
12-plugins.xml to /usr/share/openvino/inference-engine 12-plugins.xml to /usr/share/openvino/inference-engine
13-Create targets_cpu_extension.cmake 13-Create targets_cpu_extension.cmake
14 14
@@ -66,7 +66,7 @@ index bba853f..444cce9 100644
66-add_subdirectory (src/openvino/tools/statistics_collector) 66-add_subdirectory (src/openvino/tools/statistics_collector)
67+#add_subdirectory (src/openvino/tools/statistics_collector) 67+#add_subdirectory (src/openvino/tools/statistics_collector)
68diff --git a/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt b/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt 68diff --git a/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt b/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt
69index 1f46013..d6cd112 100644 69index 1f46013..952c173 100644
70--- a/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt 70--- a/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt
71+++ b/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt 71+++ b/inference-engine/ie_bridges/python/src/openvino/inference_engine/CMakeLists.txt
72@@ -29,4 +29,6 @@ ADD_CUSTOM_COMMAND (TARGET ${TARGET_NAME} 72@@ -29,4 +29,6 @@ ADD_CUSTOM_COMMAND (TARGET ${TARGET_NAME}
@@ -77,7 +77,7 @@ index 1f46013..d6cd112 100644
77\ No newline at end of file 77\ No newline at end of file
78+) 78+)
79+ 79+
80+install(DIRECTORY ${PYTHON_BRIDGE_OUTPUT_DIRECTORY} DESTINATION lib/${PYTHON_VERSION}/site-packages/) 80+install(DIRECTORY ${PYTHON_BRIDGE_OUTPUT_DIRECTORY} DESTINATION ${CMAKE_INSTALL_LIBDIR}/${PYTHON_VERSION}/site-packages/)
81diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt 81diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
82index 884b0a6..25f9f23 100644 82index 884b0a6..25f9f23 100644
83--- a/inference-engine/samples/CMakeLists.txt 83--- a/inference-engine/samples/CMakeLists.txt
@@ -116,7 +116,7 @@ index a8c9caf..dffa8cb 100644
116+ 116+
117+install(TARGETS ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}) 117+install(TARGETS ${TARGET_NAME} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
118diff --git a/inference-engine/src/CMakeLists.txt b/inference-engine/src/CMakeLists.txt 118diff --git a/inference-engine/src/CMakeLists.txt b/inference-engine/src/CMakeLists.txt
119index 63fda2a..3a4bc48 100644 119index 63fda2a..350e3f5 100644
120--- a/inference-engine/src/CMakeLists.txt 120--- a/inference-engine/src/CMakeLists.txt
121+++ b/inference-engine/src/CMakeLists.txt 121+++ b/inference-engine/src/CMakeLists.txt
122@@ -37,8 +37,10 @@ set(InferenceEngine_SRC_DIRS ${CMAKE_SOURCE_DIR}/src) 122@@ -37,8 +37,10 @@ set(InferenceEngine_SRC_DIRS ${CMAKE_SOURCE_DIR}/src)