summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-10-07 15:57:12 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-10-07 16:07:27 +0800
commit70d3ae20a27c1708c15cc8f992b3af7310b26013 (patch)
tree7691ad453b7e36ec5376d9a17a7430f2bc9ff0e8
parentdbae24f5bb5c133958439b9943f59f77a4c368f1 (diff)
downloadmeta-intel-70d3ae20a27c1708c15cc8f992b3af7310b26013.tar.gz
libva-intel-utils: add recipe
We need a later version of libva than what is available in oe-core for the media components. Create our own copy of the recipe and include it only when someone has included one of meta-intel MACHINEs. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--conf/layer.conf4
-rw-r--r--conf/machine/include/meta-intel.inc4
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.9.0.bb32
3 files changed, 40 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 6e9d86e8..6b379a6c 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -40,3 +40,7 @@ PREFERRED_PROVIDER_nativesdk-zlib ?= "nativesdk-zlib"
40PREFERRED_PROVIDER_libva ?= "libva" 40PREFERRED_PROVIDER_libva ?= "libva"
41PREFERRED_PROVIDER_libva-native ?= "libva-native" 41PREFERRED_PROVIDER_libva-native ?= "libva-native"
42PREFERRED_PROVIDER_nativesdk-libva ?= "nativesdk-libva" 42PREFERRED_PROVIDER_nativesdk-libva ?= "nativesdk-libva"
43
44PREFERRED_PROVIDER_libva-utils ?= "libva-utils"
45PREFERRED_PROVIDER_libva-native ?= "libva-utils-native"
46PREFERRED_PROVIDER_nativesdk-libva-utils ?= "nativesdk-libva-utils"
diff --git a/conf/machine/include/meta-intel.inc b/conf/machine/include/meta-intel.inc
index 86c94878..460e3eee 100644
--- a/conf/machine/include/meta-intel.inc
+++ b/conf/machine/include/meta-intel.inc
@@ -22,6 +22,10 @@ PREFERRED_PROVIDER_libva = "libva-intel"
22PREFERRED_PROVIDER_libva-native = "libva-intel-native" 22PREFERRED_PROVIDER_libva-native = "libva-intel-native"
23PREFERRED_PROVIDER_nativesdk-libva = "nativesdk-libva-intel" 23PREFERRED_PROVIDER_nativesdk-libva = "nativesdk-libva-intel"
24 24
25PREFERRED_PROVIDER_libva-utils = "libva-utils-intel"
26PREFERRED_PROVIDER_libva-native = "libva-utils-intel-native"
27PREFERRED_PROVIDER_nativesdk-libva-utils = "nativesdk-libva-utils-intel"
28
25XSERVER_X86_ASPEED_AST = "xf86-video-ast \ 29XSERVER_X86_ASPEED_AST = "xf86-video-ast \
26 " 30 "
27 31
diff --git a/recipes-graphics/libva/libva-intel-utils_2.9.0.bb b/recipes-graphics/libva/libva-intel-utils_2.9.0.bb
new file mode 100644
index 00000000..2ee9ee88
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel-utils_2.9.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "libva-utils is a collection of utilities from libva project"
2
3DESCRIPTION = "libva-utils is a collection of utilities \
4and examples to exercise VA-API in accordance with the libva \
5project.VA-API is an open-source library and API specification, \
6which provides access to graphics hardware acceleration capabilities \
7for video processing. It consists of a main library and driver-specific \
8acceleration backends for each supported hardware vendor"
9
10HOMEPAGE = "https://01.org/linuxmedia/vaapi"
11BUGTRACKER = "https://github.com/intel/libva-utils/issues"
12
13SECTION = "x11"
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16
17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.9-branch"
18SRCREV = "ee781a3f5d70a7ff801940136b1d45d002b83091"
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
22
23DEPENDS = "libva"
24
25inherit meson pkgconfig features_check
26
27# depends on libva which requires opengl
28REQUIRED_DISTRO_FEATURES = "opengl"
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
31PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland"