summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-08-25 00:10:37 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-08-25 01:12:16 +0800
commit68edb423fbb30c521e103cba567a583583b7a53a (patch)
treed38189682357d95dd5a0a922bdf57b74844be045
parent6b7045d99a61b8ad47d289f84f4c7080cf032c06 (diff)
downloadmeta-intel-68edb423fbb30c521e103cba567a583583b7a53a.tar.gz
openvkl: upgrade 0.13.0 -> 1.0.0
Release notes: https://github.com/openvkl/openvkl/blob/master/CHANGELOG.md Highlights: The version 1.0 release marks long term API stability (until v2.0) Open VKL can now be built for ARM CPUs that support Neon Iterator API updates: Introducing interval and hit iterator contexts, which hold iterator-specific configuration (eliminates value selector objects) Interval and hit iteration is now supported on any volume attribute Interval iterators now include a time parameter Interval iterators now support the intervalResolutionHint parameter, replacing maxIteratorDepth and elementaryCellIteration Supporting configurable background values; default is now VKL_BACKGROUND_UNDEFINED (NaN) for all volume types vklGetValueRange() now supports all volume attributes Added ISPC-side API bindings for vklGetNumAttributes() and vklGetValueRange() Structured regular volumes: Added support for tricubic filtering More accurate gradient computations respecting filter mode Hit iteration robustness improvements VDB volumes: Interval and hit iteration robustness improvements Corrected interval iterator nominalDeltaT computation for non-normalized ray directions and non-uniform object-space grid spacings Fixed bug which could cause incorrect value range computations for temporally varying volumes vklExamples additions demonstrating: Multi-attribute interval / hit iteration Configurable background values Temporally varying volumes Superbuild updates to latest versions of dependencies Now requiring minimum versions: Embree 3.13.1 rkcommon 1.7.0 ISPC 1.16.0 License-Update: Copyright years updated Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl/0001-half.hpp-Fixed-missing-include-for-F16C-intrinsics.patch44
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.0.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_0.13.0.bb)9
2 files changed, 4 insertions, 49 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl/0001-half.hpp-Fixed-missing-include-for-F16C-intrinsics.patch b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl/0001-half.hpp-Fixed-missing-include-for-F16C-intrinsics.patch
deleted file mode 100644
index 4c8caaf2..00000000
--- a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl/0001-half.hpp-Fixed-missing-include-for-F16C-intrinsics.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 8b701e2b6989f7e071126989dd9453d7728d9a61 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 7 Jul 2021 11:40:15 +0800
4Subject: [PATCH] half.hpp: Fixed missing include for F16C intrinsics
5
6Upstream-Status: Backport [https://sourceforge.net/p/half/code/415/]
7
8Ref:
9https://github.com/openvkl/openvkl/issues/12
10
11Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
12---
13 testing/external/half.hpp | 8 ++++----
14 1 file changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/testing/external/half.hpp b/testing/external/half.hpp
17index 69f2ffd..005043f 100644
18--- a/testing/external/half.hpp
19+++ b/testing/external/half.hpp
20@@ -266,10 +266,6 @@
21 #if HALF_ENABLE_CPP11_HASH
22 #include <functional>
23 #endif
24-#if HALF_ENABLE_F16C_INTRINSICS
25- #include <immintrin.h>
26-#endif
27-
28
29 #ifndef HALF_ENABLE_F16C_INTRINSICS
30 /// Enable F16C intruction set intrinsics.
31@@ -281,6 +277,10 @@
32 #define HALF_ENABLE_F16C_INTRINSICS __F16C__
33 #endif
34
35+#if HALF_ENABLE_F16C_INTRINSICS
36+ #include <immintrin.h>
37+#endif
38+
39 #ifdef HALF_DOXYGEN_ONLY
40 /// Type for internal floating-point computations.
41 /// This can be predefined to a built-in floating-point type (`float`, `double` or `long double`) to override the internal
42--
432.17.1
44
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_0.13.0.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.0.0.bb
index b2c5a038..abbde9a1 100644
--- a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_0.13.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.0.0.bb
@@ -11,17 +11,16 @@ HOMEPAGE = "https://www.openvkl.org/"
11 11
12LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib" 12LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & Zlib"
13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
14 file://third-party-programs.txt;md5=90d62b467dd4fdf3c7d3d897fbac7437 \ 14 file://third-party-programs.txt;md5=69ec7caf49616c471161b921f53d5ec0 \
15 file://testing/external/half.hpp;beginline=1;endline=17;md5=cc1d65765aef5c4f6a37e7833173835a" 15 file://testing/external/half.hpp;beginline=1;endline=17;md5=4b60058493630c3bd0ef145470f04a7b"
16 16
17inherit pkgconfig cmake 17inherit pkgconfig cmake
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21SRC_URI = "git://github.com/openvkl/openvkl.git;protocol=https \ 21SRC_URI = "git://github.com/openvkl/openvkl.git;protocol=https \
22 file://0001-half.hpp-Fixed-missing-include-for-F16C-intrinsics.patch \ 22 "
23 " 23SRCREV = "5a7071d9b9fd5413d04871dff252ab0bf93fbf03"
24SRCREV = "84b9d78ead12f369f37cee77d985da9d13c07ae1"
25 24
26COMPATIBLE_HOST = '(x86_64).*-linux' 25COMPATIBLE_HOST = '(x86_64).*-linux'
27 26