summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2022-11-18 12:09:13 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-11-18 11:55:06 +0800
commit579394dc233cce96c84c7c45d05d6748aae03865 (patch)
tree31a8929e718e5d1fa61b563caca35a797eca5789
parent2ce9b55f99a30e810aed196888c0858f4996e26e (diff)
downloadmeta-intel-579394dc233cce96c84c7c45d05d6748aae03865.tar.gz
linux-intel-rt/5.19: add recipe
Build 5.19 RT kernel version from mainline-tracking tree at: https://github.com/intel/mainline-tracking This will track the mainline kernel and will be used to enable support for newer platforms. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.19.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.19.bb b/recipes-kernel/linux/linux-intel-rt_5.19.bb
new file mode 100644
index 00000000..58952b0c
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_5.19.bb
@@ -0,0 +1,28 @@
1require linux-intel.inc
2
3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
4 "
5SRC_URI:append = " file://0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
7# Skip processing of this recipe if it is not explicitly specified as the
8# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
9# to build multiple virtual/kernel providers, e.g. as dependency of
10# core-image-rt-sdk, core-image-rt.
11python () {
12 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
13 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
14}
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18KMETA_BRANCH = "yocto-5.19"
19
20DEPENDS += "elfutils-native openssl-native util-linux-native"
21
22LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
23
24LINUX_VERSION ?= "5.19.0"
25SRCREV_machine ?= "7de7f243440a51b6b996fc462f7fd7a546c175d2"
26SRCREV_meta ?= "0cba9aa40445bf59bfa651e1bd43a31c2ca7d524"
27
28LINUX_KERNEL_TYPE = "preempt-rt"