summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-02-13 20:56:06 +0000
committerSaul Wold <sgw@linux.intel.com>2017-03-07 12:22:22 -0800
commit4e5d634471c03a3256556206115391ec0f543caf (patch)
tree978121ea16f588dac03442069540e404698b2bd0
parentc5790c6aca82ca6a266159bd8f51861cc12b8f75 (diff)
downloadmeta-intel-4e5d634471c03a3256556206115391ec0f543caf.tar.gz
linux-yocto-tiny: Adds support for core2-32 and corei7-64 on linux-yocto-tiny_4.9 and upgrades to 4.9.13
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend30
1 files changed, 29 insertions, 1 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
index 771662bd..602670e6 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend
@@ -1,3 +1,31 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar"
4
5LINUX_VERSION_i586-nlp-32-intel-common = "4.9.13"
6LINUX_VERSION_core2-32-intel-common = "4.9.13"
7LINUX_VERSION_corei7-64-intel-common = "4.9.13"
8
9SRCREV_meta_i586-nlp-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
10SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
11SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de"
12
13SRCREV_machine_i586-nlp-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
14SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
15SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098"
16
1COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 17COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
18COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
19COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
20
21KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
22KBRANCH_core2-32-intel-common = "standard/tiny/base"
23KBRANCH_corei7-64-intel-common = "standard/tiny/base"
24
2KMACHINE_i586-nlp-32-intel-common = "intel-quark" 25KMACHINE_i586-nlp-32-intel-common = "intel-quark"
3KERNEL_FEATURES_append_i586-nlp-32-intel-common = "cfg/fs/ext4.scc" 26KMACHINE_core2-32-intel-common = "intel-core2-32"
27KMACHINE_corei7-64-intel-common = "intel-corei7-64"
28
29KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
30KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"
31KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc"