summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-10-13 23:37:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-10-15 11:56:38 +0800
commit4958cf0852d92318fef43eafe7a58dd8b3f761f1 (patch)
tree6ab6a244724805b1fcb7d10f8eb9f1b26e97dd67
parent26de78f5fece9313f9158b0bac8e0c575e68c1fa (diff)
downloadmeta-intel-4958cf0852d92318fef43eafe7a58dd8b3f761f1.tar.gz
opencl-clang: add recipe for LLVM 11
Point to latest for llvm 11 branch as there's no official release yet. And, pick the version of opencl-clang based on LLVMVERSION. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--conf/machine/include/meta-intel.inc3
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb34
2 files changed, 37 insertions, 0 deletions
diff --git a/conf/machine/include/meta-intel.inc b/conf/machine/include/meta-intel.inc
index 460e3eee..7346d6e1 100644
--- a/conf/machine/include/meta-intel.inc
+++ b/conf/machine/include/meta-intel.inc
@@ -26,6 +26,9 @@ PREFERRED_PROVIDER_libva-utils = "libva-utils-intel"
26PREFERRED_PROVIDER_libva-native = "libva-utils-intel-native" 26PREFERRED_PROVIDER_libva-native = "libva-utils-intel-native"
27PREFERRED_PROVIDER_nativesdk-libva-utils = "nativesdk-libva-utils-intel" 27PREFERRED_PROVIDER_nativesdk-libva-utils = "nativesdk-libva-utils-intel"
28 28
29PREFERRED_VERSION_opencl-clang ?= "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}"
30PREFERRED_VERSION_opencl-clang-native ?= "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}"
31
29XSERVER_X86_ASPEED_AST = "xf86-video-ast \ 32XSERVER_X86_ASPEED_AST = "xf86-video-ast \
30 " 33 "
31 34
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
new file mode 100644
index 00000000..4e38bb03
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 "
11SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
12
13SRCREV = "7fa38fff412e6fbfa5385a3c135e4d5216b9ab17"
14
15S = "${WORKDIR}/git"
16
17inherit cmake
18DEPENDS += "clang"
19DEPENDS_append_class-target = " opencl-clang-native"
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null"
23
24EXTRA_OECMAKE += "\
25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
26 -DCMAKE_SKIP_RPATH=TRUE \
27 "
28
29do_install_append_class-native() {
30 install -d ${D}${bindir}
31 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
32}
33
34BBCLASSEXTEND = "native nativesdk"