summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-03-22 15:02:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-03-22 18:13:47 +0800
commit311b43239440070f750a0ec44537a26c5f22e131 (patch)
treee311c2a512771316c8dec4eb4b161492fb3f199d
parentf8ce4df0524698a88188ffd7fe1f9e13240b89ab (diff)
downloadmeta-intel-311b43239440070f750a0ec44537a26c5f22e131.tar.gz
intel-graphics-compiler: fix compile issues
Backport patches to fix compile problems like: | /build/build/tmp/work/corei7-64-poky-linux/intel-graphics-compiler/1.0.10395-r0/git/visa/LocalScheduler/SWSB_G4IR.cpp:1459:49: error: expected primary-expression before 'int' | 1459 | int maxTokenDelay = std::numeric_limits<int>::min(); //The delay may cause if reuse | | ^~~ | /build/build/tmp/work/corei7-64-poky-linux/intel-graphics-compiler/1.0.10395-r0/git/visa/LocalScheduler/SWSB_G4IR.cpp:1460:37: error: 'numeric_limits' is not a member of 'std' | 1460 | int minTokenDistance = std::numeric_limits<int>::max(); //The distance from the reused node Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch23
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch25
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb2
3 files changed, 50 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch
new file mode 100644
index 00000000..1e7816ab
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/4369c970d4e02258b3c53e854faaa34197124a33.patch
@@ -0,0 +1,23 @@
1From 4369c970d4e02258b3c53e854faaa34197124a33 Mon Sep 17 00:00:00 2001
2From: Marcin Naczk <marcin.naczk@intel.com>
3Date: Tue, 22 Feb 2022 13:09:54 +0000
4Subject: [PATCH] Upgrade github Action build IGC
5
6- Fix build IGC on Ubuntu 22.04 by adding missing include
7
8Upstream-Status: Backport
9Part of: https://github.com/intel/intel-graphics-compiler/commit/4369c970d4e02258b3c53e854faaa34197124a33
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12diff --git a/visa/iga/IGALibrary/IR/SWSBSetter.hpp b/visa/iga/IGALibrary/IR/SWSBSetter.hpp
13index 6a2de51ee02..4a6fd8735ce 100644
14--- a/visa/iga/IGALibrary/IR/SWSBSetter.hpp
15+++ b/visa/iga/IGALibrary/IR/SWSBSetter.hpp
16@@ -15,6 +15,7 @@ SPDX-License-Identifier: MIT
17 #include "Operand.hpp"
18 #include "../ErrorHandler.hpp"
19 #include "RegDeps.hpp"
20+#include <limits>
21
22 namespace iga
23 {
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch
new file mode 100644
index 00000000..a504f55c
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-header.patch
@@ -0,0 +1,25 @@
1From 4f510460beb630bac74fad399370b76354fdbd65 Mon Sep 17 00:00:00 2001
2From: Bruno Pagani <bruno.n.pagani@gmail.com>
3Date: Mon, 21 Feb 2022 12:32:25 +0000
4Subject: [PATCH] Fix missing include
5
6Same as 6c805b2
7
8Upstream-Status: Backport
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10---
11 visa/LocalScheduler/SWSB_G4IR.cpp | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/visa/LocalScheduler/SWSB_G4IR.cpp b/visa/LocalScheduler/SWSB_G4IR.cpp
15index 153d8a7dc58..cea75c7faa7 100644
16--- a/visa/LocalScheduler/SWSB_G4IR.cpp
17+++ b/visa/LocalScheduler/SWSB_G4IR.cpp
18@@ -16,6 +16,7 @@ SPDX-License-Identifier: MIT
19 #include <algorithm>
20 #include <fstream>
21 #include <functional>
22+#include <limits>
23 #include <sstream>
24 #include <queue>
25
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
index c3d9f10b..764ebb76 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.10395.bb
@@ -17,6 +17,8 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;nam
17 file://0004-find-external-llvm-tblgen.patch \ 17 file://0004-find-external-llvm-tblgen.patch \
18 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \ 18 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
19 file://0001-llvm-link-external.patch \ 19 file://0001-llvm-link-external.patch \
20 file://fix-header.patch \
21 file://4369c970d4e02258b3c53e854faaa34197124a33.patch \
20 " 22 "
21 23
22SRCREV_igc = "775a850f9b0c2d7249503b47ad6bd39a4eb9b3d7" 24SRCREV_igc = "775a850f9b0c2d7249503b47ad6bd39a4eb9b3d7"