diff options
author | Saul Wold <sgw@linux.intel.com> | 2016-11-08 15:04:50 -0800 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2016-11-10 07:48:05 -0800 |
commit | cb5025bfbb9fbf1638af4c0c979f77eade2dbefb (patch) | |
tree | fc8e38f3fda4d4288fe11a8343748fbb7c1191c6 | |
parent | c1f260ba7fdf1a73bff897b14555ed5a11482a0e (diff) | |
download | meta-intel-cb5025bfbb9fbf1638af4c0c979f77eade2dbefb.tar.gz |
linux-yocto_4.4: Add INTEL_MACHINE_SUBTYPE code
This adds some a couple of bb.utils.contains() checks for an
INTEL_MACHINE_SUBSTPYE to pull the appropriate SRCREV
and KBRACH to build an alternate kernel.
Also adds support for Broxton-m/Joule device as an example.
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r-- | common/recipes-kernel/linux/linux-yocto_4.4.bbappend | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend index fca62311..948ece0d 100644 --- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend +++ b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend | |||
@@ -17,9 +17,9 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | |||
17 | LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | 17 | LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}" |
18 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 18 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
19 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 19 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
20 | KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}" | ||
21 | SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | 20 | SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" |
22 | SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | 21 | SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'b7ddcae5f0f374ab7ffd49b0f8636328f5e3386f', '${SRCREV_MACHINE_INTEL_COMMON}', d)}" |
22 | KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}" | ||
23 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 23 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
24 | 24 | ||
25 | # Quark / X1000 BSP Info | 25 | # Quark / X1000 BSP Info |