summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-10-21 13:17:52 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-10-21 15:05:46 +0800
commit4684c50cb9b6630073519c8286a84f5ea4f6ddf9 (patch)
treebc907e8211b36f715dba5d122b94c8c72ecca5fa
parent649456856dc38086e7d43d740d68198e3395b067 (diff)
downloadmeta-intel-4684c50cb9b6630073519c8286a84f5ea4f6ddf9.tar.gz
dldt-inference-engine: build clDNN against opencl-icd-loader
Instead of letting clDNN build against intel_ocl_icd prebuilt binaries under clDNN/common/intel_ocl_icd, configure cmake build to pick up opencl-icd-loader headers and libraries from staging directory. Do not set CMAKE_INSTALL_LOCAL_ONLY as it is unused. Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
index 21b5198d..bca4c545 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/dldt-inference-engine_2019r3.bb
@@ -31,7 +31,6 @@ EXTRA_OECMAKE += " \
31 -DENABLE_GNA=0 \ 31 -DENABLE_GNA=0 \
32 -DPYTHON_EXECUTABLE=${PYTHON} \ 32 -DPYTHON_EXECUTABLE=${PYTHON} \
33 -DTHREADING=TBB \ 33 -DTHREADING=TBB \
34 -DCMAKE_INSTALL_LOCAL_ONLY=OFF \
35 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \ 34 -DCMAKE_BUILD_TYPE=DebugWithRelInfo \
36 -DNGRAPH_INCLUDES=${STAGING_INCDIR}/ngraph \ 35 -DNGRAPH_INCLUDES=${STAGING_INCDIR}/ngraph \
37 -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \ 36 -DENABLE_TESTS="${@bb.utils.contains('PTEST_ENABLED', '1', '1', '0', d)}" \
@@ -54,7 +53,7 @@ COMPATIBLE_HOST = '(x86_64).*-linux'
54COMPATIBLE_HOST_libc-musl = "null" 53COMPATIBLE_HOST_libc-musl = "null"
55 54
56PACKAGECONFIG ?= "" 55PACKAGECONFIG ?= ""
57PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime" 56PACKAGECONFIG[opencl] = "-DENABLE_CLDNN=1 -DCLDNN__IOCL_ICD_INCDIRS=${STAGING_INCDIR} -DCLDNN__IOCL_ICD_STLDIRS=${STAGING_LIBDIR} -DCLDNN__IOCL_ICD_SHLDIRS=${STAGING_LIBDIR}, -DENABLE_CLDNN=0, opencl-icd-loader, opencl-icd-loader intel-compute-runtime"
58PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3" 57PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native, python3"
59 58
60do_install_ptest_base_prepend() { 59do_install_ptest_base_prepend() {