summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-10-10 13:26:12 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-10-21 07:18:55 +0800
commit15f69ba28259fae729acfc738ce8ab5273f092bd (patch)
treef48394aa05b689e95a55e54a97b3f164eccdb25e
parent748fffc6b1994e59d42cecacf2419fe46626632d (diff)
downloadmeta-intel-15f69ba28259fae729acfc738ce8ab5273f092bd.tar.gz
opencl-clang: use default TOOLCHAIN
LLD linker is no longer the default for clang-native, so we can build binaries linking to clang-native using GNU ld. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb3
1 files changed, 0 insertions, 3 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb
index e4209234..32af900d 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_9.0.0.bb
@@ -17,7 +17,6 @@ inherit cmake
17DEPENDS += "clang" 17DEPENDS += "clang"
18 18
19DEPENDS_append_class-target = " opencl-clang-native" 19DEPENDS_append_class-target = " opencl-clang-native"
20LDFLAGS_append_class-native = " -fuse-ld=lld"
21 20
22COMPATIBLE_HOST = '(x86_64).*-linux' 21COMPATIBLE_HOST = '(x86_64).*-linux'
23COMPATIBLE_HOST_libc-musl = "null" 22COMPATIBLE_HOST_libc-musl = "null"
@@ -33,5 +32,3 @@ do_install_append_class-native() {
33} 32}
34 33
35BBCLASSEXTEND = "native nativesdk" 34BBCLASSEXTEND = "native nativesdk"
36
37TOOLCHAIN_class-native = "clang"