diff options
author | California Sullivan <california.l.sullivan@intel.com> | 2018-02-06 12:19:55 -0800 |
---|---|---|
committer | California Sullivan <california.l.sullivan@intel.com> | 2018-02-06 12:19:55 -0800 |
commit | 0329150957540592cf1b3cdc6d1fc57a3f3189bf (patch) | |
tree | e4422854b92a095ea7c7c4b9f47f05f8ff2d1793 | |
parent | 83e1ac29b7dfc2c1df3d7c24bf2acef070531ae9 (diff) | |
download | meta-intel-0329150957540592cf1b3cdc6d1fc57a3f3189bf.tar.gz |
linux-yocto: remove 4.4, 4.9, and 4.10 bbappends
These have been removed from OE-core.
Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.10.bbappend | 9 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.4.bbappend | 25 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.9.bbappend | 9 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend | 15 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend | 26 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend | 24 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.10.bbappend | 17 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.4.bbappend | 33 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.9.bbappend | 17 |
9 files changed, 0 insertions, 175 deletions
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend deleted file mode 100644 index de336b04..00000000 --- a/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | KERNEL_FEATURES_INTEL_COMMON ?= "" | ||
2 | |||
3 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
4 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
5 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
6 | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend deleted file mode 100644 index a7c13abc..00000000 --- a/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | LINUX_VERSION_INTEL_COMMON = "4.4.113" | ||
4 | SRCREV_META_INTEL_COMMON ?= "b149d14ccae8349ab33e101f6af233a12f4b17ba" | ||
5 | SRCREV_MACHINE_INTEL_COMMON ?= "1b020b6a41e153456442e201a06cb34ae8f7cbf3" | ||
6 | |||
7 | KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base" | ||
8 | |||
9 | KERNEL_FEATURES_INTEL_COMMON ?= "" | ||
10 | |||
11 | LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | ||
12 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
13 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
14 | KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}" | ||
15 | SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | ||
16 | SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | ||
17 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
18 | |||
19 | LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | ||
20 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
21 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
22 | KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}" | ||
23 | SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | ||
24 | SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | ||
25 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend deleted file mode 100644 index 3e591799..00000000 --- a/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | KERNEL_FEATURES_INTEL_COMMON = "" | ||
2 | |||
3 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
4 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
5 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
6 | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend deleted file mode 100644 index e8c27707..00000000 --- a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | KERNEL_FEATURES_INTEL_COMMON ?= "" | ||
4 | |||
5 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
6 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
7 | |||
8 | KBRANCH_core2-32-intel-common = "standard/tiny/base" | ||
9 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" | ||
10 | |||
11 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
12 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
13 | |||
14 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
15 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend deleted file mode 100644 index d2e0e001..00000000 --- a/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar" | ||
4 | |||
5 | KERNEL_FEATURES_INTEL_COMMON ?= "" | ||
6 | |||
7 | LINUX_VERSION_core2-32-intel-common = "4.4.113" | ||
8 | LINUX_VERSION_corei7-64-intel-common = "4.4.113" | ||
9 | |||
10 | SRCREV_meta_core2-32-intel-common = "b149d14ccae8349ab33e101f6af233a12f4b17ba" | ||
11 | SRCREV_meta_corei7-64-intel-common = "b149d14ccae8349ab33e101f6af233a12f4b17ba" | ||
12 | |||
13 | SRCREV_machine_core2-32-intel-common = "253edd98d1ee92cbed25dc439745a4ba9de2b236" | ||
14 | SRCREV_machine_corei7-64-intel-common = "253edd98d1ee92cbed25dc439745a4ba9de2b236" | ||
15 | |||
16 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
17 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
18 | |||
19 | KBRANCH_core2-32-intel-common = "standard/tiny/intel/base" | ||
20 | KBRANCH_corei7-64-intel-common = "standard/tiny/intel/base" | ||
21 | |||
22 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
23 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
24 | |||
25 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
26 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend deleted file mode 100644 index 84d61ab4..00000000 --- a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar" | ||
4 | |||
5 | LINUX_VERSION_core2-32-intel-common = "4.9.13" | ||
6 | LINUX_VERSION_corei7-64-intel-common = "4.9.13" | ||
7 | |||
8 | SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" | ||
9 | SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" | ||
10 | |||
11 | SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" | ||
12 | SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" | ||
13 | |||
14 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
16 | |||
17 | KBRANCH_core2-32-intel-common = "standard/tiny/base" | ||
18 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" | ||
19 | |||
20 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
21 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
22 | |||
23 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
24 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
diff --git a/recipes-kernel/linux/linux-yocto_4.10.bbappend b/recipes-kernel/linux/linux-yocto_4.10.bbappend deleted file mode 100644 index b99001ed..00000000 --- a/recipes-kernel/linux/linux-yocto_4.10.bbappend +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | KERNEL_FEATURES_INTEL_COMMON ?= "" | ||
2 | |||
3 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
4 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
5 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
6 | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
10 | |||
11 | # For Crystalforest and Romley | ||
12 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | ||
13 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | ||
14 | |||
15 | # For FRI2, NUC | ||
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" | ||
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" | ||
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend deleted file mode 100644 index 94450ce7..00000000 --- a/recipes-kernel/linux/linux-yocto_4.4.bbappend +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | LINUX_VERSION_INTEL_COMMON = "4.4.113" | ||
4 | SRCREV_META_INTEL_COMMON = "b149d14ccae8349ab33e101f6af233a12f4b17ba" | ||
5 | SRCREV_MACHINE_INTEL_COMMON = "ad0fe444fa68ae2cce203abceb71f6fb87bc6c7f" | ||
6 | |||
7 | KBRANCH_INTEL_COMMON = "standard/intel/base" | ||
8 | |||
9 | KERNEL_FEATURES_INTEL_COMMON ?= "" | ||
10 | |||
11 | LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | ||
12 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
13 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
14 | KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}" | ||
15 | SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | ||
16 | SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | ||
17 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
18 | |||
19 | LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | ||
20 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
21 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
22 | SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | ||
23 | SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'a249f6388ace2a4035220c2333649b42c300faa9', '${SRCREV_MACHINE_INTEL_COMMON}', d)}" | ||
24 | KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}" | ||
25 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
26 | |||
27 | # For Crystalforest and Romley | ||
28 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | ||
29 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | ||
30 | |||
31 | # For FRI2, NUC | ||
32 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" | ||
33 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" | ||
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend deleted file mode 100644 index 9be620bb..00000000 --- a/recipes-kernel/linux/linux-yocto_4.9.bbappend +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | KERNEL_FEATURES_INTEL_COMMON = "" | ||
2 | |||
3 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
4 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
5 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
6 | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
10 | |||
11 | # For Crystalforest and Romley | ||
12 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | ||
13 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | ||
14 | |||
15 | # For FRI2, NUC | ||
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" | ||
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" | ||