summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-05-10 14:59:04 -0700
committerSaul Wold <sgw@linux.intel.com>2017-05-11 09:17:11 +0800
commitf8e08ecdab7c16352fe2d1d1e12557be213889b1 (patch)
treeb8d1d226dc551e6b949e4dd7de55a22955b604c7
parent4b83cea79a662d8061211b0db6d465cd474a974a (diff)
downloadmeta-intel-f8e08ecdab7c16352fe2d1d1e12557be213889b1.tar.gz
recipes-kernel/linux/*: Standardize use of KERNEL_FEATURES_INTEL_COMMON
Previously, some recipes hard set it to empty, and some recipes did not set it at all. So in some cases, it acted like a global variable you could modify, and in others you could only append to it. This behavior made it difficult to use (which I doubt anyone was doing). This patch changes the variable to be soft set to empty across all recipes. This way it can be used to globally change meta-intel kernels through a conf file, or individually in the different versioned recipes should the need arise. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb2
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb3
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.10.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.4.bbappend2
11 files changed, 18 insertions, 5 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
index fd88b7d5..6e61997c 100644
--- a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -27,7 +27,7 @@ KMETA = "kernel-meta"
27KCONF_BSP_AUDIT_LEVEL = "2" 27KCONF_BSP_AUDIT_LEVEL = "2"
28 28
29LINUX_KERNEL_TYPE = "preempt-rt" 29LINUX_KERNEL_TYPE = "preempt-rt"
30KERNEL_FEATURES_INTEL_COMMON = "" 30KERNEL_FEATURES_INTEL_COMMON ?= ""
31 31
32COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 32COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
33KMACHINE_core2-32-intel-common = "intel-core2-32" 33KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
index aebbedf1..46db6632 100644
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel_4.9.bb
@@ -11,13 +11,12 @@ SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machin
11LINUX_VERSION ?= "4.9.20" 11LINUX_VERSION ?= "4.9.20"
12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}" 12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}"
13 13
14
15PV = "${LINUX_VERSION}+git${SRCPV}" 14PV = "${LINUX_VERSION}+git${SRCPV}"
16 15
17KMETA = "kernel-meta" 16KMETA = "kernel-meta"
18KCONF_BSP_AUDIT_LEVEL = "2" 17KCONF_BSP_AUDIT_LEVEL = "2"
19 18
20KERNEL_FEATURES_INTEL_COMMON = "" 19KERNEL_FEATURES_INTEL_COMMON ?= ""
21 20
22COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 21COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
23KMACHINE_core2-32-intel-common = "intel-core2-32" 22KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
index 1b81c0ee..fbe2ba8d 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
@@ -6,6 +6,8 @@ SRCREV_MACHINE_INTEL_COMMON ?= "bf977ae249601f88da359260b2b2141462112f8c"
6 6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base" 7KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base"
8 8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" 11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32" 13KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
index 9d2e3c0b..17569a1c 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend
@@ -1,4 +1,4 @@
1KERNEL_FEATURES_INTEL_COMMON = "" 1KERNEL_FEATURES_INTEL_COMMON ?= ""
2 2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32" 4KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
index 85f4c1c3..03c45c88 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
@@ -6,6 +6,8 @@ SRCREV_MACHINE_INTEL_COMMON ?= "8364651ddaaa71602ad7746937d79dc815fe056d"
6 6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base" 7KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base"
8 8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" 11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32" 13KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
index 18ee836a..a447b4d9 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON ?= ""
4
3LINUX_VERSION_i586-nlp-32-intel-common = "4.1.39" 5LINUX_VERSION_i586-nlp-32-intel-common = "4.1.39"
4SRCREV_meta_i586-nlp-32-intel-common = "a867edab415f0ddc1a0d8da6ddb43c8afa9611dd" 6SRCREV_meta_i586-nlp-32-intel-common = "a867edab415f0ddc1a0d8da6ddb43c8afa9611dd"
5SRCREV_machine_i586-nlp-32-intel-common = "17e44fa855e657b2fd7bd810c42615fe6318c99b" 7SRCREV_machine_i586-nlp-32-intel-common = "17e44fa855e657b2fd7bd810c42615fe6318c99b"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
index 98d42bf3..28741825 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON ?= ""
4
3COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 5COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
index 159d8c09..d35033bc 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar" 3EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar"
4 4
5KERNEL_FEATURES_INTEL_COMMON ?= ""
6
5LINUX_VERSION_i586-nlp-32-intel-common = "4.4.60" 7LINUX_VERSION_i586-nlp-32-intel-common = "4.4.60"
6LINUX_VERSION_core2-32-intel-common = "4.4.60" 8LINUX_VERSION_core2-32-intel-common = "4.4.60"
7LINUX_VERSION_corei7-64-intel-common = "4.4.60" 9LINUX_VERSION_corei7-64-intel-common = "4.4.60"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index 92b08962..4897e088 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -6,6 +6,8 @@ SRCREV_MACHINE_INTEL_COMMON = "d2d93ffb422b65a8b66f3d24b4cd0652bec9e224"
6 6
7KBRANCH_INTEL_COMMON = "standard/intel/base" 7KBRANCH_INTEL_COMMON = "standard/intel/base"
8 8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" 11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32" 13KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.10.bbappend b/common/recipes-kernel/linux/linux-yocto_4.10.bbappend
index a09fe1a4..20504637 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.10.bbappend
@@ -1,4 +1,4 @@
1KERNEL_FEATURES_INTEL_COMMON = "" 1KERNEL_FEATURES_INTEL_COMMON ?= ""
2 2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32" 4KMACHINE_core2-32-intel-common = "intel-core2-32"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
index 2c853818..01359828 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -6,6 +6,8 @@ SRCREV_MACHINE_INTEL_COMMON = "2cc78e92f40522d8b5f278b7099c1ae657947749"
6 6
7KBRANCH_INTEL_COMMON = "standard/intel/base" 7KBRANCH_INTEL_COMMON = "standard/intel/base"
8 8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" 11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32" 13KMACHINE_core2-32-intel-common = "intel-core2-32"