summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-04-14 09:51:39 -0700
committerSaul Wold <sgw@linux.intel.com>2017-04-17 10:11:00 -0700
commit45bd09ccc2fe6675079979579ba22740e161ccbb (patch)
treed2f57c82407f0b8506f3cbf522accdd6c8458fa3
parentb275a11389f3fd8366b1947450a75a546417a5b0 (diff)
downloadmeta-intel-45bd09ccc2fe6675079979579ba22740e161ccbb.tar.gz
linux-intel-rt: Add recipe to support preempt-rt kernel
This adds the linux-intel production kernel to meta-intel with the base-rt branch. Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
new file mode 100644
index 00000000..ab723cca
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -0,0 +1,40 @@
1
2require recipes-kernel/linux/linux-yocto.inc
3
4# Skip processing of this recipe if it is not explicitly specified as the
5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
6# to build multiple virtual/kernel providers, e.g. as dependency of
7# core-image-rt-sdk, core-image-rt.
8python () {
9 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
11}
12
13KBRANCH = "base-rt"
14SRCREV_machine ?= "847b27d4831aa7271ec0ffc4c41cfca46491a305"
15SRCREV_meta ?= "803b8d600e45afa0375459bf599fe365571a3866"
16
17SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.9.20"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24KMETA = "kernel-meta"
25KCONF_BSP_AUDIT_LEVEL = "2"
26
27LINUX_KERNEL_TYPE = "preempt-rt"
28KERNEL_FEATURES_INTEL_COMMON = ""
29
30COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
31KMACHINE_core2-32-intel-common = "intel-core2-32"
32KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
33
34COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
35KMACHINE_corei7-64-intel-common = "intel-corei7-64"
36KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
37
38COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
39KMACHINE_i586-nlp-32-intel-common = "intel-quark"
40KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""