summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-09-22 14:09:33 -0700
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-10-02 14:11:34 -0700
commit63de2abadfa8164e28575e412e2bd9c315840ddb (patch)
tree942c1c0751601eddf0707c5cf17a9fa69872ba33
parent78e6dbcd283d898719a689f44d000f0787c55824 (diff)
downloadmeta-intel-63de2abadfa8164e28575e412e2bd9c315840ddb.tar.gz
disable_skylake_sound: Temp disable config for core2-32
This is needed because the current kernel has a missing kernel config check for 32bit skylake sound Commit 0d590c4be300365a2d1787fcea767ac41c741875 upstream. Signed-off-by: Saul Wold <sgw@linux.intel.com> [reworked for pyro] Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-intel-rt_4.9.bb4
-rw-r--r--common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg14
-rw-r--r--common/recipes-kernel/linux/linux-intel_4.9.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
index dee89396..0bf8f837 100644
--- a/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -14,9 +14,13 @@ KBRANCH = "base-rt"
14SRCREV_machine ?= "fc08e0615edccfb4d297c07531451cb7905fb4f4" 14SRCREV_machine ?= "fc08e0615edccfb4d297c07531451cb7905fb4f4"
15SRCREV_meta ?= "3ddaed3671efc2936efbebf4c5216e11b9dfd55d" 15SRCREV_meta ?= "3ddaed3671efc2936efbebf4c5216e11b9dfd55d"
16 16
17FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
18
17SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \ 19SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}" 20 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
19 21
22SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
23
20LINUX_VERSION ?= "4.9.47" 24LINUX_VERSION ?= "4.9.47"
21LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}" 25LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
22 26
diff --git a/common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg b/common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg
new file mode 100644
index 00000000..f7d7322e
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-intel/disable_skylake_sound.cfg
@@ -0,0 +1,14 @@
1# CONFIG_SND_SOC_INTEL_SKYLAKE is not set
2# CONFIG_SND_SOC_INTEL_BXT_DA7219_MAX98357A_MACH is not set
3# CONFIG_SND_SOC_INTEL_BXT_FLORIDA_MACH is not set
4# CONFIG_SND_SOC_INTEL_BXT_RT298_MACH is not set
5# CONFIG_SND_SOC_INTEL_BXT_TDF8532_MACH is not set
6# CONFIG_SND_SOC_INTEL_KBL_RT5663_MAX98927_MACH is not set
7# CONFIG_SND_SOC_INTEL_SKL_RT286_MACH is not set
8# CONFIG_SND_SOC_INTEL_CNL_WM8281_MACH is not set
9# CONFIG_SND_SOC_INTEL_CNL_RT274_MACH is not set
10# CONFIG_SND_SOC_INTEL_SKL_NAU88L25_SSM4567_MACH is not set
11# CONFIG_SND_SOC_INTEL_SKL_NAU88L25_MAX98357A_MACH is not set
12# CONFIG_SND_SOC_INTEL_CNL_CS42L42_MACH is not set
13# CONFIG_SND_SOC_INTEL_CNL_RT700_MACH is not set
14# CONFIG_SND_SOC_INTEL_CNL_SVFPGA_MACH is not set
diff --git a/common/recipes-kernel/linux/linux-intel_4.9.bb b/common/recipes-kernel/linux/linux-intel_4.9.bb
index 106125a1..5a750a33 100644
--- a/common/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/common/recipes-kernel/linux/linux-intel_4.9.bb
@@ -8,6 +8,8 @@ SRCREV_meta ?= "3ddaed3671efc2936efbebf4c5216e11b9dfd55d"
8SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \ 8SRC_URI = "git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \
9 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}" 9 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA}"
10 10
11SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
12
11LINUX_VERSION ?= "4.9.47" 13LINUX_VERSION ?= "4.9.47"
12LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}" 14LINUX_VERSION_EXTENSION = "-intel-pk-${LINUX_KERNEL_TYPE}"
13 15