summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-05-01 15:30:20 -0500
committerSaul Wold <sgw@linux.intel.com>2017-05-09 23:29:50 +0800
commit4b83cea79a662d8061211b0db6d465cd474a974a (patch)
treea2711ca6e22d3db907c66229e1a0b25ea933b7c0
parentca8695a4fd9bb7e5ed8636fc2070108085c56433 (diff)
downloadmeta-intel-4b83cea79a662d8061211b0db6d465cd474a974a.tar.gz
thermald,iucode-tool,libyami: Add UPSTREAM_CHECK_ variables
These variables are used by checkpkg task to figure out if there are a new version of the upstream software. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-bsp/thermald/thermald_1.5.4.bb2
-rw-r--r--common/recipes-core/microcode/iucode-tool_2.1.1.bb2
-rwxr-xr-xcommon/recipes-multimedia/libyami/libyami-utils_1.1.0.bb2
-rwxr-xr-xcommon/recipes-multimedia/libyami/libyami_1.1.0.bb3
4 files changed, 9 insertions, 0 deletions
diff --git a/common/recipes-bsp/thermald/thermald_1.5.4.bb b/common/recipes-bsp/thermald/thermald_1.5.4.bb
index 81b1b314..9bde8966 100644
--- a/common/recipes-bsp/thermald/thermald_1.5.4.bb
+++ b/common/recipes-bsp/thermald/thermald_1.5.4.bb
@@ -31,3 +31,5 @@ CONFFILES_${PN} = " \
31 ${sysconfdir}/thermald/thermal-conf.xml \ 31 ${sysconfdir}/thermald/thermal-conf.xml \
32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \ 32 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
33 " 33 "
34
35UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"
diff --git a/common/recipes-core/microcode/iucode-tool_2.1.1.bb b/common/recipes-core/microcode/iucode-tool_2.1.1.bb
index 5b216992..66cb0f94 100644
--- a/common/recipes-core/microcode/iucode-tool_2.1.1.bb
+++ b/common/recipes-core/microcode/iucode-tool_2.1.1.bb
@@ -29,3 +29,5 @@ inherit autotools
29BBCLASSEXTEND = "native" 29BBCLASSEXTEND = "native"
30 30
31COMPATIBLE_HOST = "(i.86|x86_64).*-linux" 31COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
32
33UPSTREAM_CHECK_URI = "https://gitlab.com/iucode-tool/releases"
diff --git a/common/recipes-multimedia/libyami/libyami-utils_1.1.0.bb b/common/recipes-multimedia/libyami/libyami-utils_1.1.0.bb
index b069628c..4c1dceb9 100755
--- a/common/recipes-multimedia/libyami/libyami-utils_1.1.0.bb
+++ b/common/recipes-multimedia/libyami/libyami-utils_1.1.0.bb
@@ -28,3 +28,5 @@ PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
28# gles-tests fail to build without x11: see https://github.com/01org/libyami-utils/issues/91 28# gles-tests fail to build without x11: see https://github.com/01org/libyami-utils/issues/91
29PACKAGECONFIG[x11] = "--enable-x11 --enable-tests-gles,--disable-x11 --disable-tests-gles, virtual/libx11" 29PACKAGECONFIG[x11] = "--enable-x11 --enable-tests-gles,--disable-x11 --disable-tests-gles, virtual/libx11"
30 30
31UPSTREAM_CHECK_URI = "http://github.com/01org/libyami-utils/releases"
32UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
diff --git a/common/recipes-multimedia/libyami/libyami_1.1.0.bb b/common/recipes-multimedia/libyami/libyami_1.1.0.bb
index 077c2116..8efd6f9e 100755
--- a/common/recipes-multimedia/libyami/libyami_1.1.0.bb
+++ b/common/recipes-multimedia/libyami/libyami_1.1.0.bb
@@ -22,3 +22,6 @@ DEPENDS = "libva"
22inherit autotools pkgconfig distro_features_check 22inherit autotools pkgconfig distro_features_check
23 23
24REQUIRED_DISTRO_FEATURES = "opengl" 24REQUIRED_DISTRO_FEATURES = "opengl"
25
26UPSTREAM_CHECK_URI = "https://github.com/01org/libyami/releases"
27UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"