summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-10-26 13:22:16 -0700
committerSaul Wold <sgw@linux.intel.com>2017-10-27 13:45:23 -0700
commit137538e6ff65801447e7ae8f75b920b4f4f007fc (patch)
tree4a8b6da31c6ebd25b02489a47e0354ac7120dc4a
parent0d8dccd149d4952eb8d70a0a5920309a645d21b3 (diff)
downloadmeta-intel-137538e6ff65801447e7ae8f75b920b4f4f007fc.tar.gz
lttng-modules: Fix issue related to -rt kernel
The -rt kernel requires that lttng has a patch This issue has been fixed upstream [YOCTO #12278] - This is pyro only Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/lttng/lttng-modules/0002-sched_pi_setprio-tracing-function-failed-to-compile-.patch55
-rw-r--r--common/recipes-kernel/lttng/lttng-modules_%.bbappend4
2 files changed, 58 insertions, 1 deletions
diff --git a/common/recipes-kernel/lttng/lttng-modules/0002-sched_pi_setprio-tracing-function-failed-to-compile-.patch b/common/recipes-kernel/lttng/lttng-modules/0002-sched_pi_setprio-tracing-function-failed-to-compile-.patch
new file mode 100644
index 00000000..c58a59c3
--- /dev/null
+++ b/common/recipes-kernel/lttng/lttng-modules/0002-sched_pi_setprio-tracing-function-failed-to-compile-.patch
@@ -0,0 +1,55 @@
1From 97c079142cc7386e32d34a129c2734ab05ea2f09 Mon Sep 17 00:00:00 2001
2From: Priyalee Kushwaha <priyalee.kushwaha@intel.com>
3Date: Wed, 7 Jun 2017 09:39:59 -0700
4Subject: [PATCH] sched_pi_setprio : tracing function failed to compile with RT
5 patches
6
7sched_pi_setprio tracing function shows compilation failure with
84.9.30 kernel with RT patches. one of RT patch redefines
9sched_pi_setprio in kernel.
10
11Upstream-Status: Backport
12
13Signed-off-by: Dwane Pottratz <dwane.pottratz@intel.com>
14Signed-off-by: Kushwaha, Priyalee <priyalee.kushwaha@intel.com>
15Signed-off-by: Weight, Russell H <russell.h.weight@intel.com>
16---
17 instrumentation/events/lttng-module/sched.h | 15 +++++++++++++++
18 1 file changed, 15 insertions(+)
19
20diff --git a/instrumentation/events/lttng-module/sched.h b/instrumentation/events/lttng-module/sched.h
21index 0738ff0..8d117c6 100644
22--- a/instrumentation/events/lttng-module/sched.h
23+++ b/instrumentation/events/lttng-module/sched.h
24@@ -545,6 +545,20 @@ LTTNG_TRACEPOINT_EVENT(sched_stat_runtime,
25 * Tracepoint for showing priority inheritance modifying a tasks
26 * priority.
27 */
28+#ifdef CONFIG_PREEMPT_RT_BASE
29+LTTNG_TRACEPOINT_EVENT(sched_pi_setprio,
30+
31+ TP_PROTO(struct task_struct *tsk, struct task_struct *pi_task),
32+
33+ TP_ARGS(tsk, pi_task),
34+ TP_FIELDS(
35+ ctf_array_text(char, comm, tsk->comm, TASK_COMM_LEN)
36+ ctf_integer(pid_t, tid, tsk->pid)
37+ ctf_integer(int, oldprio, tsk->prio - MAX_RT_PRIO)
38+ ctf_integer(int, newprio, pi_task ? pi_task->prio : tsk->prio)
39+ )
40+)
41+#else
42 LTTNG_TRACEPOINT_EVENT(sched_pi_setprio,
43
44 TP_PROTO(struct task_struct *tsk, int newprio),
45@@ -559,6 +573,7 @@ LTTNG_TRACEPOINT_EVENT(sched_pi_setprio,
46 )
47 )
48 #endif
49+#endif
50
51 #endif /* LTTNG_TRACE_SCHED_H */
52
53--
542.10.0
55
diff --git a/common/recipes-kernel/lttng/lttng-modules_%.bbappend b/common/recipes-kernel/lttng/lttng-modules_%.bbappend
index b65d0db6..64dfbeeb 100644
--- a/common/recipes-kernel/lttng/lttng-modules_%.bbappend
+++ b/common/recipes-kernel/lttng/lttng-modules_%.bbappend
@@ -3,5 +3,7 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
3 3
4LTTNG_PATCH = "${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/kernel','linux-intel linux-intel-rt','file://0002-lttng-modules-PKT-4.9-yocto-build-failed.patch','',d)}" 4LTTNG_PATCH = "${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/kernel','linux-intel linux-intel-rt','file://0002-lttng-modules-PKT-4.9-yocto-build-failed.patch','',d)}"
5 5
6SRC_URI += "${LTTNG_PATCH}" 6LTTNG_PATCH += "${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/kernel','linux-intel-rt','file://0002-sched_pi_setprio-tracing-function-failed-to-compile-.patch','',d)}"
7
8SRC_URI_append_intel-x86-common = " ${LTTNG_PATCH}"
7 9