summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYong Li <yong.b.li@intel.com>2016-07-07 16:38:38 +0800
committerTom Zanussi <tom.zanussi@linux.intel.com>2016-07-07 17:13:36 -0500
commitd037f2add48ae9e325fa59aaec8c910ff91dac1e (patch)
treecbed94c18553ba81dd4f7f7900121ef112ec6798
parente50f5ab8293ad428345178e2102861f59611e8fd (diff)
downloadmeta-intel-d037f2add48ae9e325fa59aaec8c910ff91dac1e.tar.gz
thermald: Add thermal daemon utility
This user space thermal daemon utility is used for thermal management. Signed-off-by: Yong Li <yong.b.li@intel.com> Acked-by: Saul Wold <sgw@linux.intel.com> Tested-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
-rw-r--r--common/recipes-bsp/thermald/thermald_1.5.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/recipes-bsp/thermald/thermald_1.5.3.bb b/common/recipes-bsp/thermald/thermald_1.5.3.bb
new file mode 100644
index 00000000..cb2b07ea
--- /dev/null
+++ b/common/recipes-bsp/thermald/thermald_1.5.3.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib libxml2 glib-2.0"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11
12LICENSE = "GPL-2.0"
13LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
14
15SRC_URI = "https://github.com/01org/thermal_daemon/archive/v${PV}.tar.gz"
16SRC_URI[md5sum] = "66402236ed3c86a798029cb4d5313817"
17SRC_URI[sha256sum] = "e20b450ef27a5b5e45474c831663c8f5ecd14c82ace5a4b1e06c442e0a23b53e"
18
19S = "${WORKDIR}/thermal_daemon-${PV}"
20
21inherit pkgconfig autotools systemd
22
23FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
24
25SYSTEMD_SERVICE_${PN} = "thermald.service"
26
27COMPATIBLE_HOST = '(i.86|x86_64).*-linux'