summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-10-05 16:01:20 -0700
committerSaul Wold <sgw@linux.intel.com>2016-10-07 13:39:13 -0700
commit9052773016727a9398d1e6b6830dc94f3203f754 (patch)
tree8d9e0de4d56d1371d9e413ea4c17ce2508500568
parentc0dad5d5f4e42d4c9be928e6ba48a7989fac1d8a (diff)
downloadmeta-intel-9052773016727a9398d1e6b6830dc94f3203f754.tar.gz
linux-yocto/4.8: Bump SRCREVs to v4.8 and add preempt-rt recipe
This updates the linux-yocto 4.8 bbappends to use the 4.8 final kernel. Also, we finally add the preempt-rt recipe since the rt patches are available with no obvious defects. v2 changes: * Add backport patch "Using BUG_ON() as an assert() is _never_ acceptable" Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.8.bbappend31
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend6
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.8.bbappend6
3 files changed, 37 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.8.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.8.bbappend
new file mode 100644
index 00000000..7ae72683
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.8.bbappend
@@ -0,0 +1,31 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.8"
4SRCREV_META_INTEL_COMMON ?= "6128a9e47cd1aeb46b604469c17bff3eba8d5f93"
5SRCREV_MACHINE_INTEL_COMMON ?= "b266f7ba78f0cb3d7073e1bf7bd7dfc92bec7431"
6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt/base"
8
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32"
12KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
13SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
14SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
15KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
16
17LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
18COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
19KMACHINE_corei7-64-intel-common = "intel-corei7-64"
20KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
21SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
22SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
23KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
24
25LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
26COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
27KMACHINE_i586-nlp-32-intel-common = "intel-quark"
28KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
29SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
30SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
31KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend
index 2276ed51..6b7205e8 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.8.bbappend
@@ -1,8 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_i586-nlp-32-intel-common = "4.8.0-rc4" 3LINUX_VERSION_i586-nlp-32-intel-common = "4.8"
4SRCREV_meta_i586-nlp-32-intel-common = "8cb7317502c2577f8c83eaf1c061603023824313" 4SRCREV_meta_i586-nlp-32-intel-common = "6128a9e47cd1aeb46b604469c17bff3eba8d5f93"
5SRCREV_machine_i586-nlp-32-intel-common = "3eab887a55424fc2c27553b7bfe32330df83f7b8" 5SRCREV_machine_i586-nlp-32-intel-common = "67813e7efa3a4614e209c2f058d92ef9a636441a"
6 6
7COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
8KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base" 8KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.8.bbappend b/common/recipes-kernel/linux/linux-yocto_4.8.bbappend
index 412accf9..726f03e9 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.8.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.8.bbappend
@@ -1,8 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.8.0-rc4" 3LINUX_VERSION_INTEL_COMMON = "4.8"
4SRCREV_META_INTEL_COMMON = "8cb7317502c2577f8c83eaf1c061603023824313" 4SRCREV_META_INTEL_COMMON = "6128a9e47cd1aeb46b604469c17bff3eba8d5f93"
5SRCREV_MACHINE_INTEL_COMMON = "a7d71794e4e38d2f861c1b1dbff761ae0b0836b3" 5SRCREV_MACHINE_INTEL_COMMON = "67813e7efa3a4614e209c2f058d92ef9a636441a"
6 6
7KBRANCH_INTEL_COMMON = "standard/base" 7KBRANCH_INTEL_COMMON = "standard/base"
8 8