summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2047-10-21 11:59:02 +0800
committerTom Zanussi <tom.zanussi@linux.intel.com>2016-07-22 13:37:07 -0500
commit783068714319922038437bec1ea271f18d4eb153 (patch)
tree8b9545912e63839f39c75d3124ff81c2ee950f75
parent1827f6aa3048c61e6d6f174016fb61a614dbf3eb (diff)
downloadmeta-intel-783068714319922038437bec1ea271f18d4eb153.tar.gz
meta-isg: dpdk: fix compilation with dynamic libs
Ensure that the correct CFLAGS are passed to LD when compiling rte libs as shared. For building the dpdk with config CONFIG_RTE_BUILD_SHARED_LIB=y Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk.inc1
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk.inc b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
index b1b56c92..6f3593bc 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk.inc
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
@@ -9,6 +9,7 @@ SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
9 file://dpdk-16.04-point-to-the-right-include-and-lib-path.patch \ 9 file://dpdk-16.04-point-to-the-right-include-and-lib-path.patch \
10 file://dpdk-16.04-Fix-for-misleading-indentation-error.patch \ 10 file://dpdk-16.04-Fix-for-misleading-indentation-error.patch \
11 file://dpdk-16.04-dpdk-fix-installation-warning-and-issue.patch \ 11 file://dpdk-16.04-dpdk-fix-installation-warning-and-issue.patch \
12 file://dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch \
12 " 13 "
13 14
14COMPATIBLE_MACHINE = "crystalforest|intel-corei7-64" 15COMPATIBLE_MACHINE = "crystalforest|intel-corei7-64"
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch
new file mode 100644
index 00000000..4254d073
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-16.04-dpdk-fix-compilation-with-dynamic-libs.patch
@@ -0,0 +1,30 @@
1From 8ce0e3249942a90f733bb2113e70e5a90ae67b00 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Thu, 21 Jul 2016 05:53:52 +0800
4Subject: [PATCH 1/2] dpdk: fix compilation with dynamic libs
5
6Upstream-Status: Inappropriate [Configuration]
7
8Ensure that the correct cflags are being used.
9
10Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
11---
12 mk/rte.lib.mk | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/mk/rte.lib.mk b/mk/rte.lib.mk
16index 8f7e021..42610c9 100644
17--- a/mk/rte.lib.mk
18+++ b/mk/rte.lib.mk
19@@ -70,7 +70,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
20
21 ifeq ($(LINK_USING_CC),1)
22 # Override the definition of LD here, since we're linking with CC
23-LD := $(CC) $(CPU_CFLAGS)
24+LD := $(CC) $(CPU_CFLAGS) $(EXTRA_CFLAGS)
25 _CPU_LDFLAGS := $(call linkerprefix,$(CPU_LDFLAGS))
26 override EXTRA_LDFLAGS := $(call linkerprefix,$(EXTRA_LDFLAGS))
27 else
28--
291.9.1
30