summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2016-11-02 13:38:24 -0700
committerSaul Wold <sgw@linux.intel.com>2016-11-02 16:31:53 -0700
commit1484a008eb141b0de3e28a8eedbd1cad41f2bb6f (patch)
tree6b6f94aaf535e8c8419738d5b070d3b40f470303
parentf621b952fc464aa0b08007b3c68c0693812f34c1 (diff)
downloadmeta-intel-1484a008eb141b0de3e28a8eedbd1cad41f2bb6f.tar.gz
systemd-boot: Make use of new override
Add the new intel-x86-common to the meta-data in order to limit the changes when the meta-intel layer is included without using meta-intel machines. Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot.bbappend11
1 files changed, 7 insertions, 4 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
index 0da0c46a..ed317554 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
+++ b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
@@ -1,8 +1,8 @@
1DEPENDS += "rmc" 1DEPENDS_append_intel-x86-common = " rmc"
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-boot:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-boot:"
4 4
5EXTRA_OEMAKE += 'EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc/efi -DRMC_EFI"' 5EXTRA_OEMAKE_append_intel-x86-common = ' EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STAGING_INCDIR}/rmc/efi -DRMC_EFI"'
6 6
7# Pin systemd revision down for systemd-boot recipe. 7# Pin systemd revision down for systemd-boot recipe.
8# Patches could not be applied cleanly when systemd in OE is updated, 8# Patches could not be applied cleanly when systemd in OE is updated,
@@ -12,10 +12,13 @@ EXTRA_OEMAKE += 'EFI_LDFLAGS="-L${STAGING_DIR_HOST}/usr/lib" EFI_CFLAGS="-I${STA
12# resolving conflicts for a new tip could be done in a short time. 12# resolving conflicts for a new tip could be done in a short time.
13 13
14# Revision: systemd 230 in OE 14# Revision: systemd 230 in OE
15SRCREV = "3a74d4fc90cb322a4784a3515bef7118c8f8c5ba" 15SRCREV_intel-x86-common = "3a74d4fc90cb322a4784a3515bef7118c8f8c5ba"
16 16
17SRC_URI += "file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \ 17SRC_URI_append_intel-x86-common = " \
18 file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \
18 file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \ 19 file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \
19 file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \ 20 file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \
20 file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \ 21 file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \
21 " 22 "
23
24PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"