summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2023-03-28 09:48:05 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-03-28 09:57:00 +0800
commit2b37e2a69cfe0a46c3f52c7f333a9a60b03dcdc3 (patch)
tree530cc396eb0d7ed3b2bf5f1b3fc6d9804f5f48f1
parentc88dfd9a79efd3b9074891ba40d4b48bbd421a8a (diff)
downloadmeta-intel-2b37e2a69cfe0a46c3f52c7f333a9a60b03dcdc3.tar.gz
openvkl: disable avx ISAs for intel-corei7-64 machine
It enables them by default instead of checking based on what is supported. openvklTest throws following error: SIGILL - Illegal instruction signal Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.3.2.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.3.2.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.3.2.bb
index 3e4113f0..6eca2172 100644
--- a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.3.2.bb
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.3.2.bb
@@ -30,6 +30,12 @@ DEPENDS = "ispc-native rkcommon embree"
30EXTRA_OECMAKE += " \ 30EXTRA_OECMAKE += " \
31 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \ 31 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \
32 " 32 "
33EXTRA_OECMAKE:intel-corei7-64 += " \
34 -DOPENVKL_ISA_AVX=OFF \
35 -DOPENVKL_ISA_AVX2=OFF \
36 -DOPENVKL_ISA_AVX512SKX=OFF \
37 "
38
33PACKAGES =+ "${PN}-examples" 39PACKAGES =+ "${PN}-examples"
34FILES:${PN}-examples = "\ 40FILES:${PN}-examples = "\
35 ${bindir} \ 41 ${bindir} \