summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-04-24 13:38:36 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-04-24 14:14:16 +0800
commitc641b6483297c6377c6b4fd9a9684c3b8dd694ea (patch)
treed966ef9287caeb4c21fda7bdaa717539cdfd185b
parent35a1fac85f0e8052f43f5d4fa33e2a2051b2ca81 (diff)
downloadmeta-intel-c641b6483297c6377c6b4fd9a9684c3b8dd694ea.tar.gz
intel-graphics-compiler: link to llvm conditionally
In order to use this recipe with zeus, link to llvm based on LLVMVERSION. In zeus release, LLVMVERSION points to 9.x. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
index 6cfa0b6d..93484c47 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
@@ -25,7 +25,9 @@ DEPENDS_append_class-target = " clang-cross-x86_64"
25 25
26RDEPENDS_${PN} += "opencl-clang" 26RDEPENDS_${PN} += "opencl-clang"
27 27
28EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=10.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3" 28LLVM_COMPAT_VER = "${@bb.utils.contains('LLVMVERSION', '9.0.1', '9.0.0', '10.0.0', d)}"
29
30EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VER} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
29 31
30BBCLASSEXTEND = "native nativesdk" 32BBCLASSEXTEND = "native nativesdk"
31 33