summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-05-11 13:46:52 -0700
committerSaul Wold <sgw@linux.intel.com>2015-05-12 13:12:10 -0700
commitf9738ec19d3b2864c0bd71b9bb3418d16e922a12 (patch)
treeec8faa3d1c663308aae8523c9e9517ae7699626f
parentafbba3222cb66c92d43e458330055f06380e29f0 (diff)
downloadmeta-intel-f9738ec19d3b2864c0bd71b9bb3418d16e922a12.tar.gz
lttng-modules: add bbappend to address 3.19.5 update3.0-fido-1.8
The 3.19.5 kernel update included an incompatible change that caused lttng-modules to fail to build, the patch needed to be rebased due to changes in the associated Makefile. Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch71
-rw-r--r--common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend9
2 files changed, 80 insertions, 0 deletions
diff --git a/common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
new file mode 100644
index 00000000..ccc6c54f
--- /dev/null
+++ b/common/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
@@ -0,0 +1,71 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3lttng-modules: replace KERNELDIR with KERNEL_SRC
4
5Since lttng-modules uses the default way of module.bbclass to
6build and install lttng-modules, we do this replacement for
7it as-is.
8
9Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com>
10[sgw - rebased for 2.6.1]
11Signed-off-by: Saul wold <sgw@linux.intel.com>
12
13Index: git/Makefile
14===================================================================
15--- git.orig/Makefile
16+++ git/Makefile
17@@ -68,19 +68,19 @@ obj-m += lib/
18 endif # CONFIG_TRACEPOINTS
19
20 else # KERNELRELEASE
21- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
22- PWD := $(shell pwd)
23- CFLAGS = $(EXTCFLAGS)
24-
25+ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
26+ PWD := $(shell pwd)
27+ CFLAGS = $(EXTCFLAGS)
28+
29 default:
30- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
31+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
32
33 modules_install:
34- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
35+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
36
37 clean:
38- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
39+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
40
41 %.i: %.c
42- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) $@
43+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) $@
44 endif # KERNELRELEASE
45Index: git/probes/Makefile
46===================================================================
47--- git.orig/probes/Makefile
48+++ git/probes/Makefile
49@@ -267,18 +267,18 @@ endif
50 endif
51
52 else
53- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
54+ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
55 PWD := $(shell pwd)
56 CFLAGS = $(EXTCFLAGS)
57
58 default:
59- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
60+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
61
62 modules_install:
63- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
64+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
65 /sbin/depmod -a
66
67 clean:
68- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
69+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
70
71 endif
diff --git a/common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend b/common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend
new file mode 100644
index 00000000..6d88e305
--- /dev/null
+++ b/common/recipes-kernel/lttng/lttng-modules_2.6.%.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRCREV = "62080b2248fd8ec4111ffc379d0bc5eaf0a5c16d"
4
5#SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6 \
6# file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
7# "
8
9