summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosep Puigdemont <josep.puigdemont@enea.com>2014-07-17 18:36:31 +0200
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-09-02 16:05:02 -0500
commitb89a7c533df4fa17d8c239e674b0af83253a65b6 (patch)
treedd59fdf2647ea60a5571a650d501104ebc5f65cb
parent00de64dbe0563dfaf21679e2902a56f62a039df4 (diff)
downloadmeta-intel-b89a7c533df4fa17d8c239e674b0af83253a65b6.tar.gz
linux-yocto: Use _append when overrides are used
Some modules in the KERNEL_MODULE_AUTOLOAD list were removed when including the meta-intel layer. It turns out the problem happens due to using the += operator together with machine overrides. Using _append_machine fixes this. Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Acked-By: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend8
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend8
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend8
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend4
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend4
-rw-r--r--meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend4
6 files changed, 18 insertions, 18 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index bfb5f62a..554bd624 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -19,9 +19,9 @@ KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}
19# default SRCREV is set and linux-yocto-dev is the preferred provider. 19# default SRCREV is set and linux-yocto-dev is the preferred provider.
20 20
21# For Crystalforest and Romley 21# For Crystalforest and Romley
22KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio" 22KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
23KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio" 23KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
24 24
25# For FRI2, NUC 25# For FRI2, NUC
26KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi" 26KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
27KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi" 27KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index a142e5be..19af3671 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -21,9 +21,9 @@ KBRANCH_corei7-64-intel-common = "standard/base"
21KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 21KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
22 22
23# For Crystalforest and Romley 23# For Crystalforest and Romley
24KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio" 24KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
25KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio" 25KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
26 26
27# For FRI2, NUC 27# For FRI2, NUC
28KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi" 28KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
29KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi" 29KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
index a0ca5fcd..b367adb4 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -20,9 +20,9 @@ KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21 21
22# For Crystalforest and Romley 22# For Crystalforest and Romley
23KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio" 23KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
24KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio" 24KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
25 25
26# For FRI2, NUC 26# For FRI2, NUC
27KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi" 27KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
28KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi" 28KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
index e57449f9..25361e88 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -12,5 +12,5 @@ KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2"
12SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" 12SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64"
13#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" 13#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX"
14 14
15KERNEL_MODULE_AUTOLOAD_fri2 += "iwlwifi" 15KERNEL_MODULE_AUTOLOAD_append_fri2 = " iwlwifi"
16KERNEL_MODULE_AUTOLOAD_fri2-noemgd += "iwlwifi" 16KERNEL_MODULE_AUTOLOAD_append_fri2-noemgd = " iwlwifi"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
index a4732f21..bfbb7540 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -18,5 +18,5 @@ LINUX_VERSION_fri2-noemgd = "3.10.38"
18SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" 18SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473"
19SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" 19SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388"
20 20
21KERNEL_MODULE_AUTOLOAD_fri2 += "iwlwifi" 21KERNEL_MODULE_AUTOLOAD_append_fri2 = " iwlwifi"
22KERNEL_MODULE_AUTOLOAD_fri2-noemgd += "iwlwifi" 22KERNEL_MODULE_AUTOLOAD_append_fri2-noemgd = " iwlwifi"
diff --git a/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend
index c691a424..7e7f05f9 100644
--- a/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -32,5 +32,5 @@ SRCREV_valleyisland-io_valleyisland-64 = "8ea4fb625f2654bbdd5dfcb9db67328d21ebe5
32 32
33SRC_URI_valleyisland-64 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},valleyisland-io-1.0;name=machine,meta,valleyisland-io" 33SRC_URI_valleyisland-64 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},valleyisland-io-1.0;name=machine,meta,valleyisland-io"
34 34
35KERNEL_MODULE_AUTOLOAD_valleyisland-32 += "i2c-dev" 35KERNEL_MODULE_AUTOLOAD_append_valleyisland-32 = " i2c-dev"
36KERNEL_MODULE_AUTOLOAD_valleyisland-64 += "i2c-dev" 36KERNEL_MODULE_AUTOLOAD_append_valleyisland-64 = " i2c-dev"