summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2015-07-10 05:11:54 +0200
committerGeorge Nita <george.nita@enea.com>2015-07-10 05:11:54 +0200
commit8292f22ea94554d4d8ffb58ca96d8c3c12543dd0 (patch)
tree436baa2a65a1eae5da834cd6ef5306f4372e773e
parent6098c21c68145a054bf04f8706d780007c254048 (diff)
parent6b3837170bfda7ce9df409c10e05f66f4b987a89 (diff)
downloadmeta-intel-8292f22ea94554d4d8ffb58ca96d8c3c12543dd0.tar.gz
Merge remote-tracking branch 'origin/master' into master-enea
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend8
-rw-r--r--conf/machine/include/intel-quark-common.inc7
-rw-r--r--conf/machine/intel-quark.conf28
3 files changed, 43 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index 554bd624..75cd2809 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -14,6 +14,14 @@ KMACHINE_corei7-64-intel-common = "intel-corei7-64"
14KBRANCH_corei7-64-intel-common = "standard/base" 14KBRANCH_corei7-64-intel-common = "standard/base"
15KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 15KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
16 16
17# Quark / X1000 BSP Info
18LINUX_VERSION_i586-nlp-32-intel-common = "4.1"
19COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
20KMACHINE_i586-nlp-32-intel-common = "intel-quark"
21KBRANCH_i586-nlp-32-intel-common = "standard/base"
22KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
23#KCONFIG_MODE_i586-nlp-32-intel-common = "--allnoconfig"
24
17# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV 25# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV
18# and setting them here breaks the default mechanism to use AUTOREV if the 26# and setting them here breaks the default mechanism to use AUTOREV if the
19# default SRCREV is set and linux-yocto-dev is the preferred provider. 27# default SRCREV is set and linux-yocto-dev is the preferred provider.
diff --git a/conf/machine/include/intel-quark-common.inc b/conf/machine/include/intel-quark-common.inc
new file mode 100644
index 00000000..e2d34d70
--- /dev/null
+++ b/conf/machine/include/intel-quark-common.inc
@@ -0,0 +1,7 @@
1#
2# Common configuration for all MACHINES of the intel-corei7-64 type
3#
4
5DEFAULTTUNE ?= "i586-nlp-32"
6require conf/machine/include/tune-i586-nlp.inc
7require conf/machine/include/x86-base.inc
diff --git a/conf/machine/intel-quark.conf b/conf/machine/intel-quark.conf
new file mode 100644
index 00000000..b59e5664
--- /dev/null
+++ b/conf/machine/intel-quark.conf
@@ -0,0 +1,28 @@
1#@TYPE: Machine
2#@NAME: quark
3
4#@DESCRIPTION: Machine configuration for Quark systems
5
6require conf/machine/include/meta-intel.inc
7require conf/machine/include/intel-quark-common.inc
8require conf/machine/include/intel-common-pkgarch.inc
9
10# Use dev kernel which is 4.1 based currently
11PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-dev"
12PREFERRED_PROVIDER_linux-yocto ?= "linux-yocto-dev"
13
14#Avoid pulling in GRUB
15MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ""
16
17MACHINE_FEATURES = "efi usb"
18MACHINE_FEATURES += "intel-ucode"
19
20MACHINE_EXTRA_RRECOMMENDS += "kernel-modules linux-firmware"
21
22SERIAL_CONSOLE = "115200 ttyS1"
23APPEND += "console=ttyS1,115200 console=tty0"
24
25EFI_PROVIDER = "gummiboot"
26
27
28