summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2015-08-20 05:12:04 +0200
committerGeorge Nita <george.nita@enea.com>2015-08-20 05:12:04 +0200
commit52b57c5f39a041f0a05aac092d142050845734c9 (patch)
tree620d8cc0cd1e2d82403e4445e58c2ea0801e62fc
parentaedac614e462f2c11ea7ce7de02e5aa2267a3e3b (diff)
parentadc8064908409d29b9f6a7f0710be400769807af (diff)
downloadmeta-intel-52b57c5f39a041f0a05aac092d142050845734c9.tar.gz
Merge remote-tracking branch 'origin/master' into master-enea
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend37
-rw-r--r--conf/machine/intel-core2-32.conf2
-rw-r--r--conf/machine/intel-corei7-64.conf2
-rw-r--r--conf/machine/intel-quark.conf9
4 files changed, 43 insertions, 7 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
new file mode 100644
index 00000000..6830e3b9
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -0,0 +1,37 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4
5LINUX_VERSION_core2-32-intel-common = "4.1.2"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/base"
9SRCREV_meta_core2-32-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
10SRCREV_machine_core2-32-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12
13LINUX_VERSION_corei7-64-intel-common = "4.1.2"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/base"
17SRCREV_meta_corei7-64-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
18SRCREV_machine_corei7-64-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21# Quark / X1000 BSP Info
22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.2"
23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
24KMACHINE_i586-nlp-32-intel-common = "intel-quark"
25KBRANCH_i586-nlp-32-intel-common = "standard/base"
26SRCREV_meta_i586-nlp-32-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
27SRCREV_machine_i586-nlp-32-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
28KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
29
30
31# For Crystalforest and Romley
32KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
33KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
34
35# For FRI2, NUC
36KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
37KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"
diff --git a/conf/machine/intel-core2-32.conf b/conf/machine/intel-core2-32.conf
index 2a7aad1f..09303e31 100644
--- a/conf/machine/intel-core2-32.conf
+++ b/conf/machine/intel-core2-32.conf
@@ -8,7 +8,7 @@ require conf/machine/include/intel-core2-32-common.inc
8require conf/machine/include/intel-common-pkgarch.inc 8require conf/machine/include/intel-common-pkgarch.inc
9 9
10PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 10PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
11PREFERRED_VERSION_linux-yocto ?= "3.19%" 11PREFERRED_VERSION_linux-yocto ?= "4.1%"
12 12
13MACHINE_FEATURES += "pcbios efi" 13MACHINE_FEATURES += "pcbios efi"
14MACHINE_FEATURES += "va-impl-intel" 14MACHINE_FEATURES += "va-impl-intel"
diff --git a/conf/machine/intel-corei7-64.conf b/conf/machine/intel-corei7-64.conf
index d1d43082..cc16d621 100644
--- a/conf/machine/intel-corei7-64.conf
+++ b/conf/machine/intel-corei7-64.conf
@@ -8,7 +8,7 @@ require conf/machine/include/intel-corei7-64-common.inc
8require conf/machine/include/intel-common-pkgarch.inc 8require conf/machine/include/intel-common-pkgarch.inc
9 9
10PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 10PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
11PREFERRED_VERSION_linux-yocto ?= "3.19%" 11PREFERRED_VERSION_linux-yocto ?= "4.1%"
12 12
13MACHINE_FEATURES += "pcbios efi" 13MACHINE_FEATURES += "pcbios efi"
14MACHINE_FEATURES += "va-impl-intel" 14MACHINE_FEATURES += "va-impl-intel"
diff --git a/conf/machine/intel-quark.conf b/conf/machine/intel-quark.conf
index b59e5664..7da054ec 100644
--- a/conf/machine/intel-quark.conf
+++ b/conf/machine/intel-quark.conf
@@ -7,9 +7,8 @@ require conf/machine/include/meta-intel.inc
7require conf/machine/include/intel-quark-common.inc 7require conf/machine/include/intel-quark-common.inc
8require conf/machine/include/intel-common-pkgarch.inc 8require conf/machine/include/intel-common-pkgarch.inc
9 9
10# Use dev kernel which is 4.1 based currently 10PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
11PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-dev" 11PREFERRED_VERSION_linux-yocto ?= "4.1%"
12PREFERRED_PROVIDER_linux-yocto ?= "linux-yocto-dev"
13 12
14#Avoid pulling in GRUB 13#Avoid pulling in GRUB
15MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "" 14MACHINE_ESSENTIAL_EXTRA_RDEPENDS = ""
@@ -24,5 +23,5 @@ APPEND += "console=ttyS1,115200 console=tty0"
24 23
25EFI_PROVIDER = "gummiboot" 24EFI_PROVIDER = "gummiboot"
26 25
27 26# Ensure that the Lock prefix is omitted for the kernel"
28 27KERNEL_EXTRA_ARGS = "EXTRA_CFLAGS=-Wa,-momit-lock-prefix=yes"