summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-10-07 21:45:10 +0100
committerSaul Wold <sgw@linux.intel.com>2015-10-19 08:46:22 -0700
commit258296f9d1bb91d219e8301841e132352d4c6328 (patch)
treea7571eedb8fe6b9b39ace7047c7fd19ef76a660e
parentcd5d22bb686a062e6df9ad09935f60f57dd6657b (diff)
downloadmeta-intel-258296f9d1bb91d219e8301841e132352d4c6328.tar.gz
xorg-driver: remove duplicate files from oe-core
These files are copies of files from oe-core, delete them as they are unused. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-graphics/xorg-driver/xorg-driver-common.inc33
-rw-r--r--common/recipes-graphics/xorg-driver/xorg-driver-video.inc4
2 files changed, 0 insertions, 37 deletions
diff --git a/common/recipes-graphics/xorg-driver/xorg-driver-common.inc b/common/recipes-graphics/xorg-driver/xorg-driver-common.inc
deleted file mode 100644
index 1ed2742d..00000000
--- a/common/recipes-graphics/xorg-driver/xorg-driver-common.inc
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "X driver"
2HOMEPAGE = "http://www.x.org"
3BUGTRACKER = "https://bugs.freedesktop.org"
4SECTION = "x11/drivers"
5LICENSE = "MIT-X"
6
7PE = "2"
8INC_PR = "r0"
9
10DEPENDS = "virtual/xserver xproto randrproto util-macros"
11
12SRC_URI = "${XORG_MIRROR}/individual/driver/${BPN}-${PV}.tar.bz2"
13
14S = "${WORKDIR}/${BPN}-${PV}"
15
16FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
17FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
18
19inherit autotools pkgconfig
20
21# AC_CHECK_FILE doesn't work when cross compiling, so we create a replacement
22# macro that simply assumes the test succeeds.
23do_configure_prepend () {
24 echo 'AC_DEFUN(CC_AC_CHECK_FILE, $2)' > configure.ac.new
25 sed 's/AC_CHECK_FILE/CC_AC_CHECK_FILE/g' configure.ac >> configure.ac.new
26 mv configure.ac.new configure.ac
27}
28
29# FIXME: We don't want to include the libtool archives (*.la) from modules
30# directory, as they serve no useful purpose. Upstream should fix Makefile.am
31do_install_append() {
32 find ${D}${libdir}/xorg/modules -regex ".*\.la$" | xargs rm -f --
33}
diff --git a/common/recipes-graphics/xorg-driver/xorg-driver-video.inc b/common/recipes-graphics/xorg-driver/xorg-driver-video.inc
deleted file mode 100644
index 57c80d10..00000000
--- a/common/recipes-graphics/xorg-driver/xorg-driver-video.inc
+++ /dev/null
@@ -1,4 +0,0 @@
1include xorg-driver-common.inc
2
3DEPENDS =+ "renderproto videoproto xextproto fontsproto"
4