summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2012-09-06 10:47:46 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-09-07 17:20:31 -0500
commite3d9eb5df031ea32208d196061b5511849019da9 (patch)
treefd2c0792fff88f61f1e3179038b48a1ce6559652
parent66b516f3d3a287eecbf8804b2221bfc27e36db63 (diff)
downloadmeta-intel-1.3_M4.rc1.tar.gz
meta-crystalforest: Crystal Forest BSP Created.1.3_M4.rc11.3_M4
Initial checkin for the new Crystal Forest BSP. This BSP is based on Sandybridge CPU and Cave Creek Chipset. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com>
-rw-r--r--meta-crystalforest/COPYING.MIT17
-rw-r--r--meta-crystalforest/README139
-rw-r--r--meta-crystalforest/README.sources17
-rw-r--r--meta-crystalforest/binary/.gitignore0
-rw-r--r--meta-crystalforest/conf/layer.conf12
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-shumway.conf26
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-stargo.conf27
-rw-r--r--meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig3
-rw-r--r--meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig3
-rw-r--r--meta-crystalforest/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf26
-rw-r--r--meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf26
-rw-r--r--meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend18
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend17
15 files changed, 337 insertions, 0 deletions
diff --git a/meta-crystalforest/COPYING.MIT b/meta-crystalforest/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-crystalforest/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-crystalforest/README b/meta-crystalforest/README
new file mode 100644
index 00000000..7b88b224
--- /dev/null
+++ b/meta-crystalforest/README
@@ -0,0 +1,139 @@
1This README file contains information on building the meta-crystalforest
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The 'Crystal Forest' platform consists of two versions.
61. STARGO
72. SHUMWAY
8
9Stargo Platform is based on Intel Sandy Bridge Gladden Processor,plus the Cave Creek chipset.
10Shumway Platform is based on two Intel Sandy Bridge (SNB-EP ES2 Grade and SNB-EN ES2 Grade)
11Processors plus two Cave Creek Chipsets.
12
13Both Platforms uses Matrox graphics Card.
14
15
16Dependencies
17============
18
19This layer depends on:
20
21 URI: git://git.openembedded.org/bitbake
22 branch: master
23
24 URI: git://git.openembedded.org/openembedded-core
25 layers: meta
26 branch: master
27
28 URI: git://git.yoctoproject.org/meta-intel
29 layers: intel
30 branch: master
31
32
33Patches
34=======
35
36Please submit any patches against this BSP to the Yocto mailing list
37(yocto@yoctoproject.org) and cc: the maintainer:
38
39Maintainer: Kishore Bodke <kishore.k.bodke@intel.com>
40
41Please see the meta-intel/MAINTAINERS file for more details.
42
43
44Table of Contents
45=================
46
47 I. Building the meta-crystalforest BSP layer
48 II. Booting the images in /binary
49
50
51I. Building the meta-crystalforest BSP layer
52=======================================
53
54In order to build an image with BSP support for a given release, you
55need to download the corresponding BSP tarball from the 'Board Support
56Package (BSP) Downloads' page of the Yocto Project website.
57
58Having done that, and assuming you extracted the BSP tarball contents
59at the top-level of your yocto build tree, you can build a crystalforest
60image by adding the location of the meta-crystalforest layer to
61bblayers.conf, along with the meta-intel layer itself (to access
62common metadata shared between BSPs) e.g.:
63
64 yocto/meta-intel \
65 yocto/meta-intel/meta-crystalforest \
66
67To enable the Crystal Forest Stargo layer, add the crystalforest-stargo MACHINE to local.conf:
68
69 MACHINE ?= "crystalforest-stargo"
70
71To enable the Crystal Forest Shumway layer, add the crystalforest-shumway MACHINE to local.conf:
72
73 MACHINE ?= "crystalforest-shumway"
74
75
76You should then be able to build a crystalforest image as such:
77
78 $ source oe-init-build-env
79 $ bitbake core-image-sato
80
81At the end of a successful build, you should have a live image that
82you can boot from a USB flash drive (see instructions on how to do
83that below, in the section 'Booting the images from /binary').
84
85As an alternative to downloading the BSP tarball, you can also work
86directly from the meta-intel git repository. For each BSP in the
87'meta-intel' repository, there are multiple branches, one
88corresponding to each major release starting with 'laverne' (0.90), in
89addition to the latest code which tracks the current master (note that
90not all BSPs are present in every release). Instead of extracting a
91BSP tarball at the top level of your yocto build tree, you can
92equivalently check out the appropriate branch from the meta-intel
93repository at the same location.
94
95
96II. Booting the images in /binary
97=================================
98
99This BSP contains bootable live images, which can be used to directly
100boot Yocto off of a USB flash drive.
101
102Under Linux, insert a USB flash drive. Assuming the USB flash drive
103takes device /dev/sdf, use dd to copy the live image to it. For
104example:
105
106To boot the Stargo Platform:
107
108# dd if=core-image-sato-crystalforest-stargo-20120829033154.hddimg of=/dev/sdf
109# sync
110# eject /dev/sdf
111
112To boot the Shumway Platform:
113
114# dd if=core-image-sato-crystalforest-shumway-20120829044852.hddimg of=/dev/sdf
115# sync
116# eject /dev/sdf
117
118This should give you a bootable USB flash device. Insert the device
119into a bootable USB socket on the target, and power on. This should
120result in a system booted to the Sato graphical desktop.
121
122If you want a terminal, use the arrows at the top of the UI to move to
123different pages of available applications, one of which is named
124'Terminal'. Clicking that should give you a root terminal.
125
126If you want to ssh into the system, you can use the root terminal to
127ifconfig the IP address and use that to ssh in. The root password is
128empty, so to log in type 'root' for the user name and hit 'Enter' at
129the Password prompt: and you should be in.
130
131----
132
133If you find you're getting corrupt images on the USB (it doesn't show
134the syslinux boot: prompt, or the boot: prompt contains strange
135characters), try doing this first:
136
137# dd if=/dev/zero of=/dev/sdf bs=1M count=512
138
139
diff --git a/meta-crystalforest/README.sources b/meta-crystalforest/README.sources
new file mode 100644
index 00000000..76180f1a
--- /dev/null
+++ b/meta-crystalforest/README.sources
@@ -0,0 +1,17 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.2/poky-denzil-7.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-crystalforest/binary/.gitignore b/meta-crystalforest/binary/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-crystalforest/binary/.gitignore
diff --git a/meta-crystalforest/conf/layer.conf b/meta-crystalforest/conf/layer.conf
new file mode 100644
index 00000000..6b802d63
--- /dev/null
+++ b/meta-crystalforest/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "crystalforest"
9BBFILE_PATTERN_crystalforest := "^${LAYERDIR}/"
10BBFILE_PRIORITY_crystalforest = "6"
11
12LAYERDEPENDS_crystalforest = "intel"
diff --git a/meta-crystalforest/conf/machine/crystalforest-shumway.conf b/meta-crystalforest/conf/machine/crystalforest-shumway.conf
new file mode 100644
index 00000000..0a2141c8
--- /dev/null
+++ b/meta-crystalforest/conf/machine/crystalforest-shumway.conf
@@ -0,0 +1,26 @@
1#@TYPE: Machine
2#@NAME: crystalforest-shumway
3
4#@DESCRIPTION: Machine configuration for Crystal Forest Server (SHUMWAY) systems
5# i.e. Two Sandy Bridge Jaketown processors (SNB-EP ES2 Grade and SNB-EN ES2 Grade) + Two Cave Creek Chipsets.
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
8PREFERRED_VERSION_linux-yocto ?= "3.4%"
9
10require conf/machine/include/tune-x86_64.inc
11require conf/machine/include/ia32-base.inc
12require conf/machine/include/meta-intel.inc
13
14XSERVER ?= "${XSERVER_IA32_BASE} \
15 ${XSERVER_IA32_EXT} \
16 ${XSERVER_IA32_MATROX_MGA} \
17 "
18#This Kernel Option is required for Intel Quick Assist Technology Software.
19APPEND += "acpi_enforce_resources=lax"
20
21#Uncomment the below Kernel Option if Virtualization is not needed.
22#APPEND += "intel_iommu=off"
23
24SYSLINUX_OPTS = "serial 0 115200"
25SERIAL_CONSOLE = "115200 ttyS0"
26APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-crystalforest/conf/machine/crystalforest-stargo.conf b/meta-crystalforest/conf/machine/crystalforest-stargo.conf
new file mode 100644
index 00000000..575a504d
--- /dev/null
+++ b/meta-crystalforest/conf/machine/crystalforest-stargo.conf
@@ -0,0 +1,27 @@
1#@TYPE: Machine
2#@NAME: crystalforest-stargo
3
4#@DESCRIPTION: Machine configuration for Crystal Forest (STARGO) systems
5# i.e. One Sandy Bridge based Gladden Processor + One Cave Creek Chipset
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
8PREFERRED_VERSION_linux-yocto ?= "3.4%"
9
10require conf/machine/include/tune-x86_64.inc
11require conf/machine/include/ia32-base.inc
12require conf/machine/include/meta-intel.inc
13
14XSERVER ?= "${XSERVER_IA32_BASE} \
15 ${XSERVER_IA32_EXT} \
16 ${XSERVER_IA32_MATROX_MGA} \
17 "
18
19#This Kernel Option is required for Intel Quick Assist Technology Software.
20APPEND += "acpi_enforce_resources=lax"
21
22#Uncomment the below Kernel Option if Virtualization is not needed.
23#APPEND += "intel_iommu=off"
24
25SYSLINUX_OPTS = "serial 0 115200"
26SERIAL_CONSOLE = "115200 ttyS0"
27APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-crystalforest/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-crystalforest/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..54da0ffd
--- /dev/null
+++ b/meta-crystalforest/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC = "1"
diff --git a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf
new file mode 100644
index 00000000..28ad0bf7
--- /dev/null
+++ b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Matrox MGA"
3 Driver "mga"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Matrox MGA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf
new file mode 100644
index 00000000..28ad0bf7
--- /dev/null
+++ b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Matrox MGA"
3 Driver "mga"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Matrox MGA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
new file mode 100644
index 00000000..db56439c
--- /dev/null
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
@@ -0,0 +1,18 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_crystalforest-stargo = "crystalforest-stargo"
4KMACHINE_crystalforest-stargo = "crystalforest"
5KBRANCH_crystalforest-stargo = "standard/preempt-rt/base"
6
7SRCREV_machine_pn-linux-yocto-rt_crystalforest-stargo ?= "9032b1e9daf5b4396f939981c3be95f67802d18c"
8SRCREV_meta_pn-linux-yocto-rt_crystalforest-stargo ?= "463299bc2e533e1bd38b0053ae7b210980f269c3"
9
10
11COMPATIBLE_MACHINE_crystalforest-shumway = "crystalforest-shumway"
12KMACHINE_crystalforest-shumway = "crystalforest"
13KBRANCH_crystalforest-shumway = "standard/preempt-rt/base"
14
15SRCREV_machine_pn-linux-yocto-rt_crystalforest-shumway ?= "9032b1e9daf5b4396f939981c3be95f67802d18c"
16SRCREV_meta_pn-linux-yocto-rt_crystalforest-shumway ?= "463299bc2e533e1bd38b0053ae7b210980f269c3"
17
18module_autoload_uio = "uio"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
new file mode 100644
index 00000000..9be788ce
--- /dev/null
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -0,0 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_crystalforest-stargo = "crystalforest-stargo"
4KMACHINE_crystalforest-stargo = "crystalforest"
5KBRANCH_crystalforest-stargo = "standard/common-pc-64/crystalforest"
6
7SRCREV_machine_pn-linux-yocto_crystalforest-stargo ?= "0985844fa6235422c67ef269952fa4e765f252f9"
8SRCREV_meta_pn-linux-yocto_crystalforest-stargo ?= "463299bc2e533e1bd38b0053ae7b210980f269c3"
9
10COMPATIBLE_MACHINE_crystalforest-shumway = "crystalforest-shumway"
11KMACHINE_crystalforest-shumway = "crystalforest"
12KBRANCH_crystalforest-shumway = "standard/common-pc-64/crystalforest"
13
14SRCREV_machine_pn-linux-yocto_crystalforest-shumway ?= "0985844fa6235422c67ef269952fa4e765f252f9"
15SRCREV_meta_pn-linux-yocto_crystalforest-shumway ?= "463299bc2e533e1bd38b0053ae7b210980f269c3"
16
17module_autoload_uio = "uio"