summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-10-30 14:38:34 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-11-01 08:35:40 -0500
commit1a5ab65544830dd571a368b9d9f6ec782ffc94ac (patch)
treecd4cab96caf4705d9bebdb902d0d4a3a3ee4d76c
parente215e3fb61b6d1aee753fbc236341346c69395a4 (diff)
downloadmeta-intel-1.3.tar.gz
mesa-dri.bbappend: avoid conflict with emgd-driver-bin1.3.final1.3
Extend the mesa-dri recipe from oecore to avoid conflict with files generated by emgd-driver-bin recipe. This extention is needed only when emgd-driver-bin recipe is included in the target image, so the code is conditional to run only on the machine with emgd graphics driver. The emgd binary driver also provides egl, gles1, gles2 library & headers. To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image is bundling the emgd driver. This commits avoids these build warning WARNING: The recipe is trying to install files into a shared area when those files already exist. Those files are: /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/KHR/khrplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/eglplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/eglext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/egl.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/glplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/gl.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/glext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2ext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2platform.h And revert the replacement change commited earlier to avoid these warnings. Revert "mesa-dri.bbappend: avoid buildtime warnings" This reverts commit 2408d28972db8e56f37ec52208adc65734c61dea. This fixes the bug: [YOCTO #3295] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend27
1 files changed, 23 insertions, 4 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
index 90e43944..6bfa9686 100644
--- a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
+++ b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
@@ -1,5 +1,24 @@
1# Temporary avoid warnings of duplicate files providers until
2# mesa-dri & emgd-driver-bin recipes are fixed
3SSTATE_DUPWHITELIST += "${STAGING_INCDIR}/KHR ${STAGING_INCDIR}/EGL \
4 ${STAGING_INCDIR}/GLES ${STAGING_INCDIR}/GLES2"
5 1
2# The emgd binary driver also provides egl, gles1, gles2 library & headers.
3# To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image
4# is bundling the emgd driver.
5
6python __anonymous () {
7 import re
8 xserver = d.getVar('XSERVER', True)
9 if 'emgd-driver-bin' in xserver.split(' '):
10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"]
12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"]
13 pattern = re.compile("--with-egl-platforms")
14 new_extra_oeconf = [ ]
15 for i in extra_oeconf:
16 if ( i not in take_out ) and ( not pattern.match(i)):
17 new_extra_oeconf.append(i)
18 for i in put_in:
19 new_extra_oeconf.append(i)
20
21 d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
22 depends = d.getVar('DEPENDS', True)
23 d.setVar('DEPENDS', depends + " emgd-driver-bin")
24}