summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-02-10 01:58:14 -0600
committerTom Zanussi <tom.zanussi@intel.com>2011-02-10 01:58:14 -0600
commite8abba6e66d9e0936a688bd985bc93b824b24543 (patch)
treec626125accb1007fdc5f0b61bfe2c28c8fd627fc
parentd4ec0c2e8c52f0e5e30ff04e214cb7ec383b6c9d (diff)
downloadmeta-intel-e8abba6e66d9e0936a688bd985bc93b824b24543.tar.gz
meta-crownbay: apply init-live.sh coldplug udev trigger patch here instead
At the moment, we can't spin a new laverne release, so we need to add it to the crownbay layer instead. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot/0001-init-live.sh-add-coldplug-udev-trigger.patch44
-rw-r--r--meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend6
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot/0001-init-live.sh-add-coldplug-udev-trigger.patch b/meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot/0001-init-live.sh-add-coldplug-udev-trigger.patch
new file mode 100644
index 00000000..5119b3f8
--- /dev/null
+++ b/meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot/0001-init-live.sh-add-coldplug-udev-trigger.patch
@@ -0,0 +1,44 @@
1From 0b8fcb95dd4209d56e150d0b20133e728b22776c Mon Sep 17 00:00:00 2001
2From: Tom Zanussi <tom.zanussi@intel.com>
3Date: Mon, 7 Feb 2011 13:45:45 -0600
4Subject: [PATCH 1/2] init-live.sh: add 'coldplug' udev trigger
5
6Fixes [BUGID #693]
7
8The init-live.sh script starts udevd in init-live.sh:early_setup(),
9but doesn't account for the possibility that the root device may have
10already been registered by the kernel before udevd starts up.
11
12If the device is detected after udevd starts up, everything's fine -
13udevd gets the 'add' uevent for the device, the root image shows up at
14e.g. /media/sda/rootfs.img, and the boot continues.
15
16If however the device is detected before udevd starts up, udevd misses
17the 'add' uevent and the root image never shows up, causing it to stay
18in the 'waiting for removable media' loop forever.
19
20The 'udevadm trigger' command is meant to be used to avoid this
21situation, but init-live.sh doesn't use it. Furthermore, since the
22default was changed in udev 152 from 'add' to 'change', the command
23needs to explicity name 'add' as the action.
24
25Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
26---
27 meta/recipes-core/initrdscripts/files/init-live.sh | 1 +
28 1 files changed, 1 insertions(+), 0 deletions(-)
29
30diff --git a/meta/recipes-core/initrdscripts/files/init-live.sh b/meta/recipes-core/initrdscripts/files/init-live.sh
31index c96b1f4..f3e5145 100644
32--- a/init-live.sh
33+++ b/init-live.sh
34@@ -11,6 +11,7 @@ early_setup() {
35 mount -t proc proc /proc
36 mount -t sysfs sysfs /sys
37 udevd --daemon
38+ /sbin/udevadm trigger --action=add
39 }
40
41 read_args() {
42--
431.7.0.4
44
diff --git a/meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend b/meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend
new file mode 100644
index 00000000..c5d929dd
--- /dev/null
+++ b/meta-crownbay/recipes-core/initrdscripts/initramfs-live-boot_1.0.bbappend
@@ -0,0 +1,6 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2S = "${WORKDIR}"
3
4PR .= ".1"
5
6SRC_URI_append += " file://0001-init-live.sh-add-coldplug-udev-trigger.patch"