summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2016-03-31 02:55:10 +0800
committerSaul Wold <sgw@linux.intel.com>2016-03-30 16:18:09 -0700
commitdcfd63ce736d22cb95ec90bfe62116e01b4d306d (patch)
tree5f7109dd74f997e42b0945f6790bdf9cd7ab22af
parentabb8758eb800c37c6c2700b3c45ffdb723b4d2ae (diff)
downloadmeta-intel-dcfd63ce736d22cb95ec90bfe62116e01b4d306d.tar.gz
meta-isg: qat16: fix v2.5.0 build with kernel v4.4
The qat recipe currently relies on EXTRA_OEMAKE having been set to "-e MAKEFLAGS=" in bitbake.conf to operate. It is necessary to make this explicit so that the default in bitbake.conf can be changed. The prototype of a func used in QAT16 is changed in kernel v4.4 Also, make sure that we point to the correct include path to the local headers. Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16.inc8
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-Added-include-dir-path.patch30
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-change-in-return-type-of-func-in-kernel-v4.4.patch40
3 files changed, 75 insertions, 3 deletions
diff --git a/meta-isg/common/recipes-extended/qat/qat16.inc b/meta-isg/common/recipes-extended/qat/qat16.inc
index 90765ea0..c789fda6 100644
--- a/meta-isg/common/recipes-extended/qat/qat16.inc
+++ b/meta-isg/common/recipes-extended/qat/qat16.inc
@@ -15,6 +15,8 @@ SRC_URI="https://01.org/sites/default/files/page/qatmux.l.${PV}.tgz;name=qat \
15 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \ 15 file://qat16_2.3.0-34-qat-fix-for-cross-compilation-issue.patch \
16 file://qat16_2.3.0-34-qat-remove-local-path-from-makefile.patch \ 16 file://qat16_2.3.0-34-qat-remove-local-path-from-makefile.patch \
17 file://qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch \ 17 file://qat16_2.3.0-34-make-sure-CFLAGS-are-correct.patch \
18 file://qat16_2.5.0-80-qat-change-in-return-type-of-func-in-kernel-v4.4.patch \
19 file://qat16_2.5.0-80-qat-Added-include-dir-path.patch \
18 " 20 "
19 21
20COMPATIBLE_MACHINE = "crystalforest|intel-corei7-64" 22COMPATIBLE_MACHINE = "crystalforest|intel-corei7-64"
@@ -47,8 +49,8 @@ PARALLEL_MAKE = ""
47#To get around the double slashes in paths in QAT makefiles 49#To get around the double slashes in paths in QAT makefiles
48PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" 50PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
49 51
50EXTRA_OEMAKE_append = " CFLAGS+=-fgnu89-inline" 52EXTRA_OEMAKE_append = " CFLAGS+='-fgnu89-inline -fPIC'"
51 53EXTRA_OEMAKE = "-e MAKEFLAGS="
52do_unpack2() { 54do_unpack2() {
53 cd ${S}/ 55 cd ${S}/
54 tar xzvf ${ICP_DRIVER_TYPE}.L.${PV}.tar.gz 56 tar xzvf ${ICP_DRIVER_TYPE}.L.${PV}.tar.gz
@@ -60,7 +62,7 @@ do_compile () {
60 export LD="${LD} --hash-style=gnu" 62 export LD="${LD} --hash-style=gnu"
61 export MACHINE="${TARGET_ARCH}" 63 export MACHINE="${TARGET_ARCH}"
62 cd ${S}/quickassist 64 cd ${S}/quickassist
63 oe_runmake EXTRA_OEMAKE="'CFLAGS=${CFLAGS} -fPIC'" 65 oe_runmake
64 66
65 cd ${SAMPLE_CODE_DIR} 67 cd ${SAMPLE_CODE_DIR}
66 touch ${SAMPLE_CODE_DIR}/performance/compression/calgary 68 touch ${SAMPLE_CODE_DIR}/performance/compression/calgary
diff --git a/meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-Added-include-dir-path.patch b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-Added-include-dir-path.patch
new file mode 100644
index 00000000..a5389306
--- /dev/null
+++ b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-Added-include-dir-path.patch
@@ -0,0 +1,30 @@
1From 142bf81912701d94985ad656c2250650113d00de Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Tue, 22 Mar 2016 01:44:09 +0800
4Subject: [PATCH 2/2] qat: Added include dir path
5
6Upstream-Status: Inappropriate [Configuration]
7
8Make sure that we point to the correct include path to the local
9headers.
10
11Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
12---
13 quickassist/build_system/build_files/env_files/linux_2.6_user_space.mk | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/quickassist/build_system/build_files/env_files/linux_2.6_user_space.mk b/quickassist/build_system/build_files/env_files/linux_2.6_user_space.mk
17index b504f7f..a75f152 100755
18--- a/quickassist/build_system/build_files/env_files/linux_2.6_user_space.mk
19+++ b/quickassist/build_system/build_files/env_files/linux_2.6_user_space.mk
20@@ -84,6 +84,7 @@ INCLUDES+=-I$(API_DIR) \
21
22 EXTRA_CFLAGS += $(cmd_line_cflags)
23 EXTRA_CFLAGS += -fno-strict-aliasing
24+EXTRA_CFLAGS += $(INCLUDES)
25 EXTRA_LDFLAGS +=-whole-archive
26
27 ifeq ($(ARCH), i386)
28--
291.9.1
30
diff --git a/meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-change-in-return-type-of-func-in-kernel-v4.4.patch b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-change-in-return-type-of-func-in-kernel-v4.4.patch
new file mode 100644
index 00000000..b427799b
--- /dev/null
+++ b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.5.0-80-qat-change-in-return-type-of-func-in-kernel-v4.4.patch
@@ -0,0 +1,40 @@
1From f056dbedd106e03860de66d5c84cd018da087dda Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Tue, 22 Mar 2016 00:59:36 +0800
4Subject: [PATCH 1/2] qat: change in return type of func in kernel v4.4
5
6Upstream-Status: Submitted
7
8The function 'seq_puts' return type is changed from 'int' to 'void'.
9Now use of 'ret' variable is not valid. So used another condition to check
10for overflow.
11
12Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
13---
14 quickassist/adf/drivers/common/linux/src/adf_proc_debug.c | 6 +++---
15 1 file changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/quickassist/adf/drivers/common/linux/src/adf_proc_debug.c b/quickassist/adf/drivers/common/linux/src/adf_proc_debug.c
18index 7d81eaa..a1dd917 100755
19--- a/quickassist/adf/drivers/common/linux/src/adf_proc_debug.c
20+++ b/quickassist/adf/drivers/common/linux/src/adf_proc_debug.c
21@@ -132,13 +132,13 @@ static int adf_debug_show(struct seq_file *sfile, void *v)
22 {
23 debug_file_info_t* file_info = sfile->private;
24 if (file_info && file_info->seq_read && file_info->page) {
25- int ret = 0, old_offset = file_info->offset;
26+ int old_offset = file_info->offset;
27 file_info->offset =
28 file_info->seq_read(file_info->private_data,
29 file_info->page, PAGE_SIZE - 1,
30 file_info->offset);
31- ret = seq_puts(sfile, (char*)file_info->page);
32- if (ret) {
33+ seq_puts(sfile, (char*)file_info->page);
34+ if (sfile->count == sfile->size) {
35 /* run out of space - need to reprint */
36 file_info->offset = old_offset;
37 }
38--
391.9.1
40