diff options
author | Ross Burton <ross.burton@intel.com> | 2014-05-20 17:11:06 +0100 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@linux.intel.com> | 2014-05-21 20:21:50 -0500 |
commit | b4a4966212122b31c936f1c320faaf383489864f (patch) | |
tree | 194dbc86a59ea4ab96642cd3926a575414438dd9 | |
parent | 9ad362ed0de2ae217f2c3debcfeb62ded9122de5 (diff) | |
download | meta-intel-b4a4966212122b31c936f1c320faaf383489864f.tar.gz |
calgary-corpus: clean up unpack logic
As with canterbury-corpus, use SRC_URI parameters to unpack correctly instead of
doing it by hand.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Acked-by: Ong Boon Leong <boon.leong.ong@intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
-rw-r--r-- | common/recipes-corpus/calgary-corpus/calgary-corpus.bb | 24 |
1 files changed, 8 insertions, 16 deletions
diff --git a/common/recipes-corpus/calgary-corpus/calgary-corpus.bb b/common/recipes-corpus/calgary-corpus/calgary-corpus.bb index 8c3aea8a..0a91387a 100644 --- a/common/recipes-corpus/calgary-corpus/calgary-corpus.bb +++ b/common/recipes-corpus/calgary-corpus/calgary-corpus.bb | |||
@@ -5,26 +5,18 @@ SECTION = "misc" | |||
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
7 | 7 | ||
8 | S = "${WORKDIR}/corpus" | 8 | # The tarball doesn't extract a directory, so ask bitbake to make one |
9 | 9 | SRC_URI = "http://corpus.canterbury.ac.nz/resources/calgary.tar.gz;subdir=${BP}" | |
10 | SRC_URI = "http://corpus.canterbury.ac.nz/resources/calgary.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "651d06b35d3d39522157cf8dc4a3d01c" | 10 | SRC_URI[md5sum] = "651d06b35d3d39522157cf8dc4a3d01c" |
13 | SRC_URI[sha256sum] = "e109eebdc19c5cee533c58bd6a49a4be3a77cc52f84ba234a089148a4f2093b7" | 11 | SRC_URI[sha256sum] = "e109eebdc19c5cee533c58bd6a49a4be3a77cc52f84ba234a089148a4f2093b7" |
14 | 12 | ||
15 | do_unpack () { | ||
16 | mkdir -p ${S} | ||
17 | tar -xf ${DL_DIR}/calgary.tar.gz -C ${WORKDIR}/corpus | ||
18 | } | ||
19 | |||
20 | |||
21 | do_unpack_append () { | ||
22 | rm -rf ${WORKDIR}/corpus/patches | ||
23 | } | ||
24 | |||
25 | FILES_${PN} = "/lib/firmware/*" | ||
26 | |||
27 | do_install () { | 13 | do_install () { |
14 | # do_unpack creates this directory but we don't want to install it, so | ||
15 | # delete it now. | ||
16 | rm -rf ${S}/patches | ||
17 | |||
28 | install -d ${D}/lib/firmware | 18 | install -d ${D}/lib/firmware |
29 | install -m 664 ${S}/* ${D}/lib/firmware | 19 | install -m 664 ${S}/* ${D}/lib/firmware |
30 | } | 20 | } |
21 | |||
22 | FILES_${PN} = "/lib/firmware/*" | ||