diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2021-02-02 18:33:30 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2021-02-02 23:10:43 +0800 |
commit | 5d6513bae51d3c7552e1ee565e4de652143430cf (patch) | |
tree | a61ea4c18b2c22d4bd86981e22a2dc124e5780b1 | |
parent | 02e2f260a63b8f01aabb307a996405b3613a280f (diff) | |
download | meta-intel-5d6513bae51d3c7552e1ee565e4de652143430cf.tar.gz |
intel-graphics-compiler: upgrade 1.0.5435 -> 1.0.6083
Refreshed patch.
Drop VectorCompiler build config, which is not require anymore.
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch | 35 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6083.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb) | 6 |
2 files changed, 23 insertions, 18 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch index 89a28097..aead2d1c 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/link-to-LLVMGenXIntrinsics.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 483154871f72590b81c036b000be09627376b5a9 Mon Sep 17 00:00:00 2001 | 1 | From 11b923c99cbe3580885ce40c322277fc823107a0 Mon Sep 17 00:00:00 2001 |
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | 2 | From: Naveen Saini <naveen.kumar.saini@intel.com> |
3 | Date: Thu, 27 Aug 2020 12:17:12 +0800 | 3 | Date: Tue, 2 Feb 2021 13:39:53 +0800 |
4 | Subject: [PATCH] IGC/VectorCompiler/CMakeLists.txt: link to external | 4 | Subject: [PATCH] IGC/VectorCompiler/CMakeLists.txt: link to external |
5 | LLVMGenXIntrinsics | 5 | LLVMGenXIntrinsics |
6 | 6 | ||
@@ -13,14 +13,14 @@ Upstream-Status: Inappropriate [configuration specific] | |||
13 | 13 | ||
14 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | 14 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> |
15 | --- | 15 | --- |
16 | IGC/VectorCompiler/CMakeLists.txt | 23 ++--------------------- | 16 | IGC/VectorCompiler/CMakeLists.txt | 32 ++----------------------------- |
17 | 1 file changed, 2 insertions(+), 21 deletions(-) | 17 | 1 file changed, 2 insertions(+), 30 deletions(-) |
18 | 18 | ||
19 | diff --git a/IGC/VectorCompiler/CMakeLists.txt b/IGC/VectorCompiler/CMakeLists.txt | 19 | diff --git a/IGC/VectorCompiler/CMakeLists.txt b/IGC/VectorCompiler/CMakeLists.txt |
20 | index 3592e0b4..ae754b8b 100644 | 20 | index 86f343ee..b4268160 100644 |
21 | --- a/IGC/VectorCompiler/CMakeLists.txt | 21 | --- a/IGC/VectorCompiler/CMakeLists.txt |
22 | +++ b/IGC/VectorCompiler/CMakeLists.txt | 22 | +++ b/IGC/VectorCompiler/CMakeLists.txt |
23 | @@ -50,10 +50,7 @@ if(IGC_BUILD__USING_SYSTEM_LLVM OR (WIN32 AND LLVM_USE_PREBUILT)) | 23 | @@ -53,10 +53,7 @@ if(IGC_BUILD__USING_SYSTEM_LLVM OR (WIN32 AND LLVM_USE_PREBUILT)) |
24 | message(STATUS "[VC] Using system llvm") | 24 | message(STATUS "[VC] Using system llvm") |
25 | 25 | ||
26 | # Need to search for llvm-tblgen | 26 | # Need to search for llvm-tblgen |
@@ -32,8 +32,8 @@ index 3592e0b4..ae754b8b 100644 | |||
32 | if(LLVM_TABLEGEN_EXE-NOTFOUND) | 32 | if(LLVM_TABLEGEN_EXE-NOTFOUND) |
33 | message(FATAL_ERROR "[VC] llvm-tblgen is not found") | 33 | message(FATAL_ERROR "[VC] llvm-tblgen is not found") |
34 | endif() | 34 | endif() |
35 | @@ -131,23 +128,7 @@ if(LLVM_ON_WIN32) | 35 | @@ -140,32 +137,7 @@ if(LLVM_ON_WIN32) |
36 | add_compile_options(/wd4624) | 36 | add_compile_options(/wd4141) |
37 | endif() | 37 | endif() |
38 | 38 | ||
39 | -if(DEFINED VC_INTRINSICS_SRC) | 39 | -if(DEFINED VC_INTRINSICS_SRC) |
@@ -48,15 +48,24 @@ index 3592e0b4..ae754b8b 100644 | |||
48 | - | 48 | - |
49 | -# We are using prebuilt SPIRV and building intrinsics. | 49 | -# We are using prebuilt SPIRV and building intrinsics. |
50 | -set(INTRBUILD "${CMAKE_CURRENT_BINARY_DIR}/intrbuild") | 50 | -set(INTRBUILD "${CMAKE_CURRENT_BINARY_DIR}/intrbuild") |
51 | - | ||
52 | - | ||
53 | -# Do not copy anything from prebuilts. libSPIRVDLL.so will be dynamically loaded at runtime. | ||
54 | -add_subdirectory(${INTRSRC} ${INTRBUILD}) | 51 | -add_subdirectory(${INTRSRC} ${INTRBUILD}) |
55 | -include_directories(${INTRSRC}/include ${INTRBUILD}/include) | 52 | -# Make separate target for intrinstics headers. |
53 | -# Ideally, this should be inside intrinsics, but | ||
54 | -# this breaks in-tree build of intrinsics with LLVM. | ||
55 | -add_library(VCIntrinsicsHeaders INTERFACE) | ||
56 | -target_include_directories(VCIntrinsicsHeaders | ||
57 | - INTERFACE | ||
58 | - ${INTRSRC}/include | ||
59 | - ${INTRBUILD}/include | ||
60 | - ) | ||
61 | -add_dependencies(VCIntrinsicsHeaders | ||
62 | - GenXIntrinsics | ||
63 | - ) | ||
64 | - | ||
56 | +find_package(LLVMGenXIntrinsics REQUIRED) | 65 | +find_package(LLVMGenXIntrinsics REQUIRED) |
57 | |||
58 | include(cmake/spirv.cmake) | 66 | include(cmake/spirv.cmake) |
59 | include(${IGC_SOURCE_DIR}/cmake/utils.cmake) | 67 | include(${IGC_SOURCE_DIR}/cmake/utils.cmake) |
68 | |||
60 | -- | 69 | -- |
61 | 2.17.1 | 70 | 2.17.1 |
62 | 71 | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6083.bb index e762246c..c92b8ea4 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6083.bb | |||
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ | |||
14 | file://improve_src_package_reproducibility.patch \ | 14 | file://improve_src_package_reproducibility.patch \ |
15 | " | 15 | " |
16 | 16 | ||
17 | SRCREV = "93f02a7dfa37d879abc2ff5d62fd1e527fa4b03a" | 17 | SRCREV = "f6ec355e7e275f87e0756576cd7a390d2365ed48" |
18 | 18 | ||
19 | # Used to replace with relative path in reproducibility patch | 19 | # Used to replace with relative path in reproducibility patch |
20 | export B | 20 | export B |
@@ -34,10 +34,6 @@ RDEPENDS_${PN} += "opencl-clang" | |||
34 | LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.1.0', d)}" | 34 | LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.1.0', d)}" |
35 | EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0 -DIGC_BUILD__VC_ENABLED=OFF" | 35 | EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0 -DIGC_BUILD__VC_ENABLED=OFF" |
36 | 36 | ||
37 | # VectorCompiler doesn't build with LLVM11 as of this release. | ||
38 | # Re-enable after those issues have been fixed. | ||
39 | EXTRA_OECMAKE_append = " ${@bb.utils.contains('LLVMVERSION', '11.0.0', "-DIGC_BUILD__VC_ENABLED=OFF", "", d)}" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | 37 | BBCLASSEXTEND = "native nativesdk" |
42 | 38 | ||
43 | UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$" | 39 | UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$" |