summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-08-25 08:21:07 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2023-08-25 13:50:42 +0800
commitf30c2a8a3da3fc35f1277b406ed193eafd0d9f9b (patch)
treea16f57803a155c355a06ff2d40c94ce9b711aaf4
parente3911bc45ee2a210408cfbc5217199ee6b7569a4 (diff)
downloadmeta-intel-f30c2a8a3da3fc35f1277b406ed193eafd0d9f9b.tar.gz
opencl-clang/14.0: update to latest
Drop patch 0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch which is not needed anymore Backport a fix from main branch to fix build issues. Move do_install:append:class-native to individual recipe Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch32
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch32
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc5
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb5
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb11
5 files changed, 45 insertions, 40 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch
new file mode 100644
index 00000000..732589f2
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-Fix-standalone-build-415.patch
@@ -0,0 +1,32 @@
1From 3a281f634be5e56d5fb49d07da85fe24e5971dd0 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <Zatloukal.Frantisek@gmail.com>
3Date: Fri, 21 Apr 2023 04:07:21 +0200
4Subject: [PATCH] Fix standalone build (#415)
5
6Fixes https://github.com/intel/opencl-clang/issues/406
7Fixes https://github.com/intel/opencl-clang/issues/374
8
9Upstream-Status: Backport [https://github.com/intel/opencl-clang/commit/529a9188114bcbd8ed753d2276942384fa50d7a1]
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 cl_headers/CMakeLists.txt | 6 +++++-
13 1 file changed, 5 insertions(+), 1 deletion(-)
14
15diff --git a/cl_headers/CMakeLists.txt b/cl_headers/CMakeLists.txt
16index 69cf11e..a258b62 100644
17--- a/cl_headers/CMakeLists.txt
18+++ b/cl_headers/CMakeLists.txt
19@@ -1,5 +1,9 @@
20 set(CL_HEADERS_LIB cl_headers)
21-set(CLANG_COMMAND $<TARGET_FILE:clang> )
22+if(USE_PREBUILT_LLVM)
23+ find_program(CLANG_COMMAND clang PATHS ${LLVM_TOOLS_BINARY_DIR})
24+else()
25+ set(CLANG_COMMAND $<TARGET_FILE:clang>)
26+endif()
27 if(LLVM_USE_HOST_TOOLS AND NOT OPENCL_CLANG_BUILD_EXTERNAL)
28 build_native_tool(clang CLANG_COMMAND)
29 endif()
30--
312.34.1
32
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch
deleted file mode 100644
index 8df7e3ab..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/files/0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From f3ef79a6301bab0b3a447f07ceb94c39a95009df Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 2 Apr 2020 08:59:20 +0800
4Subject: [PATCH] don't redefine LLVM_TABLEGEN_EXE
5
6Use the value that has been passed by the user.
7
8Upstream-Status: Submitted
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10---
11 CMakeLists.txt | 5 ++++-
12 1 file changed, 4 insertions(+), 1 deletion(-)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index 6893e97..941b0ae 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -137,7 +137,10 @@ endif(NOT USE_PREBUILT_LLVM)
19 set (COMPILE_OPTIONS_TD opencl_clang_options.td)
20 set (COMPILE_OPTIONS_INC opencl_clang_options.inc)
21
22-set(LLVM_TABLEGEN_EXE "llvm-tblgen")
23+if(NOT DEFINED LLVM_TABLEGEN_EXE)
24+ set(LLVM_TABLEGEN_EXE "llvm-tblgen")
25+endif()
26+
27 set(LLVM_TARGET_DEFINITIONS ${COMPILE_OPTIONS_TD})
28 if(USE_PREBUILT_LLVM)
29 set(TABLEGEN_ADDITIONAL -I ${LLVM_INCLUDE_DIRS})
30--
312.25.1
32
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc
index 1d9b4d51..0886e43b 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc
@@ -16,9 +16,4 @@ DEPENDS:append:class-target = " opencl-clang-native"
16COMPATIBLE_HOST = '(x86_64).*-linux' 16COMPATIBLE_HOST = '(x86_64).*-linux'
17COMPATIBLE_HOST:libc-musl = "null" 17COMPATIBLE_HOST:libc-musl = "null"
18 18
19do_install:append:class-native() {
20 install -d ${D}${bindir}
21 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
22}
23
24BBCLASSEXTEND = "native nativesdk" 19BBCLASSEXTEND = "native nativesdk"
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
index d0b2acfb..6cab99c2 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
@@ -10,3 +10,8 @@ EXTRA_OECMAKE += "\
10 -DCMAKE_SKIP_RPATH=TRUE \ 10 -DCMAKE_SKIP_RPATH=TRUE \
11 -DPREFERRED_LLVM_VERSION="12.0.0" \ 11 -DPREFERRED_LLVM_VERSION="12.0.0" \
12 " 12 "
13
14do_install:append:class-native() {
15 install -d ${D}${bindir}
16 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
17}
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb
index 367ca7e9..2af08f39 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_14.0.0.bb
@@ -1,8 +1,8 @@
1require opencl-clang.inc 1require opencl-clang.inc
2 2
3SRC_URI:append = " file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ 3SRC_URI:append = " file://0001-Fix-standalone-build-415.patch \
4 " 4 "
5SRCREV = "06c7c0d7f5cbd13810d79489a533fa6c5b6c7d9f" 5SRCREV = "cf95b338d14685e4f3402ab1828bef31d48f1fd6"
6 6
7BRANCH = "ocl-open-140" 7BRANCH = "ocl-open-140"
8 8
@@ -13,3 +13,8 @@ EXTRA_OECMAKE += "\
13 -DCMAKE_SKIP_RPATH=TRUE \ 13 -DCMAKE_SKIP_RPATH=TRUE \
14 -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \ 14 -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \
15 " 15 "
16
17do_install:append:class-native() {
18 install -d ${D}${bindir}
19 install -m 0755 ${B}/bin/linux_resource_linker ${D}${bindir}/
20}