summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2023-05-19 15:48:46 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-05-19 17:39:59 +0800
commit2da4523e0861e9a246338c645bf3115033176e7f (patch)
tree02e426269afcbb6d70d2cc2b2c2203a0e5fe795e
parenta19fda659afc05b7767d7e3adaefd0c0610a055c (diff)
downloadmeta-intel-2da4523e0861e9a246338c645bf3115033176e7f.tar.gz
openvkl: disable avx ISAs for intel-corei7-64 machine
It enables them by default instead of checking based on what is supported. openvklTest throws following error: SIGILL - Illegal instruction signal Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> (cherry picked from commit 2b37e2a69cfe0a46c3f52c7f333a9a60b03dcdc3) Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.2.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.2.0.bb b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.2.0.bb
index 4691b07f..2f581639 100644
--- a/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.2.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-oneapi/openvkl/openvkl_1.2.0.bb
@@ -30,6 +30,12 @@ DEPENDS = "ispc-native rkcommon embree"
30EXTRA_OECMAKE += " \ 30EXTRA_OECMAKE += " \
31 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \ 31 -DISPC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/ispc \
32 " 32 "
33EXTRA_OECMAKE:intel-corei7-64 += " \
34 -DOPENVKL_ISA_AVX=OFF \
35 -DOPENVKL_ISA_AVX2=OFF \
36 -DOPENVKL_ISA_AVX512SKX=OFF \
37 "
38
33PACKAGES =+ "${PN}-examples" 39PACKAGES =+ "${PN}-examples"
34FILES:${PN}-examples = "\ 40FILES:${PN}-examples = "\
35 ${bindir} \ 41 ${bindir} \