summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-04-13 00:04:02 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-04-13 14:11:39 +0800
commit20ee2c142f3e3379543bc893fd778832ac5b1ca1 (patch)
tree8d1a66b280258330b3dd1c5844e479148ace153c
parent2fbf1ec742e0196f16fd4f85f36f61a1c573b61a (diff)
downloadmeta-intel-20ee2c142f3e3379543bc893fd778832ac5b1ca1.tar.gz
open-model-zoo: upgrade 2021.4.2 -> 2022.1
The project now is able to locate the required package and libraries correctly so no need to pass flags to cmake. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch16
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.4.2.bb66
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2022.1.bb54
3 files changed, 61 insertions, 75 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
index 6d0c6cbc..3db0a31e 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
@@ -1,4 +1,4 @@
1From 247a5383e7ae444fd99022a19fe90a59dbedbc98 Mon Sep 17 00:00:00 2001 1From e071d6a6323f04dc7e6e40047199e509536d7f6e Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Mon, 30 Aug 2021 17:54:17 +0800 3Date: Mon, 30 Aug 2021 17:54:17 +0800
4Subject: [PATCH] demos: use gflags from meta-oe 4Subject: [PATCH] demos: use gflags from meta-oe
@@ -7,23 +7,21 @@ Upstream-Status: Inappropriate
7 7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> 9Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
10
10--- 11---
11 demos/CMakeLists.txt | 2 +- 12 demos/CMakeLists.txt | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-) 13 1 file changed, 1 insertion(+), 1 deletion(-)
13 14
14diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt 15diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt
15index 1df8f248d..d368d608c 100644 16index 98de0db6c..077d43fb4 100644
16--- a/demos/CMakeLists.txt 17--- a/demos/CMakeLists.txt
17+++ b/demos/CMakeLists.txt 18+++ b/demos/CMakeLists.txt
18@@ -131,7 +131,7 @@ find_package(OpenCV REQUIRED COMPONENTS core highgui videoio imgproc imgcodecs g 19@@ -140,7 +140,7 @@ endmacro()
19 find_package(InferenceEngine REQUIRED) 20 find_package(OpenCV REQUIRED COMPONENTS core highgui videoio imgproc imgcodecs gapi)
20 find_package(ngraph REQUIRED) 21 find_package(OpenVINO REQUIRED COMPONENTS Runtime)
21 22
22-add_subdirectory(thirdparty/gflags) 23-add_subdirectory(thirdparty/gflags)
23+#add_subdirectory(thirdparty/gflags) 24+#add_subdirectory(thirdparty/gflags)
24 add_subdirectory(common/cpp) 25 add_subdirectory(common/cpp)
26 add_subdirectory(common/cpp_gapi)
25 add_subdirectory(multi_channel_common/cpp) 27 add_subdirectory(multi_channel_common/cpp)
26
27--
282.17.1
29
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.4.2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.4.2.bb
deleted file mode 100644
index 5c410db4..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.4.2.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Open Model Zoo repository"
2HOMEPAGE = "https://github.com/opencv/open_model_zoo"
3DESCRIPTION = "This repository includes optimized deep learning \
4models and a set of demos to expedite development of high-performance \
5deep learning inference applications."
6
7SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=https;branch=master \
8 file://0001-use-oe-gflags.patch \
9 "
10
11SRCREV = "0d7aeac5eacdd343fdf9b375a23b7ec9a3846002"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
15"
16
17inherit cmake
18
19S = "${WORKDIR}/git"
20OECMAKE_SOURCEPATH = "${S}/demos"
21
22DEPENDS += "openvino-inference-engine opencv gflags"
23
24RDEPENDS:${PN} += " \
25 python3-decorator \
26 python3-defusedxml \
27 python3-networkx \
28 python3-protobuf \
29 python3-requests \
30 python3-pyyaml \
31 python3-numpy \
32 bash \
33"
34
35COMPATIBLE_HOST = '(x86_64).*-linux'
36COMPATIBLE_HOST:libc-musl = "null"
37
38EXTRA_OECMAKE += " \
39 -DIE_MAIN_SOURCE_DIR=${B} \
40 -DENABLE_SAMPLES=ON \
41 -DIE_INCLUDE_DIR=${STAGING_EXECPREFIXDIR} \
42 -DIE_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine.so \
43 -DIE_C_API_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_c_api.so \
44 -DIE_LEGACY_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_legacy.so \
45 -DIE_NN_BUILDER_RELEASE_LIBRARY=${STAGING_LIBDIR}/libinference_engine_nn_builder.so \
46 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \
47"
48
49do_configure:prepend(){
50 mkdir -p ${WORKDIR}/InferenceEngine/share
51 cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/
52}
53
54do_install(){
55 install -d ${D}${libdir}
56 install -d ${D}${bindir}
57 install -d ${D}${datadir}/openvino/open-model-zoo/tools
58 install -d ${D}${datadir}/openvino/open-model-zoo/demos
59 cp -rf ${WORKDIR}/build/intel64/Release/lib/*.a ${D}${libdir}
60 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir}
61 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo
62 cp -rf ${WORKDIR}/git/demos ${D}${datadir}/openvino/open-model-zoo
63 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools
64}
65
66FILES:${PN} += "${datadir}/openvino"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2022.1.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2022.1.bb
new file mode 100644
index 00000000..d21b2968
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2022.1.bb
@@ -0,0 +1,54 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Open Model Zoo repository"
2HOMEPAGE = "https://github.com/opencv/open_model_zoo"
3DESCRIPTION = "This repository includes optimized deep learning \
4models and a set of demos to expedite development of high-performance \
5deep learning inference applications."
6
7SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=https;branch=releases/2022/1 \
8 file://0001-use-oe-gflags.patch \
9 "
10
11SRCREV = "cf9003a95ddb742aabea341aa1573c3fa25ebbe1"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
15"
16
17inherit cmake
18
19S = "${WORKDIR}/git"
20OECMAKE_SOURCEPATH = "${S}/demos"
21
22DEPENDS += "openvino-inference-engine opencv gflags"
23
24RDEPENDS:${PN} += " \
25 python3-decorator \
26 python3-defusedxml \
27 python3-networkx \
28 python3-protobuf \
29 python3-requests \
30 python3-pyyaml \
31 python3-numpy \
32 bash \
33"
34
35COMPATIBLE_HOST = '(x86_64).*-linux'
36COMPATIBLE_HOST:libc-musl = "null"
37
38EXTRA_OECMAKE += " \
39 -DENABLE_SAMPLES=ON \
40 "
41
42do_install(){
43 install -d ${D}${libdir}
44 install -d ${D}${bindir}
45 install -d ${D}${datadir}/openvino/open-model-zoo/tools
46 install -d ${D}${datadir}/openvino/open-model-zoo/demos
47 cp -rf ${WORKDIR}/build/intel64/Release/*.a ${D}${libdir}
48 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir}
49 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo
50 cp -rf ${WORKDIR}/git/demos ${D}${datadir}/openvino/open-model-zoo
51 cp -rf ${WORKDIR}/git/tools/model_tools ${D}${datadir}/openvino/open-model-zoo/tools
52}
53
54FILES:${PN} += "${datadir}/openvino"