summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-03-09 20:38:30 -0800
committerSaul Wold <sgw@linux.intel.com>2016-03-10 09:23:09 -0800
commit8c15de8dbaa1414ffd0f69bea7227e7285816f85 (patch)
treed2c28dd495369f74f5f8bbf73f1a1fd1a34da5c7
parent822b3faa3e82853dac695193f567fc3d8f7ebea0 (diff)
downloadmeta-intel-8c15de8dbaa1414ffd0f69bea7227e7285816f85.tar.gz
linux-yocto/4.1: Update to Linux 4.1.18
This SRCREV update also includes the fix to CVE-2016-0728. An intermittent graphics bug that appears to be harmless besides spamming dmesg has been observed on this release, but it is very rare and no method to reproduce or patch to fix it has been found. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend18
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend6
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend18
3 files changed, 21 insertions, 21 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
index a0e2ef42..c3709cdc 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
@@ -1,25 +1,25 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_core2-32-intel-common = "4.1.8" 3LINUX_VERSION_core2-32-intel-common = "4.1.18"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5SRCREV_meta_core2-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b" 5SRCREV_meta_core2-32-intel-common = "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
6SRCREV_machine_core2-32-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e" 6SRCREV_machine_core2-32-intel-common = "2a4c22b03d434f7695e607b6ad30f77671985a6d"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base" 8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base"
9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11LINUX_VERSION_corei7-64-intel-common = "4.1.8" 11LINUX_VERSION_corei7-64-intel-common = "4.1.18"
12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
13SRCREV_meta_corei7-64-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b" 13SRCREV_meta_corei7-64-intel-common = "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
14SRCREV_machine_corei7-64-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e" 14SRCREV_machine_corei7-64-intel-common = "2a4c22b03d434f7695e607b6ad30f77671985a6d"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base" 16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base"
17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18 18
19LINUX_VERSION_i586-nlp-32-intel-common = "4.1.8" 19LINUX_VERSION_i586-nlp-32-intel-common = "4.1.18"
20COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 20COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
21SRCREV_meta_i586-nlp-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b" 21SRCREV_meta_i586-nlp-32-intel-common = "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
22SRCREV_machine_i586-nlp-32-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e" 22SRCREV_machine_i586-nlp-32-intel-common = "2a4c22b03d434f7695e607b6ad30f77671985a6d"
23KMACHINE_i586-nlp-32-intel-common = "intel-corei7-64" 23KMACHINE_i586-nlp-32-intel-common = "intel-corei7-64"
24KBRANCH_i586-nlp-32-intel-common = "standard/preempt-rt/base" 24KBRANCH_i586-nlp-32-intel-common = "standard/preempt-rt/base"
25KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 25KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
index d2a1c3c8..aed3e6e4 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
@@ -1,9 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3#LINUX_VERSION_i586-nlp-32-intel-common = "4.1.2" 3#LINUX_VERSION_i586-nlp-32-intel-common = "4.1.18"
4COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 4COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
5SRCREV_meta-nlp-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b" 5SRCREV_meta-nlp-32-intel-common = "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
6SRCREV_machine-nlp-32-intel-common = "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 6SRCREV_machine-nlp-32-intel-common = "ec18b0b3bd6befd416078e81d775dab37b3f9124"
7KBRANCH_i586-nlp-32-intel-common = "standard/tiny/common-pc" 7KBRANCH_i586-nlp-32-intel-common = "standard/tiny/common-pc"
8KMACHINE_i586-nlp-32-intel-common = "intel-quark" 8KMACHINE_i586-nlp-32-intel-common = "intel-quark"
9KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index c8d24934..b9736b3d 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -2,29 +2,29 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5LINUX_VERSION_core2-32-intel-common = "4.1.8" 5LINUX_VERSION_core2-32-intel-common = "4.1.18"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/base" 8KBRANCH_core2-32-intel-common = "standard/base"
9SRCREV_meta_core2-32-intel-common ?= "cf9ab7112dd8b7fe02739a76e24ba32e87b91306" 9SRCREV_meta_core2-32-intel-common ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
10SRCREV_machine_core2-32-intel-common ?= "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 10SRCREV_machine_core2-32-intel-common ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12 12
13LINUX_VERSION_corei7-64-intel-common = "4.1.8" 13LINUX_VERSION_corei7-64-intel-common = "4.1.18"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/base" 16KBRANCH_corei7-64-intel-common = "standard/base"
17SRCREV_meta_corei7-64-intel-common ?= "cf9ab7112dd8b7fe02739a76e24ba32e87b91306" 17SRCREV_meta_corei7-64-intel-common ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
18SRCREV_machine_corei7-64-intel-common ?= "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 18SRCREV_machine_corei7-64-intel-common ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20 20
21# Quark / X1000 BSP Info 21# Quark / X1000 BSP Info
22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.8" 22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.18"
23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
24KMACHINE_i586-nlp-32-intel-common = "intel-quark" 24KMACHINE_i586-nlp-32-intel-common = "intel-quark"
25KBRANCH_i586-nlp-32-intel-common = "standard/base" 25KBRANCH_i586-nlp-32-intel-common = "standard/base"
26SRCREV_meta_i586-nlp-32-intel-common ?= "cf9ab7112dd8b7fe02739a76e24ba32e87b91306" 26SRCREV_meta_i586-nlp-32-intel-common ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
27SRCREV_machine_i586-nlp-32-intel-common ?= "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 27SRCREV_machine_i586-nlp-32-intel-common ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
28KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" 28KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
29 29
30 30