summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRebecca Chang Swee Fun <rebecca.swee.fun.chang@intel.com>2016-11-03 16:20:56 +0800
committerSaul Wold <sgw@linux.intel.com>2016-11-08 13:34:16 -0800
commit8b8678c8894fb5a1b931862bbd9a581b54f40e32 (patch)
tree2c4dcc4ae50f47ca256c51db373520fbb31cfec4
parent3957e4d5044d16170ef52cc7ec6ea513c968137b (diff)
downloadmeta-intel-8b8678c8894fb5a1b931862bbd9a581b54f40e32.tar.gz
linux-yocto_4.1: use BSP_SUBTYPE for BSP specific configuration
Leaf Hill BSP has specific kernel configuration in yocto-kernel-cache for kernel v4.1. We found some issue where we can't overwrite the existing kernel configs in yocto-kernel-cache from developer's custom meta layer. Root cause analysis has shown that the usage of KERNEL_FEATURES in kernel recipes and local.conf to pick up BSP specific configs from kernel-meta is inappropriate. KERNEL_FEATURES should always and only used for adding configuration or features to the build. A new variable "BSP_SUBTYPE" has been created to resolve this issue. Suggested-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Rebecca Chang Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend8
-rw-r--r--conf/machine/intel-corei7-64.conf2
2 files changed, 5 insertions, 5 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index 48445d8b..e559e8ca 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -11,12 +11,12 @@ SRCREV_meta_core2-32-intel-common ?= "20edcbf4e42dd4cef7213a0ce2a4481d8d296f5d"
11SRCREV_machine_core2-32-intel-common ?= "9195020e5747fba069c19996fab079931584a7fb" 11SRCREV_machine_core2-32-intel-common ?= "9195020e5747fba069c19996fab079931584a7fb"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13 13
14LINUX_VERSION_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', '4.1.27', '4.1.26', d)}" 14LINUX_VERSION_corei7-64-intel-common = "${@bb.utils.contains('BSP_SUBTYPE', 'leafhill', '4.1.27', '4.1.26', d)}"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16KMACHINE_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'leafhill', 'intel-corei7-64', d)}" 16KMACHINE_corei7-64-intel-common = "${@bb.utils.contains('BSP_SUBTYPE', 'leafhill', 'leafhill', 'intel-corei7-64', d)}"
17KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'standard/intel/4.1.27/leaf-hill', 'standard/intel/base', d)}" 17KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('BSP_SUBTYPE', 'leafhill', 'standard/intel/4.1.27/leaf-hill', 'standard/intel/base', d)}"
18SRCREV_meta_corei7-64-intel-common ?= "68b5089eeffb5878a990d9eb418407c8e18a6f37" 18SRCREV_meta_corei7-64-intel-common ?= "68b5089eeffb5878a990d9eb418407c8e18a6f37"
19SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', '41fc98f785ad56f0df1b85ac039bd5e391697842', '9195020e5747fba069c19996fab079931584a7fb', d)}" 19SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('BSP_SUBTYPE', 'leafhill', '41fc98f785ad56f0df1b85ac039bd5e391697842', '9195020e5747fba069c19996fab079931584a7fb', d)}"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} \ 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} \
21 ${@bb.utils.contains('AUDIO_FEATURES', 'ssp', '${KERNEL_FEATURES_LEAFHILL_AUDIO}', '', d)}" 21 ${@bb.utils.contains('AUDIO_FEATURES', 'ssp', '${KERNEL_FEATURES_LEAFHILL_AUDIO}', '', d)}"
22 22
diff --git a/conf/machine/intel-corei7-64.conf b/conf/machine/intel-corei7-64.conf
index 305fd2f9..30e58fab 100644
--- a/conf/machine/intel-corei7-64.conf
+++ b/conf/machine/intel-corei7-64.conf
@@ -33,4 +33,4 @@ SYSLINUX_OPTS = "serial 0 115200"
33SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS0" 33SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS0"
34SERIAL_CONSOLES_CHECK = "ttyS2 ttyS0" 34SERIAL_CONSOLES_CHECK = "ttyS2 ttyS0"
35APPEND += "console=ttyS2,115200n8 console=ttyS0,115200 console=tty0" 35APPEND += "console=ttyS2,115200n8 console=ttyS0,115200 console=tty0"
36APPEND += "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'reboot=efi kmemleak=off i915.enable_ipc=1', '', d)}" 36APPEND += "${@bb.utils.contains('BSP_SUBTYPE', 'leafhill', 'reboot=efi kmemleak=off i915.enable_ipc=1', '', d)}"