diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2018-04-20 08:42:13 +0800 |
---|---|---|
committer | California Sullivan <california.l.sullivan@intel.com> | 2018-04-23 11:11:38 -0700 |
commit | 632399bb6f72910f8949f3b6da24e4ff8293224a (patch) | |
tree | 72775a26d464455eae2f3a94b9371a928409b85d | |
parent | d5699efd24fd6ac2476c0dbe1d733f40ea4f8d59 (diff) | |
download | meta-intel-fca33c8d21b71db0ca71b665bae1d7b76843b925.tar.gz |
ixgbevf: cleanup recipeyocto-2.5sumo-19.0.0
* Remove unnecessary code and include version info in recipe.
* Better description of the package and project page
* Change do_install to use S instead of WORKDIR. Using S would
fail when used with devtool that relies on externalsrc class.
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
5 files changed, 68 insertions, 101 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf.bb b/recipes-kernel/intel-ethernet/ixgbevf.bb deleted file mode 100644 index bb00e354..00000000 --- a/recipes-kernel/intel-ethernet/ixgbevf.bb +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE" | ||
2 | DESCRIPTION="Intel 10-Gbps Ethernet driver for Magnolia Park" | ||
3 | AUTHOR = "Ong Boon Leong" | ||
4 | HOMEPAGE = "http://www.intel.com/network/connectivity/products/server_adapters.htm" | ||
5 | SECTION = "kernel/network" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
8 | |||
9 | PV = "4.3.4" | ||
10 | PR = "r0" | ||
11 | |||
12 | SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/ixgbevf-${PV}.tar.gz \ | ||
13 | file://0001-ixgbevf-src-Makefile-change-make-install-to-make.patch \ | ||
14 | file://0002-ixgbevf_common.patch \ | ||
15 | file://0001-ixgbevf-skip-host-depmod.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "9459bf9ac4b2b827bee2ff147d192622" | ||
19 | SRC_URI[sha256sum] = "63a6568be16347e19bae74238d739cd7ffa83a6236c6d8e25d2539d46cb25f88" | ||
20 | |||
21 | S = "${WORKDIR}/${PN}-${PV}/src" | ||
22 | SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts" | ||
23 | |||
24 | EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" \ | ||
25 | BUILD_ARCH="${TARGET_ARCH}" PREFIX="${D}" \ | ||
26 | SYSTEM_MAP_FILE="${STAGING_KERNEL_BUILDDIR}/System.map-${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"' | ||
27 | |||
28 | KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf" | ||
29 | KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf" | ||
30 | |||
31 | inherit module | ||
32 | |||
33 | do_install_append () { | ||
34 | # Install scripts/set_irq_affinity | ||
35 | install -d ${D}/etc/network | ||
36 | install -m 0755 ${SCRIPT_DIR}/set_irq_affinity ${D}/etc/network | ||
37 | } | ||
38 | |||
39 | #SSTATE_DUPWHITELIST += "${STAGING_DIR_HOST}/lib/modules/${KERNEL_VERSION}/" | ||
40 | |||
41 | PACKAGES += "${PN}-script" | ||
42 | |||
43 | FILES_${PN}-script += "/etc/network/set_irq_affinity" | ||
44 | |||
45 | #Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped" | ||
46 | INSANE_SKIP_${PN} = "installed-vs-shipped" | ||
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch new file mode 100644 index 00000000..49a59496 --- /dev/null +++ b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From b1d7f46442e50458311573443a5c78637874f62b Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Thu, 12 Apr 2018 11:46:15 +0800 | ||
4 | Subject: [PATCH] Makefile: check for CONFIG_IXGBEVF instead | ||
5 | |||
6 | Check for the correct config, otherwise it won't build with kbuild. | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
11 | --- | ||
12 | src/Makefile | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/Makefile b/Makefile | ||
16 | index 968ef5e..e3cb81b 100644 | ||
17 | --- a/Makefile | ||
18 | +++ b/Makefile | ||
19 | @@ -28,7 +28,7 @@ ifneq ($(KERNELRELEASE),) | ||
20 | # Makefile for the Intel(R) 10GbE PCI Express Virtual Function Driver | ||
21 | # | ||
22 | |||
23 | -obj-$(CONFIG_IXGBE) += ixgbevf.o | ||
24 | +obj-$(CONFIG_IXGBEVF) += ixgbevf.o | ||
25 | |||
26 | define ixgbevf-y | ||
27 | ixgbevf_main.o | ||
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch deleted file mode 100644 index 8234f589..00000000 --- a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 511ee0d8d40a3e76b3e9875a96228ff370dbdfc6 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Goh, Wen Sen" <wen.sen.goh@intel.com> | ||
3 | Date: Wed, 22 Jun 2016 11:25:41 +0800 | ||
4 | Subject: [PATCH] ixgbevf_patch | ||
5 | |||
6 | --- | ||
7 | Makefile | 4 ++-- | ||
8 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
9 | |||
10 | diff --git a/Makefile b/Makefile | ||
11 | index 8df134a..8d5660e 100644 | ||
12 | --- a/Makefile | ||
13 | +++ b/Makefile | ||
14 | @@ -100,7 +100,7 @@ clean: | ||
15 | @-rm -rf *.${MANSECTION}.gz *.ko | ||
16 | |||
17 | # Install the modules and manpage | ||
18 | -install: default manfile | ||
19 | +modules_install: default manfile | ||
20 | @echo "Copying manpages..." | ||
21 | @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz | ||
22 | @echo "Installing modules..." | ||
23 | @@ -145,6 +145,6 @@ help: | ||
24 | @echo ' Other variables may be available for tuning make process, see' | ||
25 | @echo ' Kernel Kbuild documentation for more information' | ||
26 | |||
27 | -.PHONY: default noisy clean manfile silent sparse ccc install uninstall help | ||
28 | +.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help | ||
29 | |||
30 | endif # ifneq($(KERNELRELEASE),) | ||
31 | -- | ||
32 | 2.8.3 | ||
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch b/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch deleted file mode 100644 index d442e24d..00000000 --- a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | From f74fbcd821a394dec58263fd2c2ea62eae298b2f Mon Sep 17 00:00:00 2001 | ||
2 | From: "Goh, Wen Sen" <wen.sen.goh@intel.com> | ||
3 | Date: Sun, 26 Jun 2016 12:01:36 +0800 | ||
4 | Subject: [PATCH] ixgbevf patch | ||
5 | |||
6 | --- | ||
7 | common.mk | 1 + | ||
8 | 1 file changed, 1 insertion(+) | ||
9 | |||
10 | diff --git a/common.mk b/common.mk | ||
11 | index b9b01c7..228a926 100644 | ||
12 | --- a/common.mk | ||
13 | +++ b/common.mk | ||
14 | @@ -289,6 +289,7 @@ export INSTALL_MOD_DIR ?= updates/drivers/net/ethernet/intel/${DRIVER} | ||
15 | kernelbuild = ${MAKE} $(if ${GCC_I_SYS},CC="${GCC_I_SYS}") \ | ||
16 | ${CCFLAGS_VAR}="${EXTRA_CFLAGS}" \ | ||
17 | -C "${KSRC}" \ | ||
18 | + CONFIG_IXGBE=m \ | ||
19 | CONFIG_${DRIVER_UPPERCASE}=m \ | ||
20 | M="${CURDIR}" \ | ||
21 | ${2} ${1}; | ||
22 | -- | ||
23 | 2.8.3 | ||
diff --git a/recipes-kernel/intel-ethernet/ixgbevf_4.3.4.bb b/recipes-kernel/intel-ethernet/ixgbevf_4.3.4.bb new file mode 100644 index 00000000..9dc0aaf3 --- /dev/null +++ b/recipes-kernel/intel-ethernet/ixgbevf_4.3.4.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE" | ||
2 | DESCRIPTION="This virtual function driver supports kernel versions 2.6.x and newer \ | ||
3 | This driver supports 82599, X540, X550, and X552-based virtual function devices \ | ||
4 | that can only be activated on kernels that support SR-IOV. \ | ||
5 | SR-IOV requires the correct platform and OS support. \ | ||
6 | The guest OS loading this driver must support MSI-X interrupts." | ||
7 | |||
8 | HOMEPAGE = "https://sourceforge.net/projects/e1000/" | ||
9 | SECTION = "kernel/network" | ||
10 | LICENSE = "GPLv2" | ||
11 | LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
12 | |||
13 | SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/${BP}.tar.gz \ | ||
14 | file://0001-ixgbevf-skip-host-depmod.patch \ | ||
15 | file://0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[md5sum] = "9459bf9ac4b2b827bee2ff147d192622" | ||
19 | SRC_URI[sha256sum] = "63a6568be16347e19bae74238d739cd7ffa83a6236c6d8e25d2539d46cb25f88" | ||
20 | |||
21 | S = "${WORKDIR}/${BP}/src" | ||
22 | MODULES_INSTALL_TARGET = "install" | ||
23 | |||
24 | EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"' | ||
25 | |||
26 | KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf" | ||
27 | KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf" | ||
28 | |||
29 | inherit module | ||
30 | |||
31 | do_install_append () { | ||
32 | # Install scripts/set_irq_affinity | ||
33 | install -d ${D}${sysconfdir}/network | ||
34 | install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network | ||
35 | |||
36 | rm -rf ${D}${prefix}/man | ||
37 | } | ||
38 | |||
39 | PACKAGES += "${PN}-script" | ||
40 | |||
41 | FILES_${PN}-script += "${sysconfdir}/network/set_irq_affinity" | ||